By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,417 Members | 1,856 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,417 IT Pros & Developers. It's quick & easy.

Cannot shutdown W3SVC

P: n/a
Hi,

I've just installed ASP.NET 1.1 (I have previously been using 1.0).
Now I am unable to create a new asp.net application in VS.NET.

The problems is as follows.....
It appears that the W3SVC service is 'frozen' in ShutDown mode.

When I do a 'NET STOP W3SVC' from the command line I get the following error
"The service could not be stopped in it's present state. If the service is
starting, it cannot process requests until it is fully started"

If I go to 'Start | Administrative Tools | Services' I can see that the
'WebCLient' Service has its status as 'Stopping'.

I've tried to reboot - still has the same 'Stopping' status. I've tried to
add a new IIS Snap-in to a MMC window. None of these work.

Does anyone have any ideas as to how I can shutdown (and successfully
restart) this service? My hair is already receding but I feel that this is
going to turn me completely bald :).

Thanks in advance

John

Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
OK, found a way around this...

I ran the following from the Command Line

iisreset /stop
iisreset /start

The WebCLient service is still in 'Stopping' status though. Not sure why?


"JBMC" <SP**********************@hotmail.com> wrote in message
news:2g************@uni-berlin.de...
Hi,

I've just installed ASP.NET 1.1 (I have previously been using 1.0).
Now I am unable to create a new asp.net application in VS.NET.

The problems is as follows.....
It appears that the W3SVC service is 'frozen' in ShutDown mode.

When I do a 'NET STOP W3SVC' from the command line I get the following error "The service could not be stopped in it's present state. If the service is
starting, it cannot process requests until it is fully started"

If I go to 'Start | Administrative Tools | Services' I can see that the
'WebCLient' Service has its status as 'Stopping'.

I've tried to reboot - still has the same 'Stopping' status. I've tried to add a new IIS Snap-in to a MMC window. None of these work.

Does anyone have any ideas as to how I can shutdown (and successfully
restart) this service? My hair is already receding but I feel that this is
going to turn me completely bald :).

Thanks in advance

John

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.