By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,230 Members | 2,471 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,230 IT Pros & Developers. It's quick & easy.

Running ASP.NET from Another Directory

P: n/a
Sorry for the cross-post as I am not sure which group to post this question
to. I am trying to run an ASP.NET application in IIS 6.0. If I have my
application in the c:\inetpub\wwwroot\app1\ directory, which the Default
Website is pointing to, the application works. However, if I create a new
Website and point it to d:\IIS\sites\app1\ it does not work.

I checked the permissions on the c:\inetpub\wwwroot\ directory and the it
was the following:

-IUSR_SERVER - Explicit "Deny Write"
-IIS_WPG - Read Access
-Administrators - Full Control
-SYSTEM - Full Control
-CREATOR OWNER - No Permissions

I set the permissions on d:\IIS\sites\ to the same as c:\inetpub\wwwroot\
and the application still did not work. I kept getting the page pasted at
the end of this message. However when I set the permission on d:\IIS\sites\
to Everyone - Full Control the .aspx page loads successfully. I obviousely
do not want to do that so I am hoping someone has a better suggestion.

Shahir Ahang

Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
> Sorry for the cross-post as I am not sure which group to post this
question
to.


It doesn't belong in asp.general, which is for "classic" ASP...
Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.