By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,569 Members | 1,321 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,569 IT Pros & Developers. It's quick & easy.

Fatal Execution Engine Error (0 x 7924b50b)

P: n/a
[ NOTE: This is a duplicate posting from VS.NET General group. It's been a
couple days with no solution garnered yet in that group and I'm hoping
there is another set of viewers here who may have experience with this. It
appears there is more activity in this group. I hope this additional
posting is acceptable. I'm trying to avooid a complete reinstallation!]

1. Getting above when try to open any aspx.files in VS.Net 2003. OS is
Server
2003.
2. No apparent entry in Event Viewer either by time of error.

3. CLR debugger breaks at followinng point:
Microsoft.VSDesigner.WebForms.ElementBehaviorFacto ry.Microsoft.VSDesigner.In
terop.Trident.IElementBehaviorFactory._FindBehavio r

4. Problem does not appear to be in my apps because

A. Everything had been working for months.

B. Occurs when tryinng to open any file in any app's aspx. Files open
When click through debugging steps and then exit, VS.NET 2003
closes.

C. Apps will build and run on problem machine.

D. Same files copied to another machine open normally in Designer mode.

5. The entries in Google and MSKB on Fatal Execution Engine Error have
different
error numbers and seem to be more app or initial installation releated.
Has anyone seen this before?

Thanks.

Alan

Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Alan,

I get the same error message with Windows XP Visual Studio .NET 2003.

I have reinstalled Visual Studio .NET 2003 but this is of no avail.

Were you able to resolve the problem? If so, could you please help me
out?

Thanks,
-Sankar

Nov 19 '05 #2

P: n/a
Sankar wrote:
Hi Alan,

I get the same error message with Windows XP Visual Studio .NET 2003.

I have reinstalled Visual Studio .NET 2003 but this is of no avail.

Were you able to resolve the problem? If so, could you please help me
out?

Thanks,
-Sankar
I just started seeing this "Fatal Execution Engine Error (0x7924c982)"
in all my applications whenever using the Designer. Create a new Web
project, add a button, and I get this fault.

Debugging show' this at the top of the call stack:
microsoft.vsdesigner.dll!Microsoft.VSDesigner.WebF orms.ElementBehaviorFactory.Microsoft.VSDesigner.I nterop.Trident.IElementBehaviorFactory._FindBehavi or(string

pchBehaviorName, string pchBehaviorUrl, System.Object pUnkSite) + 0x24
bytes

This is called by mshtml.dll and the first two arguments are NULL
Any ideas ?

-scott

Nov 19 '05 #3

P: n/a
Scott,

I could resolve this problem using the standard Microsoft techniques:-(

1). Uninstalled Infragistics (I dont believe Infragistics has got
anything to do with it. I just wanted to be safe.)
2). Uninstalled .NET Visual Studio
3). Uniinstalled .NET Framework

Reinstalled all the above in the reverse order.

The problem went away.

Unless the behavior that you are observing is something specific to the
calling application, I would recommend the same.
It seems to me that what you are doing is fairly innoccous though.
Sorry I dont have a better explanation.

-Sankar

Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.