By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,886 Members | 1,107 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,886 IT Pros & Developers. It's quick & easy.

userName=System & aspnet_wp.exe could not be launched

P: n/a

I am getting the message below in the event log. This is a development
machine running Windows 2000 Pro.
I have changed userName from machine to SYSTEM in machine.config. I gave
EVERYONE group full control to Microsoft.Net folder and wwwroot which
contains my app. I used filemon from sysinternals to find what is causing
the permission problem but filemon doesn't report anything related to IIS.
I reinstalled the d.net framework and rebooted.
This is frustrating!
aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that
the .NET Framework is correctly installed and that the ACLs on the
installation directory allow access to the configured account.

J.
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I simply rerun the Dot Net Framework 1.1 and the problem is resolved for
same error message.

However, it is weired that Microsoft sold the product with bugs (nothing new
or wrong though!!) and they are not offering the patch publicly to download.

Command used to run the dotnetfx:

d:\dotNetFramework\dotnetfx.exe /t:%temp% /c:"msiexec.exe /fvecms
%temp%\netfx.msi"

Note: Replace the drive letter d: to the drive letter of the CD-ROM.

Thanks,
Prodip

"John Dalberg" <jo*****@hotmail.com> wrote in message
news:1l*****************************@40tude.net...

I am getting the message below in the event log. This is a development
machine running Windows 2000 Pro.
I have changed userName from machine to SYSTEM in machine.config. I gave
EVERYONE group full control to Microsoft.Net folder and wwwroot which
contains my app. I used filemon from sysinternals to find what is causing
the permission problem but filemon doesn't report anything related to IIS.
I reinstalled the d.net framework and rebooted.
This is frustrating!
aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that
the .NET Framework is correctly installed and that the ACLs on the
installation directory allow access to the configured account.

J.

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.