By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,948 Members | 1,958 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,948 IT Pros & Developers. It's quick & easy.

Deploy error on Remote Server

P: n/a
Hi,

I am getting message shown below when I tested a simple web application on
production Remote Server which has ASP.net
enabled for IIS.

Please advise!

I have tried the resolution provided and even used trace enabled but message
still comes while
the application runs fine on local computer.

Imran Saroia

Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Change you web.config file to contain

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Instead of:
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>

This should give you a more detailed error message. Let me know what that
message is.

"IMRAN SAROIA" <im*************@hotmail.com> wrote in message
news:Og**************@TK2MSFTNGP11.phx.gbl...
Hi,

I am getting message shown below when I tested a simple web application on
production Remote Server which has ASP.net
enabled for IIS.

Please advise!

I have tried the resolution provided and even used trace enabled but message still comes while
the application runs fine on local computer.

Imran Saroia

Server Error in '/' Application.
-------------------------------------------------------------------------- -- ----

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web>
</configuration>

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.