By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,640 Members | 1,581 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,640 IT Pros & Developers. It's quick & easy.

SmartNavigation hosed in default web folder

P: n/a
I've deployed a web forms app to IIS 6/Server 2003 Ent. If my web folder is designated as the default web folder, SmartNavigation doesn't work. All pages with SN enabled render blank pages. If the the app is located in a sub folder under the the default web site, SN works fine. This is a problem because I have to redirect from the root folder which is mapped to our domain name. This caused the IP address to show up in the user's address bar rather than the domain name

I'd like the app to exist at the root folder and for users to see our domain name.
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Make sure you have the aspnet_client folder under the root and that the
SmartNavigation script file is somewhere in that folder.

"Paul T" <an*******@discussions.microsoft.com> wrote in message
news:5A**********************************@microsof t.com...
I've deployed a web forms app to IIS 6/Server 2003 Ent. If my web folder is designated as the default web folder, SmartNavigation doesn't work. All
pages with SN enabled render blank pages. If the the app is located in a
sub folder under the the default web site, SN works fine. This is a problem
because I have to redirect from the root folder which is mapped to our
domain name. This caused the IP address to show up in the user's address
bar rather than the domain name.
I'd like the app to exist at the root folder and for users to see our

domain name.
Nov 18 '05 #2

P: n/a
Thanks! That did it.
Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.