By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,805 Members | 1,273 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,805 IT Pros & Developers. It's quick & easy.

Error running project with subfolder web.config

P: n/a
Hi all,

I'm working through examples on configuring ASP.NET (all on local machine).
The first exercise deals with the customErrors in the config files. The
machine.config file has a customErrors mode set to RemoteOnly and the
application's web.config has it set to On with a redirect for a 404 error.
This works fine.

However, when I add a subfolder to the application and place a web.config
file in there (from the IDE so I'm not just manually introducing typos) then
run, I get the error:

Error while trying to run project: Unable to start debugging on the web
server. Server side-error occurred on sending debug HTTP request.

It continues to happen whether I leave the subfolder's web.config alone or
change the customErrors setting. The <CustomErrors> element of the
machine.config's <configSection> does not specify any allowDefinition
restrictions (which I'm told would default to allowing "sub-configs"
anywhere).

Any idea where to look next?

TIA,

John
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Not all of the sections are allowed in subfolders. Use only what you need.

"John Spiegel" <js******@YETANOTHERSPAMHATERc-comld.com> wrote in message
news:eM**************@tk2msftngp13.phx.gbl...
Hi all,

I'm working through examples on configuring ASP.NET (all on local machine). The first exercise deals with the customErrors in the config files. The
machine.config file has a customErrors mode set to RemoteOnly and the
application's web.config has it set to On with a redirect for a 404 error.
This works fine.

However, when I add a subfolder to the application and place a web.config
file in there (from the IDE so I'm not just manually introducing typos) then run, I get the error:

Error while trying to run project: Unable to start debugging on the web
server. Server side-error occurred on sending debug HTTP request.

It continues to happen whether I leave the subfolder's web.config alone or
change the customErrors setting. The <CustomErrors> element of the
machine.config's <configSection> does not specify any allowDefinition
restrictions (which I'm told would default to allowing "sub-configs"
anywhere).

Any idea where to look next?

TIA,

John

Nov 18 '05 #2

P: n/a
Thanks, Rick.

Sounds more plausible than anything I've come up with!

"Rick Spiewak" <ri*********@mindspring.com> wrote in message
news:eR*************@TK2MSFTNGP10.phx.gbl...
Not all of the sections are allowed in subfolders. Use only what you need.

"John Spiegel" <js******@YETANOTHERSPAMHATERc-comld.com> wrote in message
news:eM**************@tk2msftngp13.phx.gbl...
Hi all,

I'm working through examples on configuring ASP.NET (all on local

machine).
The first exercise deals with the customErrors in the config files. The
machine.config file has a customErrors mode set to RemoteOnly and the
application's web.config has it set to On with a redirect for a 404 error. This works fine.

However, when I add a subfolder to the application and place a web.config file in there (from the IDE so I'm not just manually introducing typos)

then
run, I get the error:

Error while trying to run project: Unable to start debugging on the web
server. Server side-error occurred on sending debug HTTP request.

It continues to happen whether I leave the subfolder's web.config alone or change the customErrors setting. The <CustomErrors> element of the
machine.config's <configSection> does not specify any allowDefinition
restrictions (which I'm told would default to allowing "sub-configs"
anywhere).

Any idea where to look next?

TIA,

John


Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.