468,133 Members | 1,187 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,133 developers. It's quick & easy.

ADODB.connection safety settings error

Hi All,
I'm running a webpage-application where, in a aspx-page,a udl is called in
vbscript
in an xsl-stylesheet to access a database. When I want to execute this, I
receive
following error

ADODB.Connection Safety settings on this computer prohibit accessing a data
source on
another domain.

There is nothing wrong with the udl cause "test connection" succeeded.
Also the vbscript-code I use to call the udl works.

I've tried to use Windows Authentication and SQL Server Authentication for
the connection
and it doesn't work.

I've also put <identity impersonate="true"> in my web.config to make sure
that I was running
the application and not the ASP.NET client
Could anyone please help me?
Thanks in advance
Steven Baeten
Nov 18 '05 #1
1 1893
Instead of using a UDL, you can place your connection string in the
Web.config file using the
System.Configuration.ConfigurationSettings.AppSett ings property. The
web.config section looks like this:

<configuration>
<appSettings>
<add key="ConnectionString" value="connection string here" />
</appSettings>
</configuration>

The code looks like this:

Dim str as String = _
ConfigurationSettings.AppSettings("ConnectionStrin g")

--Mary

On Fri, 7 May 2004 14:05:28 +0200, "Steven Baeten"
<st***********@hotmail.com> wrote:
Hi All,
I'm running a webpage-application where, in a aspx-page,a udl is called in
vbscript
in an xsl-stylesheet to access a database. When I want to execute this, I
receive
following error

ADODB.Connection Safety settings on this computer prohibit accessing a data
source on
another domain.

There is nothing wrong with the udl cause "test connection" succeeded.
Also the vbscript-code I use to call the udl works.

I've tried to use Windows Authentication and SQL Server Authentication for
the connection
and it doesn't work.

I've also put <identity impersonate="true"> in my web.config to make sure
that I was running
the application and not the ASP.NET client
Could anyone please help me?
Thanks in advance
Steven Baeten


Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Andre Azevedo | last post: by
reply views Thread by ASP.Confused | last post: by
3 posts views Thread by Yuk Tang | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.