By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,650 Members | 1,778 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,650 IT Pros & Developers. It's quick & easy.

Help: Runtime error

P: n/a
If I try ANY aspx pages on my server, even INVALID, bogus pages, I get a
"Runtime Error". Any idea why?

Here is the full message:
Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 18 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
this error occurs when you are accessing the page from remote machines..try
it from the local system (i mean on your server). you will get exact error.

you can also change your web.config to <customErrors mode="Off"/> (thats
what the error says).

Av.

"VB Programmer" <Ro************************@juno.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
If I try ANY aspx pages on my server, even INVALID, bogus pages, I get a
"Runtime Error". Any idea why?

Here is the full message:
Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could,
however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable
on remote machines, please create a <customErrors> tag within a
"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 18 '05 #2

P: n/a
On the server itself the page shows up as normal HTML, with no buttons, text
boxes, etc...

I ran aspnet_regiis -i but this didn't help.

Please help!

Thanks.
"avnrao" <av*@newsgroups.com> wrote in message
news:uG**************@TK2MSFTNGP11.phx.gbl...
this error occurs when you are accessing the page from remote machines..try it from the local system (i mean on your server). you will get exact error.
you can also change your web.config to <customErrors mode="Off"/> (thats
what the error says).

Av.

"VB Programmer" <Ro************************@juno.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
If I try ANY aspx pages on my server, even INVALID, bogus pages, I get a
"Runtime Error". Any idea why?

Here is the full message:
Server Error in '/' Application.


--------------------------------------------------------------------------

--
----

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,
however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable
on remote machines, please create a <customErrors> tag within a
"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Nov 18 '05 #3

P: n/a
check if your IIS has .aspx and .ascx extensions mapped to the respective
isapi dlls. (properties->virtualdirectory tab-> configuration)
after running aspnet_regiis, you need to restart iis.

Av
"VB Programmer" <Ro************************@juno.com> wrote in message
news:eN*************@tk2msftngp13.phx.gbl...
On the server itself the page shows up as normal HTML, with no buttons,
text
boxes, etc...

I ran aspnet_regiis -i but this didn't help.

Please help!

Thanks.
"avnrao" <av*@newsgroups.com> wrote in message
news:uG**************@TK2MSFTNGP11.phx.gbl...
this error occurs when you are accessing the page from remote

machines..try
it from the local system (i mean on your server). you will get exact

error.

you can also change your web.config to <customErrors mode="Off"/> (thats
what the error says).

Av.

"VB Programmer" <Ro************************@juno.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
> If I try ANY aspx pages on my server, even INVALID, bogus pages, I get
> a
> "Runtime Error". Any idea why?
>
> Here is the full message:
>
>
> Server Error in '/' Application.


--------------------------------------------------------------------------

--
> ----
>
> Runtime Error
> Description: An application error occurred on the server. The current
> custom
> error settings for this application prevent the details of the application > error from being viewed remotely (for security reasons). It could,
> however,
> be viewed by browsers running on the local server machine.
>
> Details: To enable the details of this specific error message to be
> viewable
> on remote machines, please create a <customErrors> tag within a
> "web.config"
> configuration file located in the root directory of the current web
> application. This <customErrors> tag should then have its "mode" attribute > set to "Off".
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="Off"/>
> </system.web>
> </configuration>
>
> Notes: The current error page you are seeing can be replaced by a
> custom
> error page by modifying the "defaultRedirect" attribute of the
> application's
> <customErrors> configuration tag to point to a custom error page URL.
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="RemoteOnly"
> defaultRedirect="mycustompage.htm"/>
> </system.web>
> </configuration>
>
>
>



Nov 18 '05 #4

P: n/a
THanks
"avnrao" <av*@newsgroups.com> wrote in message
news:uO*************@TK2MSFTNGP12.phx.gbl...
check if your IIS has .aspx and .ascx extensions mapped to the respective
isapi dlls. (properties->virtualdirectory tab-> configuration)
after running aspnet_regiis, you need to restart iis.

Av
"VB Programmer" <Ro************************@juno.com> wrote in message
news:eN*************@tk2msftngp13.phx.gbl...
On the server itself the page shows up as normal HTML, with no buttons,
text
boxes, etc...

I ran aspnet_regiis -i but this didn't help.

Please help!

Thanks.
"avnrao" <av*@newsgroups.com> wrote in message
news:uG**************@TK2MSFTNGP11.phx.gbl...
this error occurs when you are accessing the page from remote

machines..try
it from the local system (i mean on your server). you will get exact

error.

you can also change your web.config to <customErrors mode="Off"/> (thats what the error says).

Av.

"VB Programmer" <Ro************************@juno.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
> If I try ANY aspx pages on my server, even INVALID, bogus pages, I get > a
> "Runtime Error". Any idea why?
>
> Here is the full message:
>
>
> Server Error in '/' Application.
-------------------------------------------------------------------------

- --
> ----
>
> Runtime Error
> Description: An application error occurred on the server. The current
> custom
> error settings for this application prevent the details of the

application
> error from being viewed remotely (for security reasons). It could,
> however,
> be viewed by browsers running on the local server machine.
>
> Details: To enable the details of this specific error message to be
> viewable
> on remote machines, please create a <customErrors> tag within a
> "web.config"
> configuration file located in the root directory of the current web
> application. This <customErrors> tag should then have its "mode"

attribute
> set to "Off".
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="Off"/>
> </system.web>
> </configuration>
>
> Notes: The current error page you are seeing can be replaced by a
> custom
> error page by modifying the "defaultRedirect" attribute of the
> application's
> <customErrors> configuration tag to point to a custom error page URL.
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="RemoteOnly"
> defaultRedirect="mycustompage.htm"/>
> </system.web>
> </configuration>
>
>
>



Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.