469,322 Members | 1,633 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,322 developers. It's quick & easy.

Drop-Down List forgets values in Windows 2003

Hi,

got a drop-down list on a windows form in VS.NET2003.

In the form load when NOT a postback, we add four values to the drop-down
list. These appear in Internet Explorer.

When you click a button on the form, the value selected in the drop-down is
supposed to be put in a label's Text property. However, when you click the
button, the page refreshes and all of the values from the drop-down list are
lost. The value is not transferred to the label and nothing is left to
select from - the drop-down is totally empty.

The same project on a Windows 2000 server works perfectly but when copied to
ANY windows 2003 server the results are the same failure.

Can anybody help please?
Nov 18 '05 #1
2 1275
Code never lies, so post it!
--Michael

"R-D-C" <no****@please.uk> wrote in message news:%2***************@TK2MSFTNGP10.phx.gbl...
Hi,

got a drop-down list on a windows form in VS.NET2003.

In the form load when NOT a postback, we add four values to the drop-down
list. These appear in Internet Explorer.

When you click a button on the form, the value selected in the drop-down is
supposed to be put in a label's Text property. However, when you click the
button, the page refreshes and all of the values from the drop-down list are
lost. The value is not transferred to the label and nothing is left to
select from - the drop-down is totally empty.

The same project on a Windows 2000 server works perfectly but when copied to
ANY windows 2003 server the results are the same failure.

Can anybody help please?

Nov 18 '05 #2
Sounds like Viewstate is disabled.
Turn it on.
--
Joe Fallon

"R-D-C" <no****@please.uk> wrote in message
news:%2***************@TK2MSFTNGP10.phx.gbl...
Hi,

got a drop-down list on a windows form in VS.NET2003.

In the form load when NOT a postback, we add four values to the drop-down
list. These appear in Internet Explorer.

When you click a button on the form, the value selected in the drop-down is supposed to be put in a label's Text property. However, when you click the button, the page refreshes and all of the values from the drop-down list are lost. The value is not transferred to the label and nothing is left to
select from - the drop-down is totally empty.

The same project on a Windows 2000 server works perfectly but when copied to ANY windows 2003 server the results are the same failure.

Can anybody help please?

Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Ian Dobson | last post: by
1 post views Thread by Torre Quinn | last post: by
reply views Thread by ViRi | last post: by
5 posts views Thread by Markus | last post: by
1 post views Thread by Darren | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by mdpf | last post: by
reply views Thread by harlem98 | last post: by
reply views Thread by listenups61195 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.