By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,813 Members | 1,252 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,813 IT Pros & Developers. It's quick & easy.

asp with sharepoint services

P: n/a
Not sure if I'm posting in the right group but here goes.

I am getting the following error when trying to browse to an .aspx
page which I have set up in a virtual directory under the default
companyweb sharepoint site on Microsoft SBS 2003. I've tried various
suggestions I've seen in other posts but no luck. I've also tried
giving every single user/group full permissions to the directory and
files but still no luck.

The page works fine on my workstatation and I've also tried some very
simple "hello world" inline ASP pages but the same thing happens
regardless.

The first message I get is:
************************************************** ********************
Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
************************************************** *********
If I set the mode to off I get the following error:

************************************************** ************
Debugging is not supported under current trust level settings.
Description: An unhandled exception occurred during the execution of
the current web request. Please review the stack trace for more
information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Debugging is not
supported under current trust level settings.

Source Error:

An unhandled exception was generated during the execution of the
current web request. Information regarding the origin and location of
the exception can be identified using the exception stack trace below.

Stack Trace:
[HttpException (0x80004005): Debugging is not supported under current
trust level settings.]
System.Web.UI.TemplateParser.HandlePostParse() +182
System.Web.UI.TemplateParser.Parse() +200
System.Web.UI.TemplateParser.GetParserCacheItemThr oughCompilation()
+73
System.Web.UI.TemplateParser.GetParserCacheItemInt ernal(Boolean
fCreateIfNotFound) +189
System.Web.UI.TemplateParser.GetParserCacheItemWit hNewConfigPath()
+125
System.Web.UI.TemplateParser.GetParserCacheItem() +88
System.Web.UI.ApplicationFileParser.GetCompiledApp licationType(String
inputFile, HttpContext context, ApplicationFileParser& parser) +168
System.Web.HttpApplicationFactory.CompileApplicati on(HttpContext
context) +43
System.Web.HttpApplicationFactory.Init(HttpContext context) +485
System.Web.HttpApplicationFactory.GetApplicationIn stance(HttpContext
context) +170
System.Web.HttpRuntime.ProcessRequestInternal(Http WorkerRequest wr)
+414
************************************************** ************
If I then change the trust level to full then I get a

404 NOT FOUND error.
Any advice?

Thanks,

Michael
Nov 18 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Have you excluded that app in SharePoint? If you don't, the SharePoint
filter will try and handle the request which is not what you want to happen.

Jim Cheshire, MCSE, MCSD [MSFT]
ASP.NET
Developer Support
ja******@online.microsoft.com

This post is provided "AS-IS" with no warranties and confers no rights.
--------------------
From: ms@fullermetric.com (Michael S)
Newsgroups: microsoft.public.dotnet.framework.aspnet
Subject: asp with sharepoint services
Date: 15 Apr 2004 11:09:40 -0700
Organization: http://groups.google.com
Lines: 91
Message-ID: <16**************************@posting.google.com >
NNTP-Posting-Host: 142.179.95.156
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Trace: posting.google.com 1082052580 7557 127.0.0.1 (15 Apr 2004 18:09:40 GMT)X-Complaints-To: gr**********@google.com
NNTP-Posting-Date: Thu, 15 Apr 2004 18:09:40 +0000 (UTC)
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed 00.sul.t-online.de!t-onlin
e.de!news.glorb.com!postnews1.google.com!not-for-mailXref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:225913
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Not sure if I'm posting in the right group but here goes.

I am getting the following error when trying to browse to an .aspx
page which I have set up in a virtual directory under the default
companyweb sharepoint site on Microsoft SBS 2003. I've tried various
suggestions I've seen in other posts but no luck. I've also tried
giving every single user/group full permissions to the directory and
files but still no luck.

The page works fine on my workstatation and I've also tried some very
simple "hello world" inline ASP pages but the same thing happens
regardless.

The first message I get is:
************************************************* *********************
Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
************************************************* **********
If I set the mode to off I get the following error:

************************************************* *************
Debugging is not supported under current trust level settings.
Description: An unhandled exception occurred during the execution of
the current web request. Please review the stack trace for more
information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Debugging is not
supported under current trust level settings.

Source Error:

An unhandled exception was generated during the execution of the
current web request. Information regarding the origin and location of
the exception can be identified using the exception stack trace below.

Stack Trace:
[HttpException (0x80004005): Debugging is not supported under current
trust level settings.]
System.Web.UI.TemplateParser.HandlePostParse() +182
System.Web.UI.TemplateParser.Parse() +200
System.Web.UI.TemplateParser.GetParserCacheItemThr oughCompilation()
+73
System.Web.UI.TemplateParser.GetParserCacheItemInt ernal(Boolean
fCreateIfNotFound) +189
System.Web.UI.TemplateParser.GetParserCacheItemWit hNewConfigPath()
+125
System.Web.UI.TemplateParser.GetParserCacheItem() +88
System.Web.UI.ApplicationFileParser.GetCompiledApp licationType(String
inputFile, HttpContext context, ApplicationFileParser& parser) +168
System.Web.HttpApplicationFactory.CompileApplicati on(HttpContext
context) +43
System.Web.HttpApplicationFactory.Init(HttpContext context) +485
System.Web.HttpApplicationFactory.GetApplicationIn stance(HttpContext
context) +170
System.Web.HttpRuntime.ProcessRequestInternal(Http WorkerRequest wr)
+414
************************************************* *************
If I then change the trust level to full then I get a

404 NOT FOUND error.
Any advice?

Thanks,

Michael


Nov 18 '05 #2

P: n/a
Hi Jim,

Thanks very much for the reply.

I haven't worked very much with sharepoint so could you just confirm I
understand correctly?

I go into Sharepoint Administration to the "Defined Manged Paths" and
just add a new path to my virtual directory and exclude that path?

Also if you don't mind explaining how does the sharepoint filter try to
handle requests? Like I said I don't know much about sharepoint yet but
I just assumed it was equivalent of running pages through IIS.

Appreciate it.

Michael

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #3

P: n/a
Hi Michael,

Yes, that's what you need to do to exclude it. Additionally, you also need
to make some minor modifications to your web.config file for your
application because SharePoint overrides some of the settings from the
machine.config file.

You need to add the following to the web.config file for your application:

<httpHandlers>
<clear />
<add verb="*" path="*.aspx" type="System.Web.UI.PageHandlerFactory,
System.Web,
Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
</httpHandlers>

<trust level="Full" originUrl="" />

<httpModules>
<add name="Session" type="System.Web.SessionState.SessionStateModule"/>
</httpModules>

<pages enableSessionState="true" enableViewState="true"
enableViewStateMac="true" validateRequest="false" />

After you make that change, it should work.

When the SharePoint filter gets a request, it attempts to get the content
out of SQL Server instead of from the Web server content area. By
excluding the path and adding back in the httpHandler, you can circumvent
that for your application.

Jim Cheshire, MCSE, MCSD [MSFT]
ASP.NET
Developer Support
ja******@online.microsoft.com

This post is provided "AS-IS" with no warranties and confers no rights.

--------------------
From: Michael S <ms@fullermetric.com>
References: <K4**************@cpmsftngxa06.phx.gbl>
X-Newsreader: AspNNTP 1.50 (ActionJackson.com)
Subject: RE: asp with sharepoint services
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <u1*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
Date: Fri, 16 Apr 2004 10:20:22 -0700
NNTP-Posting-Host: actionjackson133.dsl.frii.net 216.17.147.133
Lines: 1
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftn gp13.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:226202
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi Jim,

Thanks very much for the reply.

I haven't worked very much with sharepoint so could you just confirm I
understand correctly?

I go into Sharepoint Administration to the "Defined Manged Paths" and
just add a new path to my virtual directory and exclude that path?

Also if you don't mind explaining how does the sharepoint filter try to
handle requests? Like I said I don't know much about sharepoint yet but
I just assumed it was equivalent of running pages through IIS.

Appreciate it.

Michael

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!


Nov 18 '05 #4

P: n/a
Hello Jim,

Thanks to your help I'm getting much closer. Now at least the
web.config file in my virtual directory is getting parsed.

I'm running into the following error:
Configuration Error
Description: An error occurred during the processing of a configuration
file required to service this request. Please review the specific error
details below and modify your configuration file appropriately.

Parser Error Message: File or assembly name System.Web, or one of its
dependencies, was not found.

Source Error:
Line 82:
Line 83:
Line 84: <add verb="*" path="*.aspx"
type="System.Web.UI.PageHandlerFactory,System.Web,
Line 85: Version=1.0.5000.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a" />
Line 86: </httpHandlers>
Source File: E:\FMP\Sales\Overdue_Items\web.config Line: 84

Assembly Load Trace: The following information can be helpful to
determine why the assembly 'System.Web' could not be loaded.
=== Pre-bind state information ===
LOG: DisplayName = System.Web, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a
(Partial)
LOG: Appbase = file:///E:/FMP/Sales/Overdue_Items
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private,
custom, partial, or location-based assembly bind).
LOG: Post-policy reference: System.Web, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web/System.Web.DLL.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web.DLL.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web/System.Web.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web.EXE.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web/System.Web.EXE.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web.EXE.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web/System.Web.EXE.

I've tried adding the System.Web.UI.PageHandlerFactory namespace to my
project but the only ones I have under System.Web.UI are HTMLControls
and WebControls.

Any more thoughts?

Thanks again,

Michael

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #5

P: n/a
Michael,

Look in the GAC (c:\Windows\Assembly) and check the version for the
System.Web assembly and make sure that it's right. It is right if you are
using the 1.1 Framework. If you are using the 1.0 Framework, the version
will be 1.0.3300.0.

Jim Cheshire, MCSE, MCSD [MSFT]
ASP.NET
Developer Support
ja******@online.microsoft.com

This post is provided "AS-IS" with no warranties and confers no rights.

--------------------
From: Michael S <ms@fullermetric.com>
References: <ee*************@cpmsftngxa10.phx.gbl>
X-Newsreader: AspNNTP 1.50 (ActionJackson.com)
Subject: RE: asp with sharepoint services
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <e2**************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
Date: Fri, 16 Apr 2004 14:48:07 -0700
NNTP-Posting-Host: actionjackson133.dsl.frii.net 216.17.147.133
Lines: 1
Path: cpmsftngxa10.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFT NGP08.phx.gbl!tk2msftngp13
..phx.gblXref: cpmsftngxa10.phx.gbl microsoft.public.dotnet.framework.aspnet:227125
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hello Jim,

Thanks to your help I'm getting much closer. Now at least the
web.config file in my virtual directory is getting parsed.

I'm running into the following error:
Configuration Error
Description: An error occurred during the processing of a configuration
file required to service this request. Please review the specific error
details below and modify your configuration file appropriately.

Parser Error Message: File or assembly name System.Web, or one of its
dependencies, was not found.

Source Error:
Line 82:
Line 83:
Line 84: <add verb="*" path="*.aspx"
type="System.Web.UI.PageHandlerFactory,System.Web ,
Line 85: Version=1.0.5000.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a" />
Line 86: </httpHandlers>
Source File: E:\FMP\Sales\Overdue_Items\web.config Line: 84

Assembly Load Trace: The following information can be helpful to
determine why the assembly 'System.Web' could not be loaded.
=== Pre-bind state information ===
LOG: DisplayName = System.Web, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a
(Partial)
LOG: Appbase = file:///E:/FMP/Sales/Overdue_Items
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private,
custom, partial, or location-based assembly bind).
LOG: Post-policy reference: System.Web, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web/System.Web.DLL.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web.DLL.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web/System.Web.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web.EXE.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/bo/64deacff/e9a594f9/System.Web/System.Web.EXE.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web.EXE.
LOG: Attempting download of new URL
file:///E:/FMP/Sales/Overdue_Items/bin/System.Web/System.Web.EXE.

I've tried adding the System.Web.UI.PageHandlerFactory namespace to my
project but the only ones I have under System.Web.UI are HTMLControls
and WebControls.

Any more thoughts?

Thanks again,

Michael

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!


Nov 18 '05 #6

P: n/a
Morning Jim,

Checked the version and we are using the 1.1 Framework.

Thanks,

Michael

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.