467,864 Members | 1,896 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,864 developers. It's quick & easy.

Web application causes Web Access Failed message

Hello,

I'm trying to create a new ASP. NET Web Application project, when I enter a
name and press OK i get the following:

Web Access Failed.
The default web access mode for this project is set to file share, but the
project folder at "http://..." cannot be opened with the path
"C:\inetpub\...." The error returned was:

Unable to create Web project 'name'. The file path does not correspond to
the URL. The two need to map to the same server location. The connection
with the server was reset.

Any ideas why this is happening?

Thanks in advance.
Simon

--
Simon Jefferies
Tools Programmer, Headfirst Productions
mailto:si****@headfirst.co.uk
-


Nov 18 '05 #1
  • viewed: 3612
Share:
7 Replies
Hi Simon,

From your description, you encountered the following error:
===============================================
Web Access Failed.
The default web access mode for this project is set to file share, but the
project folder at "http://..." cannot be opened with the path
"C:\inetpub\...." The error returned was:

Unable to create Web project 'name'. The file path does not correspond to
the URL. The two need to map to the same server location. The connection
with the server was reset.
===============================================
when try creating an ASP.NET web project in VS.NET ,yes?

As for this problem, I'd like to confirm some further items:
1. Are you using IIS6(on win2k3 server) or not? If so, there is a kb
article discussing on this problem:
http://support.microsoft.com/?id=817264

2. If not, I've found any similiar issues which also have the symptom.
Would you have a check in the IIS manager to see whether the default site's
ip is set to unassigned and the port is the default value 80 ? the vs.net
will by default create web applicatio under the default site with url such
as Http://localhost/webapplication[n].

3. Are you creating webproject on a webaddress which is mapping to a remote
shared folder?

Please have a check on the above items. Also any further information is
helpful for us to do some further research on this. Thanks.
Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #2
Thanks for your reply,
when try creating an ASP.NET web project in VS.NET ,yes?

As for this problem, I'd like to confirm some further items:
1. Are you using IIS6(on win2k3 server) or not? If so, there is a kb
article discussing on this problem:
http://support.microsoft.com/?id=817264
I am running Windows XP SP2 Preview Release. IIS 5.1 (mentioned in the about
box for IIS).

2. If not, I've found any similiar issues which also have the symptom.
Would you have a check in the IIS manager to see whether the default
site's
ip is set to unassigned and the port is the default value 80 ? the vs.net
will by default create web applicatio under the default site with url such
as Http://localhost/webapplication[n].
It was originally set to 80, but I read on a KB about changing it, I have it
set to 81. But neither setting makes a difference.

3. Are you creating webproject on a webaddress which is mapping to a
remote
shared folder?
When I create a project, I create a standard ASP.NET web application, with
the location set to:

http://localhost/WebApplication1 for example.

Thanks
Simon Jefferies
Tools Programmer, Headfirst Productions
mailto:si****@headfirst.co.uk
-

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:vk****************@cpmsftngxa10.phx.gbl... Hi Simon,

From your description, you encountered the following error:
===============================================
Web Access Failed.
The default web access mode for this project is set to file share, but the
project folder at "http://..." cannot be opened with the path
"C:\inetpub\...." The error returned was:

Unable to create Web project 'name'. The file path does not correspond to
the URL. The two need to map to the same server location. The connection
with the server was reset.
===============================================
when try creating an ASP.NET web project in VS.NET ,yes?

As for this problem, I'd like to confirm some further items:
1. Are you using IIS6(on win2k3 server) or not? If so, there is a kb
article discussing on this problem:
http://support.microsoft.com/?id=817264

2. If not, I've found any similiar issues which also have the symptom.
Would you have a check in the IIS manager to see whether the default
site's
ip is set to unassigned and the port is the default value 80 ? the vs.net
will by default create web applicatio under the default site with url such
as Http://localhost/webapplication[n].

3. Are you creating webproject on a webaddress which is mapping to a
remote
shared folder?

Please have a check on the above items. Also any further information is
helpful for us to do some further research on this. Thanks.
Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #3
Hi Simon,

Since you created the webproject locally, I think this will be helpful that
we needn't worry about the remote shared scenario which may cause security
issues.

When you set the IIS default webserver's ip as unassigned and port as 81and
create a web project, have you changed the default location
(http://localhost/WebApplication[n]) to
http://localhost:81/WebApplication[n] ?
If not, the VS.NET will use the 80 default port to connect the IIS default
site.

Also, I suspect that whether your default site's HOme directory's LocalPath
(by default should be "[system disk]:\inetpub\wwwroot) has been changed to
other location. IF so, since the VS.NET will by default mapping the default
site's localhost address to the [x]:\inetpub\wwwroot, it'll unable to
locate it. So please check it in the IIS.

In addition, there're some former cases on this problem which is caused by
firewall security was tightened and the setting in the browser was not
checked to by pass the proxy when making a request to the local host. You
may try going to tools/options/internet connections/ and click LAN
settings in IE. Then
check bypass proxy server for local addresses.

Further more, please restarting the IIS server and then visit the default
IIS site via the http://localhost/ (if the port is 80) to see whether the
IIS is running correctly. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx


Nov 18 '05 #4
Thanks for your reply,
When you set the IIS default webserver's ip as unassigned and port as
81and
create a web project, have you changed the default location
(http://localhost/WebApplication[n]) to
http://localhost:81/WebApplication[n] ?
If not, the VS.NET will use the 80 default port to connect the IIS default
site.
I tried the http://localhost:81/webapplication[n], things have progressed.
I got an error about ASP .NET 1.1 not being installed, so I installed it by
running the asp_regiis program as mentioned in MSDN.
Also, I suspect that whether your default site's HOme directory's
LocalPath
(by default should be "[system disk]:\inetpub\wwwroot) has been changed to
other location. IF so, since the VS.NET will by default mapping the
default
site's localhost address to the [x]:\inetpub\wwwroot, it'll unable to
locate it. So please check it in the IIS.
My local path is: c:\inetpub\wwwroot
In addition, there're some former cases on this problem which is caused by
firewall security was tightened and the setting in the browser was not
checked to by pass the proxy when making a request to the local host. You
may try going to tools/options/internet connections/ and click LAN
settings in IE. Then
check bypass proxy server for local addresses.

Checked this item in the settings.
Further more, please restarting the IIS server and then visit the default
IIS site via the http://localhost/ (if the port is 80) to see whether the
IIS is running correctly. Thanks.
This is where the problems are. When I try to create the web project, i get
"The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'http://localhost:81/WebApplication1'. 'HTTP/1.1 403 Access Forbidden'.

When I restarted the IIS, and visited http://localhost:81, I get "The page
cannot be displayed" with the following message: "HTTP 403.1 Forbidden:
Execute Access Forbidden Internet Information Services".

Any ideas how to solve this issue?

Simon Jefferies
Tools Programmer, Headfirst Productions
mailto:si****@headfirst.co.uk
-

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:gW**************@cpmsftngxa06.phx.gbl... Hi Simon,

Since you created the webproject locally, I think this will be helpful
that
we needn't worry about the remote shared scenario which may cause security
issues.

When you set the IIS default webserver's ip as unassigned and port as
81and
create a web project, have you changed the default location
(http://localhost/WebApplication[n]) to
http://localhost:81/WebApplication[n] ?
If not, the VS.NET will use the 80 default port to connect the IIS default
site.

Also, I suspect that whether your default site's HOme directory's
LocalPath
(by default should be "[system disk]:\inetpub\wwwroot) has been changed to
other location. IF so, since the VS.NET will by default mapping the
default
site's localhost address to the [x]:\inetpub\wwwroot, it'll unable to
locate it. So please check it in the IIS.

In addition, there're some former cases on this problem which is caused by
firewall security was tightened and the setting in the browser was not
checked to by pass the proxy when making a request to the local host. You
may try going to tools/options/internet connections/ and click LAN
settings in IE. Then
check bypass proxy server for local addresses.

Further more, please restarting the IIS server and then visit the default
IIS site via the http://localhost/ (if the port is 80) to see whether the
IIS is running correctly. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #5
Hi Simon,

Thanks for the followup. As for the new prolbem you encountered, based on
my experience, we can trythe following things first:

1. Open the Internet Information Services Management Console
2. Expand the Virtual Directory Tree on the left-hand side until we could
see the
Default Web Site
3. Right click the Default Web Site
4. Select Properties
5. Check the Read attribute on the Home Directory tab
6. Set the Execute Permission was set to Scripts only on the Home Directory
tab

Also, I are you loging on the machine with a powerful account(such as
administrator) and is the IIS website's
diretory security setting use integrated windows and with anonymous user
disabled?

If you have any further questions, please feel free to post here. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #6
Thanks for your reply,

Its all sorted, my project has been created successfully! I didn't have the
execute permission set to scripts only, it was set to none.

Many Thanks for your help!
Simon Jefferies
Tools Programmer, Headfirst Productions
mailto:si****@headfirst.co.uk
-

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:0I**************@cpmsftngxa06.phx.gbl...
Hi Simon,

Thanks for the followup. As for the new prolbem you encountered, based on
my experience, we can trythe following things first:

1. Open the Internet Information Services Management Console
2. Expand the Virtual Directory Tree on the left-hand side until we could
see the
Default Web Site
3. Right click the Default Web Site
4. Select Properties
5. Check the Read attribute on the Home Directory tab
6. Set the Execute Permission was set to Scripts only on the Home
Directory
tab

Also, I are you loging on the machine with a powerful account(such as
administrator) and is the IIS website's
diretory security setting use integrated windows and with anonymous user
disabled?

If you have any further questions, please feel free to post here. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #7
Hi Simon,

I'm very glad that we've resolved this problem. Have a good day!

Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Simon Jefferies | last post: by
8 posts views Thread by Simon Jefferies | last post: by
13 posts views Thread by Edward Mitchell | last post: by
4 posts views Thread by casper | last post: by
17 posts views Thread by =?Utf-8?B?RGF2ZQ==?= | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.