422,577 Members | 859 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 422,577 IT Pros & Developers. It's quick & easy.

strange authentication problem...

P: n/a
hi there,

i've got a website i created, that i've put onto my test server on the web.

I have a login page, that when the user comes to it, it first pops up a
windows authentication dialog box, and i dont know why? i click cancel on it
and the page still works as normal.

How can i remove this, and why is it appearing?
i am also not using any .NET authentication methods or anything..

thanks,
Nov 18 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
you can set authentication mode in Web.config file
<authentication mode="Forms">
<forms name="login" loginUrl="login.aspx" protection="All" />
</authentication>

"Paul M" <mi******@hotmail.com> 写入消息
news:Ou**************@TK2MSFTNGP10.phx.gbl...
hi there,

i've got a website i created, that i've put onto my test server on the web.
I have a login page, that when the user comes to it, it first pops up a
windows authentication dialog box, and i dont know why? i click cancel on it and the page still works as normal.

How can i remove this, and why is it appearing?
i am also not using any .NET authentication methods or anything..

thanks,

Nov 18 '05 #2

P: n/a
thanks, but this isnt exactly what i am after..

What the problem is that i already have a login page which all works
fine...however i have 3 pages in my web app, that whenever i go to their
URL, they always popup the windows authentication window, when it shouldnt
appear..i have no authentication code for these pages, nor do i want any.

web.config is also set to <authentication mode="None" /> but still no luck.

Paull

"coollzh" <co*****@hotmail.com> wrote in message
news:uy**************@tk2msftngp13.phx.gbl...
you can set authentication mode in Web.config file
<authentication mode="Forms">
<forms name="login" loginUrl="login.aspx" protection="All" />
</authentication>

"Paul M" <mi******@hotmail.com> 写入消息
news:Ou**************@TK2MSFTNGP10.phx.gbl...
hi there,

i've got a website i created, that i've put onto my test server on the web.

I have a login page, that when the user comes to it, it first pops up a
windows authentication dialog box, and i dont know why? i click cancel

on it
and the page still works as normal.

How can i remove this, and why is it appearing?
i am also not using any .NET authentication methods or anything..

thanks,


Nov 18 '05 #3

P: n/a
thanks, but this isnt exactly what i am after..

What the problem is that i already have a login page which all works
fine...however i have 3 pages in my web app, that whenever i go to their
URL, they always popup the windows authentication window, when it shouldnt
appear..i have no authentication code for these pages, nor do i want any.

web.config is also set to <authentication mode="None" /> but still no luck.

Paull

"coollzh" <co*****@hotmail.com> wrote in message
news:uy**************@tk2msftngp13.phx.gbl...
you can set authentication mode in Web.config file
<authentication mode="Forms">
<forms name="login" loginUrl="login.aspx" protection="All" />
</authentication>

"Paul M" <mi******@hotmail.com> 写入消息
news:Ou**************@TK2MSFTNGP10.phx.gbl...
hi there,

i've got a website i created, that i've put onto my test server on the web.

I have a login page, that when the user comes to it, it first pops up a
windows authentication dialog box, and i dont know why? i click cancel

on it
and the page still works as normal.

How can i remove this, and why is it appearing?
i am also not using any .NET authentication methods or anything..

thanks,


Nov 18 '05 #4

P: n/a
it's really a trouble,i have no ideas about that.
if you have set authentication mode="None", it's will work
try again
<authentication mode="None">

<allow users="?"/>
</authentication>
"Paul M" <mi******@hotmail.com> 写入消息新闻
:uL*************@TK2MSFTNGP12.phx.gbl...
thanks, but this isnt exactly what i am after..

What the problem is that i already have a login page which all works
fine...however i have 3 pages in my web app, that whenever i go to their
URL, they always popup the windows authentication window, when it shouldnt
appear..i have no authentication code for these pages, nor do i want any.

web.config is also set to <authentication mode="None" /> but still no luck.
Paull

"coollzh" <co*****@hotmail.com> wrote in message
news:uy**************@tk2msftngp13.phx.gbl...
you can set authentication mode in Web.config file
<authentication mode="Forms">
<forms name="login" loginUrl="login.aspx" protection="All" /> <allow roles="Admins"/>
</authentication>

"Paul M" <mi******@hotmail.com> 写入消息
news:Ou**************@TK2MSFTNGP10.phx.gbl...
hi there,

i've got a website i created, that i've put onto my test server on the

web.

I have a login page, that when the user comes to it, it first pops up a windows authentication dialog box, and i dont know why? i click cancel

on
it
and the page still works as normal.

How can i remove this, and why is it appearing?
i am also not using any .NET authentication methods or anything..

thanks,



Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.