468,554 Members | 1,034 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,554 developers. It's quick & easy.

Can't Upload files, ASPNet Account required

Hi

I'm running Windows Server 2003 as a Domain Controller (with Active
Directory) as a development server. I created an app that uploads graphics
but it doesn't have permission. ASPNET machine account requires permission.
The problem is, this server is a domain controller so there is not a local
ASPNET account. How can I rectify this ?

Paul
Nov 18 '05 #1
3 1615
When you upgraded the server to support ASPX web pages, it should have
created the secure ASPNET account. This is the account that runs the
aspnet.ws worker service that handles aspx pages. By default, this
account has no write privileges. Go to the directory where the uploads
will be placed and add permission to that folder for write privs for
the ASPNET account.
On Sat, 6 Mar 2004 14:06:55 -0500, "Paul D. Fox" <pd*****@comcast.net>
wrote:
Hi

I'm running Windows Server 2003 as a Domain Controller (with Active
Directory) as a development server. I created an app that uploads graphics
but it doesn't have permission. ASPNET machine account requires permission.
The problem is, this server is a domain controller so there is not a local
ASPNET account. How can I rectify this ?

Paul


Nov 18 '05 #2
Th
"Dan Brussee" <db******@nc.rr.com> wrote in message
news:ld********************************@4ax.com...
When you upgraded the server to support ASPX web pages, it should have
created the secure ASPNET account. This is the account that runs the
aspnet.ws worker service that handles aspx pages. By default, this
account has no write privileges. Go to the directory where the uploads
will be placed and add permission to that folder for write privs for
the ASPNET account.
On Sat, 6 Mar 2004 14:06:55 -0500, "Paul D. Fox" <pd*****@comcast.net>
wrote:
Hi

I'm running Windows Server 2003 as a Domain Controller (with Active
Directory) as a development server. I created an app that uploads graphicsbut it doesn't have permission. ASPNET machine account requires permission.The problem is, this server is a domain controller so there is not a localASPNET account. How can I rectify this ?

Paul

Nov 18 '05 #3
Thanks for the response, however this was not an upgrade. This is a Windows
Server 2003 which has the framework installed. However, since its also a
Domain Controller, there are no Local Accounts such as ASPNET. Therefore
I'm trying to figure out how to rectify this so I can run "Upload" functions
as well as third party tools such as "radEditor"

Paul

"Dan Brussee" <db******@nc.rr.com> wrote in message
news:ld********************************@4ax.com...
When you upgraded the server to support ASPX web pages, it should have
created the secure ASPNET account. This is the account that runs the
aspnet.ws worker service that handles aspx pages. By default, this
account has no write privileges. Go to the directory where the uploads
will be placed and add permission to that folder for write privs for
the ASPNET account.
On Sat, 6 Mar 2004 14:06:55 -0500, "Paul D. Fox" <pd*****@comcast.net>
wrote:
Hi

I'm running Windows Server 2003 as a Domain Controller (with Active
Directory) as a development server. I created an app that uploads graphicsbut it doesn't have permission. ASPNET machine account requires permission.The problem is, this server is a domain controller so there is not a localASPNET account. How can I rectify this ?

Paul

Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by mt | last post: by
3 posts views Thread by Bart | last post: by
2 posts views Thread by Tom Wells | last post: by
2 posts views Thread by Ian Taite | last post: by
2 posts views Thread by Jay | last post: by
15 posts views Thread by David Thielen | last post: by
3 posts views Thread by Domac | last post: by
reply views Thread by NPC403 | last post: by
1 post views Thread by UniDue | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.