By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,190 Members | 1,503 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,190 IT Pros & Developers. It's quick & easy.

Add Web Reference Issue

P: n/a
Hi

I've checked the other posts on this topic but haven't been able to resolve it so far
-I have a working web service, that is to say I can view it/run it from a web browse
-From VS.Net I can use the Add Web Reference dialog and add this referenc
-However, from VS.Net 2003 the same localhost URL does not resolve and I get the "The proxy settings on this computer are not configured correctly for web discovery." message in the 'Web Services Found at this URL' box

So far I have
-Messed around with proxy settings to no avai
-Modified the machine.config file for the VSDisco dynamic discover
-Attempted to use WSDL.exe and Disco.exe from the command prompt to manually create a reference

Any thoughts or advice would be greatly appreciated.
Nov 18 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
you have to set the proxy setting in the web request with code or in the
web.config, as the web service does not have a profile, and will not pick up
proxy settings entered into internet explorer.

-- bruce (sqlwork.com)
"Morgan E. Dunn" <mo********@hotmail.com> wrote in message
news:CD**********************************@microsof t.com...
Hi,

I've checked the other posts on this topic but haven't been able to resolve it so far. -I have a working web service, that is to say I can view it/run it from a web browser -From VS.Net I can use the Add Web Reference dialog and add this reference
-However, from VS.Net 2003 the same localhost URL does not resolve and I get the "The proxy settings on this computer are not configured correctly
for web discovery." message in the 'Web Services Found at this URL' box.
So far I have:
-Messed around with proxy settings to no avail
-Modified the machine.config file for the VSDisco dynamic discovery
-Attempted to use WSDL.exe and Disco.exe from the command prompt to manually create a reference.
Any thoughts or advice would be greatly appreciated.

Nov 18 '05 #2

P: n/a
Hi,

Thanks for posting in the community!
From your description, you encountered the following error:
"The proxy settings on this computer are not configured correctly for web
discovery." message in the 'Web Services Found at this URL' box when trying
to add a web service as webreferencein a ASP.NET web app? And this works
well in VS.NET?

As for this problem, I'd like to confirm some certain things:
1. Does the problem occurs on every webservice? You may try creating a
simple webservcie and then try to generate the client proxy via both
VS.NET2003 and wsdl.exe to see whether this problem remains.

2. Also, have you tried use a winform application to add the web reference
to see whether the problem remains?

In addtion, since you said that you failed to add the web reference via the
localhost url, are you able to generate the client proxy class via "machine
name" or the physical address ? Also, sometimes the default namespace of
the webservide class may also cause the problem, try specfying a differernt
custom namespace via the WebServiceAttribute as below:

[ WebService(Description="Common Server
Variables",Namespace="http://www.mydomain.com/")]
public class ServerVariables: WebService {
................

Please check out the above items. If you have any new findings or update.
Please feel free to post here.
Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #3

P: n/a
Hi Morga,

I have one additional suggestion. Have you checked the <defaultProxy>
setting in your .Net 1.1's machine.config?

Regards,

Felix Wang
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 18 '05 #4

P: n/a
Hi Morga,

I have one additional suggestion. Have you checked the <defaultProxy>
setting in your .Net 1.1's machine.config?

Regards,

Felix Wang
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 18 '05 #5

P: n/a
Hi Morga,

I have one additional suggestion. Have you checked the <defaultProxy>
setting in your .Net 1.1's machine.config?

Regards,

Felix Wang
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 18 '05 #6

P: n/a
Hi Morga,

I have one additional suggestion. Have you checked the <defaultProxy>
setting in your .Net 1.1's machine.config?

Regards,

Felix Wang
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 18 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.