By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,353 Members | 1,277 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,353 IT Pros & Developers. It's quick & easy.

<authentication mode="Forms" /> and file access

P: n/a
How do I convince (what I have to set in asp.net server) that my program
that is using
<authentication mode="Forms" /> can write to, copy, etc. files in
directories on local disk? I have given full permisions to local directory
(IUSR_Machinename user), but I still get:

"System.UnauthorizedAccessException: Access to the path
"D:\Inetpub\wwwroot\".

Any idea how to change it?
Anton, ml.
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hello,

you must make sure that the ASPNET account has read/write permissions to the
folder you want to write to.

or

If you want to grant IUSR_Machinename user or the current windows user (if
anonymous acces in IIS is disables) permissions to write you have to add
this configuration setting in your web.config file:

<identity impersonate="true"/>

This makes that the code is execute as the anonymous user or the
authenticated user.

Hope this helps,
Kristof

"Anton ml. Vaheie" <an**********@kiss.si> wrote in message
news:OS**************@tk2msftngp13.phx.gbl...
How do I convince (what I have to set in asp.net server) that my program
that is using
<authentication mode="Forms" /> can write to, copy, etc. files in
directories on local disk? I have given full permisions to local directory
(IUSR_Machinename user), but I still get:

"System.UnauthorizedAccessException: Access to the path
"D:\Inetpub\wwwroot\".

Any idea how to change it?
Anton, ml.

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.