469,631 Members | 1,209 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,631 developers. It's quick & easy.

Brain Dead Reformatting

I know I have seen a way to stop the terrible reformatting that VS 2003 IDE
does. Beyond that is MS going to do a better (could not do a worse) job of
auto formatting.

Every change I make to the format of the page causes reformatting which
totally gets rid of the idea that controls are nested and have some
structure.

Please help

Lloyd Sheen
Nov 18 '05 #1
7 1118
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in
news:Pn********************@news01.bloor.is.net.ca ble.rogers.com:
I know I have seen a way to stop the terrible reformatting that VS 2003 IDE
does. Beyond that is MS going to do a better (could not do a worse) job of
auto formatting.


Its in the options. Just turn it off.
--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
"Programming is an art form that fights back"
ELKNews - Get your free copy at http://www.atozedsoftware.com

Nov 18 '05 #2
I have turned off the option that says when you switch views reformat. This
seems to nothing. Refomatting happens anyway. And the reformatting is
beyond belief.

Lloyd Sheen

"Chad Z. Hower aka Kudzu" <cp**@hower.org> wrote in message
news:Xn******************@127.0.0.1...
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in
news:Pn********************@news01.bloor.is.net.ca ble.rogers.com:
I know I have seen a way to stop the terrible reformatting that VS 2003 IDE does. Beyond that is MS going to do a better (could not do a worse) job of auto formatting.


Its in the options. Just turn it off.
--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
"Programming is an art form that fights back"
ELKNews - Get your free copy at http://www.atozedsoftware.com

Nov 18 '05 #3
Is this reformatting occuring when you switch from design to code view?
Afraid even with the format options off that it will still occur. Good news
is that it is fixed in the next version of vs.
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in message
news:tJ********************@news01.bloor.is.net.ca ble.rogers.com...
I have turned off the option that says when you switch views reformat. This seems to nothing. Refomatting happens anyway. And the reformatting is
beyond belief.

Lloyd Sheen

"Chad Z. Hower aka Kudzu" <cp**@hower.org> wrote in message
news:Xn******************@127.0.0.1...
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in
news:Pn********************@news01.bloor.is.net.ca ble.rogers.com:
I know I have seen a way to stop the terrible reformatting that VS
2003
IDE does. Beyond that is MS going to do a better (could not do a worse)
job
of auto formatting.


Its in the options. Just turn it off.
--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
"Programming is an art form that fights back"
ELKNews - Get your free copy at http://www.atozedsoftware.com


Nov 18 '05 #4
This problem has been addressed in countless threads, both in this NG and
many others.

Yes it does SUCK and MS does know about it.

Bottom line, is they aren't going to fix this anytime soon. And that SUCKS
too!

Will it be fixed for the Whidbey release? Your guess is as good as mine. (I
vote NOT) this problems has been around for a long time, if you check the
archives you'll see that people were bitching about this a long time ago on
FrontPage.

And no, switching it off in options does not work.

The easiest thing to do is to use Ctrl+Z (undo) 1 or more times after
switching to code view from design view, this should restore your
formatting.

I feel your pain brother!
Best of luck
Brian W


"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in message
news:Pn********************@news01.bloor.is.net.ca ble.rogers.com...
I know I have seen a way to stop the terrible reformatting that VS 2003 IDE does. Beyond that is MS going to do a better (could not do a worse) job of auto formatting.

Every change I make to the format of the page causes reformatting which
totally gets rid of the idea that controls are nested and have some
structure.

Please help

Lloyd Sheen

Nov 18 '05 #5
I absolutely hate this IDE. For a product that has a long previous life, it
seems the developers of VS 2003 did not learn from pevious iterations.

Buttons on toolbars go missing, things like Index Help just sit there. I
have had to exit the IDE more times than should be necessary just to get the
IDE back to functional.

Lloyd Sheen

"Brian W" <brianw@gold_death_2_spam_rush.com> wrote in message
news:Oq**************@TK2MSFTNGP09.phx.gbl...
This problem has been addressed in countless threads, both in this NG and
many others.

Yes it does SUCK and MS does know about it.

Bottom line, is they aren't going to fix this anytime soon. And that SUCKS
too!

Will it be fixed for the Whidbey release? Your guess is as good as mine. (I vote NOT) this problems has been around for a long time, if you check the
archives you'll see that people were bitching about this a long time ago on FrontPage.

And no, switching it off in options does not work.

The easiest thing to do is to use Ctrl+Z (undo) 1 or more times after
switching to code view from design view, this should restore your
formatting.

I feel your pain brother!
Best of luck
Brian W


"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in message news:Pn********************@news01.bloor.is.net.ca ble.rogers.com...
I know I have seen a way to stop the terrible reformatting that VS 2003

IDE
does. Beyond that is MS going to do a better (could not do a worse) job

of
auto formatting.

Every change I make to the format of the page causes reformatting which
totally gets rid of the idea that controls are nested and have some
structure.

Please help

Lloyd Sheen


Nov 18 '05 #6
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in
news:Ht********************@news01.bloor.is.net.ca ble.rogers.com:
I absolutely hate this IDE. For a product that has a long previous
You should try writing custom designers and plugins to truly "appreciate" it.
:)
life, it seems the developers of VS 2003 did not learn from pevious
iterations.


Well they learned some. But here is hoping they can learn some more in future
releases.

--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
"Programming is an art form that fights back"
ELKNews - Get your free copy at http://www.atozedsoftware.com

Nov 18 '05 #7
And the latest one, since I don't want to restart I have been doing things
in the command window. Now I want to go back to it to get those little
pieces of good code and voila it's not available when the app is not being
debugged. This worked in classic VS. MS get it right. Use some developers
as QA.
"Chad Z. Hower aka Kudzu" <cp**@hower.org> wrote in message
news:Xn******************@127.0.0.1...
"Lloyd Sheen" <sq*******************@tostopspamhotmail.com> wrote in
news:Ht********************@news01.bloor.is.net.ca ble.rogers.com:
I absolutely hate this IDE. For a product that has a long previous
You should try writing custom designers and plugins to truly "appreciate"

it. :)
life, it seems the developers of VS 2003 did not learn from pevious
iterations.
Well they learned some. But here is hoping they can learn some more in

future releases.

--
Chad Z. Hower (a.k.a. Kudzu) - http://www.hower.org/Kudzu/
"Programming is an art form that fights back"
ELKNews - Get your free copy at http://www.atozedsoftware.com

Nov 18 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by johnchampion | last post: by
3 posts views Thread by Chris Lane | last post: by
6 posts views Thread by Abhishek Srivastava | last post: by
3 posts views Thread by One Handed Man \( OHM - Terry Burns \) | last post: by
7 posts views Thread by One Handed Man \( OHM - Terry Burns \) | last post: by
1 post views Thread by Microsoft Newsserver | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.