By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,929 Members | 631 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,929 IT Pros & Developers. It's quick & easy.

website connection to database time out problem : login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

P: n/a
Hi,

The website I am working on is built with ASP.NET and connects to a
SQL Server 2000 database. The web server and database are on the same
machine. I have recently tried to modify the timeout of the website
from 20 mn to 60 mn. I changed the timeout setting in IIS. Now the
website itself doesn't time out, however after 20 mn, when I try to
access a page that needs to connect to the database, I get the
following error message

************************************************** ****************************************
Form Request:
ASP Code:
Error Number: -2147217843
ASP Source:
Error Category: Microsoft OLE DB Provider for SQL Server
File: /emissionsestimation/includes/db.asp
Line: 13
Description: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
ASP Description:
Date: 1/13/2004 9:26:08 AM
************************************************** ******************************************

If I access a page that doesn't connect to the database, it works
fine.

My connection string to the database is:
"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Id=*USER_ID*;Password=*PASSWORD*;Initial
Catalog=EmissionEstimations;Trusted_Connection=yes ;"

The connection to the database works fine unless the website is idle
for 20 mn. After 60 mn, I get the time out message I expected. So the
"login failed for user" message only happens if the application is
left idle between 20 mn and 60 mn.

Maybe the database has some kind of timeout setting that needs to be
modified as well? However why the "login failed" message ? Why this
user "ANONYMOUS" ? I'm kinda confused and I'd appreciate some help
onto why this happens and what to do about it.

Thanks heaps

Maelle
Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
you are using trusted connection and are also specifying the user name
password... that is why when the db connection fails you get
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

first remove the trusted connection... that should make that error go off...
as to why it happens after 20 mins... i am not sure...

your connection should look like this

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Id=*USER_ID*;Password=*PASSWORD*;Initial
Catalog=EmissionEstimations;"

or

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Initial Catalog=EmissionEstimations;Trusted_Connection=yes ;"

Second thing.. if you are using ASP.NET and are using Sql 2000 consider
using SqlClient namespace instead of OleDb
sqlclient is more efficient way ...

--
Regards,

HD

"Maellic" <ma*********@yahoo.fr> wrote in message
news:15**************************@posting.google.c om...
Hi,

The website I am working on is built with ASP.NET and connects to a
SQL Server 2000 database. The web server and database are on the same
machine. I have recently tried to modify the timeout of the website
from 20 mn to 60 mn. I changed the timeout setting in IIS. Now the
website itself doesn't time out, however after 20 mn, when I try to
access a page that needs to connect to the database, I get the
following error message

************************************************** **************************
************** Form Request:
ASP Code:
Error Number: -2147217843
ASP Source:
Error Category: Microsoft OLE DB Provider for SQL Server
File: /emissionsestimation/includes/db.asp
Line: 13
Description: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
ASP Description:
Date: 1/13/2004 9:26:08 AM
************************************************** **************************
****************
If I access a page that doesn't connect to the database, it works
fine.

My connection string to the database is:
"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Id=*USER_ID*;Password=*PASSWORD*;Initial
Catalog=EmissionEstimations;Trusted_Connection=yes ;"

The connection to the database works fine unless the website is idle
for 20 mn. After 60 mn, I get the time out message I expected. So the
"login failed for user" message only happens if the application is
left idle between 20 mn and 60 mn.

Maybe the database has some kind of timeout setting that needs to be
modified as well? However why the "login failed" message ? Why this
user "ANONYMOUS" ? I'm kinda confused and I'd appreciate some help
onto why this happens and what to do about it.

Thanks heaps

Maelle

Nov 18 '05 #2

P: n/a
sorry the second connection string using trusted connection should look
something like this

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*; Initial
Catalog=EmissionEstimations;Trusted_Connection=yes ;"
--
Regards,

HD

"Hermit Dave" <he************@CAPS.AND.DOTS.hotmail.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
you are using trusted connection and are also specifying the user name
password... that is why when the db connection fails you get
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

first remove the trusted connection... that should make that error go off... as to why it happens after 20 mins... i am not sure...

your connection should look like this

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Id=*USER_ID*;Password=*PASSWORD*;Initial
Catalog=EmissionEstimations;"

or

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Initial Catalog=EmissionEstimations;Trusted_Connection=yes ;"

Second thing.. if you are using ASP.NET and are using Sql 2000 consider
using SqlClient namespace instead of OleDb
sqlclient is more efficient way ...

--
Regards,

HD

"Maellic" <ma*********@yahoo.fr> wrote in message
news:15**************************@posting.google.c om...
Hi,

The website I am working on is built with ASP.NET and connects to a
SQL Server 2000 database. The web server and database are on the same
machine. I have recently tried to modify the timeout of the website
from 20 mn to 60 mn. I changed the timeout setting in IIS. Now the
website itself doesn't time out, however after 20 mn, when I try to
access a page that needs to connect to the database, I get the
following error message

************************************************** ************************** **************
Form Request:
ASP Code:
Error Number: -2147217843
ASP Source:
Error Category: Microsoft OLE DB Provider for SQL Server
File: /emissionsestimation/includes/db.asp
Line: 13
Description: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
ASP Description:
Date: 1/13/2004 9:26:08 AM

************************************************** ************************** ****************

If I access a page that doesn't connect to the database, it works
fine.

My connection string to the database is:
"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*;User
Id=*USER_ID*;Password=*PASSWORD*;Initial
Catalog=EmissionEstimations;Trusted_Connection=yes ;"

The connection to the database works fine unless the website is idle
for 20 mn. After 60 mn, I get the time out message I expected. So the
"login failed for user" message only happens if the application is
left idle between 20 mn and 60 mn.

Maybe the database has some kind of timeout setting that needs to be
modified as well? However why the "login failed" message ? Why this
user "ANONYMOUS" ? I'm kinda confused and I'd appreciate some help
onto why this happens and what to do about it.

Thanks heaps

Maelle


Nov 18 '05 #3

P: n/a
"Hermit Dave" <he************@CAPS.AND.DOTS.hotmail.com> wrote in message news:<e5*************@TK2MSFTNGP10.phx.gbl>...
sorry the second connection string using trusted connection should look
something like this

"PROVIDER=SQLOLEDB;Data Source=*IP_ADRESS*; Initial
Catalog=EmissionEstimations;Trusted_Connection=yes ;"

Thanks a lot, I'll try that and see... Hopefully it'll fix my problem
although the timeout thing is weird.

Second thing.. if you are using ASP.NET and are using Sql 2000 consider
using SqlClient namespace instead of OleDb
sqlclient is more efficient way ...


I'll look into it. If you know of any good websites that explain the
difference between both, I'd appreciate your pointers, otherwise I'll
just google it.

Thanks for your help

Maelle
Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.