468,291 Members | 1,427 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,291 developers. It's quick & easy.

HTTPHandler / HTTPModule problems

Has anyone else experienced unreliability with HTTPHandler and HTTPModles
they've written? What seems to work fine at one time, just seems to stop
working at others? Any ideas if this is a debugger issue or an IIS issue
related to the file extension mappings?

Bruce B
Nov 18 '05 #1
3 1234
I've used both HttpModules and HttpHandlers in production environments
with no problems whatsoever. What sort of issues are you looking at?

Bruce Johnson
http://www.ObjectSharp.com/Bruce

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #2
Fortunately my production environment seems stable ***so far***, it is W2K.

The instability seems to be on my local development env.: VS.NET 2003, XP
Pro. At times they just flat fail to fire, and thus I end up with broken
stuff all over. After reboot, it all starts working again. It might be
debugger related or instability in IIS, I'm not sure. I posted another
message about IIS and too many script mappings problem.

The 2002 debugger never gave me any problems. Now, with the 2003 debugger,
after 5-10 debug sessions, the debugger stops working, throws errors about
can't detach it self. It hangs in memory and prevents me from doing any
more work until I reboot.
"BruceJohnson" <Br***@ObjectSharp.removethis.com> wrote in message
news:ep**************@TK2MSFTNGP11.phx.gbl...
I've used both HttpModules and HttpHandlers in production environments
with no problems whatsoever. What sort of issues are you looking at?

Bruce Johnson
http://www.ObjectSharp.com/Bruce

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

Nov 18 '05 #3
in 2003 Debugger does not end an iis application.
So if you start the debugging again the events (like App_OnStart, ...) will
not be fired
Do a complete rebuild if you want to stop an IIS application.

George.

"Bruce B" <an*******@discussions.microsoft.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Fortunately my production environment seems stable ***so far***, it is W2K.
The instability seems to be on my local development env.: VS.NET 2003, XP
Pro. At times they just flat fail to fire, and thus I end up with broken
stuff all over. After reboot, it all starts working again. It might be
debugger related or instability in IIS, I'm not sure. I posted another
message about IIS and too many script mappings problem.

The 2002 debugger never gave me any problems. Now, with the 2003 debugger, after 5-10 debug sessions, the debugger stops working, throws errors about
can't detach it self. It hangs in memory and prevents me from doing any
more work until I reboot.
"BruceJohnson" <Br***@ObjectSharp.removethis.com> wrote in message
news:ep**************@TK2MSFTNGP11.phx.gbl...
I've used both HttpModules and HttpHandlers in production environments
with no problems whatsoever. What sort of issues are you looking at?

Bruce Johnson
http://www.ObjectSharp.com/Bruce

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!


Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Michael Iantosca | last post: by
9 posts views Thread by Jared Tullis | last post: by
reply views Thread by Mike Schilling | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.