By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,594 Members | 3,680 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,594 IT Pros & Developers. It's quick & easy.

Server Error in '/' Application

P: n/a
I give up! I've installed a new 2000 Server machine with the .NET framework
1.1. When I create the simplest for .aspx pages (nothing but a paragraph
with "test" in it and no codebehind page) and try to view this page I get
the following error. I've checked the security settings for the ASPNET user'
s "temp" directory and they are OK. The ASPNET user does have "Impersonate a
client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.

----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>


Nov 18 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Try doing what it says, then posting us the error! the ASPNET user needs to
read/write to the framework inside %windir% so it can create a class from
your aspx page.

"Rick Lemons" <ri***@cdldata.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I give up! I've installed a new 2000 Server machine with the .NET framework 1.1. When I create the simplest for .aspx pages (nothing but a paragraph
with "test" in it and no codebehind page) and try to view this page I get
the following error. I've checked the security settings for the ASPNET user' s "temp" directory and they are OK. The ASPNET user does have "Impersonate a client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.

-------------------------------------------------------------------------- -- ----

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>

Nov 18 '05 #2

P: n/a
Have you tried turning CustomErrors mode off to see what the problem is?

--
Thanks, Jeff

"Rick Lemons" <ri***@cdldata.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I give up! I've installed a new 2000 Server machine with the .NET framework 1.1. When I create the simplest for .aspx pages (nothing but a paragraph
with "test" in it and no codebehind page) and try to view this page I get
the following error. I've checked the security settings for the ASPNET user' s "temp" directory and they are OK. The ASPNET user does have "Impersonate a client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.

-------------------------------------------------------------------------- -- ----

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>

Nov 18 '05 #3

P: n/a
I did set the <customErrors mode="Off" /> in web.config and got the exact
same message.

"Chris Small" <chris@sloppycode[remove for nospam].net> wrote in message
news:3f***********************@mercury.nildram.net ...
Try doing what it says, then posting us the error! the ASPNET user needs to read/write to the framework inside %windir% so it can create a class from
your aspx page.

"Rick Lemons" <ri***@cdldata.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I give up! I've installed a new 2000 Server machine with the .NET framework
1.1. When I create the simplest for .aspx pages (nothing but a paragraph
with "test" in it and no codebehind page) and try to view this page I get the following error. I've checked the security settings for the ASPNET

user'
s "temp" directory and they are OK. The ASPNET user does have "Impersonate a
client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.


--------------------------------------------------------------------------
--
----

Runtime Error
Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the

application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors> tag within a

"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the

application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>


Nov 18 '05 #4

P: n/a
Yes. I get the exact same error screen. It's like there is an error before
it even checks this setting.
"Jeff B." <je**@nowhere.com> wrote in message
news:%2***************@TK2MSFTNGP11.phx.gbl...
Have you tried turning CustomErrors mode off to see what the problem is?

--
Thanks, Jeff

"Rick Lemons" <ri***@cdldata.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I give up! I've installed a new 2000 Server machine with the .NET framework
1.1. When I create the simplest for .aspx pages (nothing but a paragraph
with "test" in it and no codebehind page) and try to view this page I get the following error. I've checked the security settings for the ASPNET

user'
s "temp" directory and they are OK. The ASPNET user does have "Impersonate a
client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.


--------------------------------------------------------------------------
--
----

Runtime Error
Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the

application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors> tag within a

"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the

application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>


Nov 18 '05 #5

P: n/a
Problem solved. The ASPNET account did not have privileges for the folders
in this web site.

Thanks for your help everyone.
"Rick Lemons" <ri***@cdldata.com> wrote in message
news:Oc**************@TK2MSFTNGP10.phx.gbl...
Yes. I get the exact same error screen. It's like there is an error before
it even checks this setting.
"Jeff B." <je**@nowhere.com> wrote in message
news:%2***************@TK2MSFTNGP11.phx.gbl...
Have you tried turning CustomErrors mode off to see what the problem is?

--
Thanks, Jeff

"Rick Lemons" <ri***@cdldata.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I give up! I've installed a new 2000 Server machine with the .NET

framework
1.1. When I create the simplest for .aspx pages (nothing but a paragraph with "test" in it and no codebehind page) and try to view this page I get the following error. I've checked the security settings for the ASPNET

user'
s "temp" directory and they are OK. The ASPNET user does have "Impersonate
a
client after authentication". Where else do I look?

Thanks

Server Error in '/' Application.


--------------------------------------------------------------------------
--
----

Runtime Error
Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the

application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors> tag within a

"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="Off"/> </system.web></configuration>
Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the

application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File --><configuration> <system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web></configuration>



Nov 18 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.