By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,758 Members | 1,225 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,758 IT Pros & Developers. It's quick & easy.

Access is Denied error debugging ASP.NET

P: n/a
Gents,

Have .Net2003 Enterprise architect installed on a Win2k Server with IIS.

Even logged in as administrator, I cannot run any ASP.NET app with
debugging. I always get the error "Unable to start debugger on the web
server: Access is Denied" when attempting to start the app with debugging.

Now, I have already spent 3 days going through every Knowledge base article
and all the included help with .net, have tried about 50 different security
settings and other changes suggested by these articles, and I cannot seem to
solve this problem. Bit of MAJOR frustration, as I would expect that the
default install should allow debugging (it IS a development environment), at
least on the server that is running IIS.

The server is a PDC, Win2K Sp6,and has the latest .NET installed from the
MSDN downloads

HELP!
Nov 18 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi,

have you installed debugging components from VS.NET's discs?

--
Teemu Keiski
MCP, Microsoft MVP (ASP.NET), AspInsiders member
ASP.NET Forum Moderator, AspAlliance Columnist
"Don Hans" <do*****@mindspring.com> wrote in message
news:vX***********************@news4.srv.hcvlny.cv .net...
Gents,

Have .Net2003 Enterprise architect installed on a Win2k Server with IIS.

Even logged in as administrator, I cannot run any ASP.NET app with
debugging. I always get the error "Unable to start debugger on the web
server: Access is Denied" when attempting to start the app with debugging.
Now, I have already spent 3 days going through every Knowledge base article and all the included help with .net, have tried about 50 different security settings and other changes suggested by these articles, and I cannot seem to solve this problem. Bit of MAJOR frustration, as I would expect that the
default install should allow debugging (it IS a development environment), at least on the server that is running IIS.

The server is a PDC, Win2K Sp6,and has the latest .NET installed from the
MSDN downloads

HELP!

Nov 18 '05 #2

P: n/a
Yes, it seems that they are installed by default?
"Teemu Keiski" <jo****@aspalliance.com> wrote in message
news:uC**************@TK2MSFTNGP12.phx.gbl...
Hi,

have you installed debugging components from VS.NET's discs?

--
Teemu Keiski
MCP, Microsoft MVP (ASP.NET), AspInsiders member
ASP.NET Forum Moderator, AspAlliance Columnist
"Don Hans" <do*****@mindspring.com> wrote in message
news:vX***********************@news4.srv.hcvlny.cv .net...
Gents,

Have .Net2003 Enterprise architect installed on a Win2k Server with IIS.

Even logged in as administrator, I cannot run any ASP.NET app with
debugging. I always get the error "Unable to start debugger on the web
server: Access is Denied" when attempting to start the app with debugging.

Now, I have already spent 3 days going through every Knowledge base

article
and all the included help with .net, have tried about 50 different

security
settings and other changes suggested by these articles, and I cannot seem to
solve this problem. Bit of MAJOR frustration, as I would expect that
the default install should allow debugging (it IS a development environment), at
least on the server that is running IIS.

The server is a PDC, Win2K Sp6,and has the latest .NET installed from

the MSDN downloads

HELP!


Nov 18 '05 #3

P: n/a
Don:

These items are not installed by default, if i remember correctly. You have
to select the Remote Components Installation from Disc 1 of the installation
discs. It will appear as a link when the splash screen comes up after you
insert the disc.

Selecting this will bring up an HTML page with instructions on installing
the debuggers. Note this is only required if youre doing debugging on a
machine that you are not working on (NOT your localhost, but your remote
development machine).

HTH
"Don Hans" <do*****@mindspring.com> wrote in message
news:Mm***********************@news4.srv.hcvlny.cv .net...
Yes, it seems that they are installed by default?
"Teemu Keiski" <jo****@aspalliance.com> wrote in message
news:uC**************@TK2MSFTNGP12.phx.gbl...
Hi,

have you installed debugging components from VS.NET's discs?

--
Teemu Keiski
MCP, Microsoft MVP (ASP.NET), AspInsiders member
ASP.NET Forum Moderator, AspAlliance Columnist
"Don Hans" <do*****@mindspring.com> wrote in message
news:vX***********************@news4.srv.hcvlny.cv .net...
Gents,

Have .Net2003 Enterprise architect installed on a Win2k Server with IIS.
Even logged in as administrator, I cannot run any ASP.NET app with
debugging. I always get the error "Unable to start debugger on the web server: Access is Denied" when attempting to start the app with

debugging.

Now, I have already spent 3 days going through every Knowledge base

article
and all the included help with .net, have tried about 50 different

security
settings and other changes suggested by these articles, and I cannot seem
to
solve this problem. Bit of MAJOR frustration, as I would expect that

the default install should allow debugging (it IS a development environment),
at
least on the server that is running IIS.

The server is a PDC, Win2K Sp6,and has the latest .NET installed from

the MSDN downloads

HELP!



Nov 18 '05 #4

P: n/a
Thx for the reply.

I am installing from a MSDN download - dont know if it is different from the
CDs, but in the selection options indicate that "Full Remote Debugging" is
installed by default. Although I see the HTM page that indicates you can do
it manually, I reasonably sure it is installed.

In addition, I dont think it matters in this case, as I am acutally
developing (for the time being ON the server that is running IIS (not
remotely).
"Elliot M. Rodriguez" <someemail> wrote in message
news:ev**************@TK2MSFTNGP12.phx.gbl...
Don:

These items are not installed by default, if i remember correctly. You have to select the Remote Components Installation from Disc 1 of the installation discs. It will appear as a link when the splash screen comes up after you
insert the disc.

Selecting this will bring up an HTML page with instructions on installing
the debuggers. Note this is only required if youre doing debugging on a
machine that you are not working on (NOT your localhost, but your remote
development machine).

HTH
"Don Hans" <do*****@mindspring.com> wrote in message
news:Mm***********************@news4.srv.hcvlny.cv .net...
Yes, it seems that they are installed by default?
"Teemu Keiski" <jo****@aspalliance.com> wrote in message
news:uC**************@TK2MSFTNGP12.phx.gbl...
Hi,

have you installed debugging components from VS.NET's discs?

--
Teemu Keiski
MCP, Microsoft MVP (ASP.NET), AspInsiders member
ASP.NET Forum Moderator, AspAlliance Columnist
"Don Hans" <do*****@mindspring.com> wrote in message
news:vX***********************@news4.srv.hcvlny.cv .net...
> Gents,
>
> Have .Net2003 Enterprise architect installed on a Win2k Server with IIS. >
> Even logged in as administrator, I cannot run any ASP.NET app with
> debugging. I always get the error "Unable to start debugger on the web > server: Access is Denied" when attempting to start the app with
debugging.
>
> Now, I have already spent 3 days going through every Knowledge base
article
> and all the included help with .net, have tried about 50 different
security
> settings and other changes suggested by these articles, and I cannot

seem
to
> solve this problem. Bit of MAJOR frustration, as I would expect
that the
> default install should allow debugging (it IS a development

environment),
at
> least on the server that is running IIS.
>
> The server is a PDC, Win2K Sp6,and has the latest .NET installed
from the
> MSDN downloads
>
> HELP!
>
>



Nov 18 '05 #5

P: n/a
Fixed the problem.

Although it did not give the error message indicated in the article, the fix
detailed in Microsoft Knowledge Base Article - 827559 fixed this problem.

Thanks for the help
"Don Hans" <do*****@mindspring.com> wrote in message
news:WD***********************@news4.srv.hcvlny.cv .net...
Thx for the reply.

I am installing from a MSDN download - dont know if it is different from the CDs, but in the selection options indicate that "Full Remote Debugging" is
installed by default. Although I see the HTM page that indicates you can do it manually, I reasonably sure it is installed.

In addition, I dont think it matters in this case, as I am acutally
developing (for the time being ON the server that is running IIS (not
remotely).
"Elliot M. Rodriguez" <someemail> wrote in message
news:ev**************@TK2MSFTNGP12.phx.gbl...
Don:

These items are not installed by default, if i remember correctly. You

have
to select the Remote Components Installation from Disc 1 of the

installation
discs. It will appear as a link when the splash screen comes up after you
insert the disc.

Selecting this will bring up an HTML page with instructions on installing the debuggers. Note this is only required if youre doing debugging on a
machine that you are not working on (NOT your localhost, but your remote
development machine).

HTH
"Don Hans" <do*****@mindspring.com> wrote in message
news:Mm***********************@news4.srv.hcvlny.cv .net...
Yes, it seems that they are installed by default?
"Teemu Keiski" <jo****@aspalliance.com> wrote in message
news:uC**************@TK2MSFTNGP12.phx.gbl...
> Hi,
>
> have you installed debugging components from VS.NET's discs?
>
> --
> Teemu Keiski
> MCP, Microsoft MVP (ASP.NET), AspInsiders member
> ASP.NET Forum Moderator, AspAlliance Columnist
>
>
> "Don Hans" <do*****@mindspring.com> wrote in message
> news:vX***********************@news4.srv.hcvlny.cv .net...
> > Gents,
> >
> > Have .Net2003 Enterprise architect installed on a Win2k Server with
IIS.
> >
> > Even logged in as administrator, I cannot run any ASP.NET app with
> > debugging. I always get the error "Unable to start debugger on
the web
> > server: Access is Denied" when attempting to start the app with
> debugging.
> >
> > Now, I have already spent 3 days going through every Knowledge

base > article
> > and all the included help with .net, have tried about 50 different
> security
> > settings and other changes suggested by these articles, and I cannot seem
> to
> > solve this problem. Bit of MAJOR frustration, as I would expect

that the
> > default install should allow debugging (it IS a development
environment),
> at
> > least on the server that is running IIS.
> >
> > The server is a PDC, Win2K Sp6,and has the latest .NET installed from the
> > MSDN downloads
> >
> > HELP!
> >
> >
>
>



Nov 18 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.