By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,931 Members | 1,357 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,931 IT Pros & Developers. It's quick & easy.

debugging

P: n/a
wh
Can somebody confirm that you have to be in the Administrators group to be
able to debug an ASP.NET application?

Wayne.
Nov 18 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Hi Wayne,

There is an MSDN article that talks about developing as a
non-Administrator, but it is not supported. From the viewpoint of the
ASP.NET team in PSS, you must either be an Administrator or run the ASP.NET
process as your domain account via the <processModel> section of the
machine.config file.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "wh" <wa***@nospam.pyesmeadow.com>
Newsgroups: microsoft.public.dotnet.framework.aspnet
Subject: debugging
Date: Wed, 3 Dec 2003 15:47:45 -0000
Organization: freedom2surf
Lines: 6
Message-ID: <bq**********@news.freedom2surf.net>
NNTP-Posting-Host: 195.137.79.45
X-Trace: news.freedom2surf.net 1070466361 11332 195.137.79.45 (3 Dec 2003 15:46:01 GMT)X-Complaints-To: ab***@freedom2surf.net
NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000 (UTC)
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed 00.sul.t-online.de!t-onlin
e.de!peernews3.colt.net!news0.de.colt.net!news-fra1.dfn.de!npeer.de.kpn-euro
rings.net!news-out1.newsfeeds.com!propagator2-maxim!feed-maxim.newsfeeds.com
!news.freedom2surf.net!not-for-mailXref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:194740
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Can somebody confirm that you have to be in the Administrators group to be
able to debug an ASP.NET application?

Wayne.


Nov 18 '05 #2

P: n/a
Or just add your username to the "debugger users" group.
Thanks,
Shawn
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:WD******************@cpmsftngxa06.phx.gbl...
Hi Wayne,

There is an MSDN article that talks about developing as a
non-Administrator, but it is not supported. From the viewpoint of the
ASP.NET team in PSS, you must either be an Administrator or run the ASP.NET process as your domain account via the <processModel> section of the
machine.config file.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "wh" <wa***@nospam.pyesmeadow.com>
Newsgroups: microsoft.public.dotnet.framework.aspnet
Subject: debugging
Date: Wed, 3 Dec 2003 15:47:45 -0000
Organization: freedom2surf
Lines: 6
Message-ID: <bq**********@news.freedom2surf.net>
NNTP-Posting-Host: 195.137.79.45
X-Trace: news.freedom2surf.net 1070466361 11332 195.137.79.45 (3 Dec 2003 15:46:01 GMT)
X-Complaints-To: ab***@freedom2surf.net
NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000 (UTC)
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed 00.sul.t-online.de!t-onlin e.de!peernews3.colt.net!news0.de.colt.net!news-fra1.dfn.de!npeer.de.kpn-euro rings.net!news-out1.newsfeeds.com!propagator2-maxim!feed-maxim.newsfeeds.com !news.freedom2surf.net!not-for-mail
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:194740X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Can somebody confirm that you have to be in the Administrators group to beable to debug an ASP.NET application?

Wayne.

Nov 18 '05 #3

P: n/a
Shawn,

Doing that will give you Launch and Access DCOM permissions to the machine
debug manager, but it doesn't give you access to be able to debug entirely.
We have worked several issues like this, and the list of things that must
be done in order for a non-Administrator to debug is extensive. There is
no quick fix to make it work, and doing so is not going to be supported by
us.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Reply-To: "Shawn B." <le****@html.com>
From: "Shawn B." <le****@html.com>
References: <bq**********@news.freedom2surf.net> <WD**************@cpmsftngxa06.phx.gbl>Subject: Re: debugging
Date: Wed, 3 Dec 2003 09:13:07 -0800
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 63.251.219.69
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftn gp13.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:194776
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Or just add your username to the "debugger users" group.
Thanks,
Shawn
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:WD******************@cpmsftngxa06.phx.gbl. ..
Hi Wayne,

There is an MSDN article that talks about developing as a
non-Administrator, but it is not supported. From the viewpoint of the
ASP.NET team in PSS, you must either be an Administrator or run the

ASP.NET
process as your domain account via the <processModel> section of the
machine.config file.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
>From: "wh" <wa***@nospam.pyesmeadow.com>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: debugging
>Date: Wed, 3 Dec 2003 15:47:45 -0000
>Organization: freedom2surf
>Lines: 6
>Message-ID: <bq**********@news.freedom2surf.net>
>NNTP-Posting-Host: 195.137.79.45
>X-Trace: news.freedom2surf.net 1070466361 11332 195.137.79.45 (3 Dec
2003
15:46:01 GMT)
>X-Complaints-To: ab***@freedom2surf.net
>NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000 (UTC)
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli

n

e.de!peernews3.colt.net!news0.de.colt.net!news-fra1.dfn.de!npeer.de.kpn-eur

o

rings.net!news-out1.newsfeeds.com!propagator2-maxim!feed-maxim.newsfeeds.co

m
!news.freedom2surf.net!not-for-mail
>Xref: cpmsftngxa06.phx.gbl

microsoft.public.dotnet.framework.aspnet:194740 >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Can somebody confirm that you have to be in the Administrators group tobe >able to debug an ASP.NET application?
>
>Wayne.
>
>
>



Nov 18 '05 #4

P: n/a
wh
Thanks for confirming that. I've been trying all morning to get it working
but failed. In the end I added my account to the Administrators group and it
has been working since.

Wayne.
Nov 18 '05 #5

P: n/a
Unfortunately adding the developers to the Administrators
group isn't feasible in a classroom setting where we are
teaching asp.net programming.

-----Original Message-----
Shawn,

Doing that will give you Launch and Access DCOM permissions to the machinedebug manager, but it doesn't give you access to be able to debug entirely. We have worked several issues like this, and the list of things that mustbe done in order for a non-Administrator to debug is extensive. There isno quick fix to make it work, and doing so is not going to be supported byus.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
Reply-To: "Shawn B." <le****@html.com>
From: "Shawn B." <le****@html.com>
References: <bq**********@news.freedom2surf.net><WD**************@cpmsftngxa06.phx.gbl>
Subject: Re: debugging
Date: Wed, 3 Dec 2003 09:13:07 -0800
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 63.251.219.69
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl! tk2msftngp13.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:194776X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Or just add your username to the "debugger users" group.
Thanks,
Shawn
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in messagenews:WD******************@cpmsftngxa06.phx.gbl.. .
Hi Wayne,

There is an MSDN article that talks about developing as a non-Administrator, but it is not supported. From the viewpoint of the ASP.NET team in PSS, you must either be an Administrator or run the
ASP.NET
process as your domain account via the <processModel>
section of the machine.config file.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
>From: "wh" <wa***@nospam.pyesmeadow.com>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: debugging
>Date: Wed, 3 Dec 2003 15:47:45 -0000
>Organization: freedom2surf
>Lines: 6
>Message-ID: <bq**********@news.freedom2surf.net>
>NNTP-Posting-Host: 195.137.79.45
>X-Trace: news.freedom2surf.net 1070466361 11332 195.137.79.45 (3 Dec2003 15:46:01 GMT)
>X-Complaints-To: ab***@freedom2surf.net
>NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000
(UTC) >X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165 >Path:
cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!

newsfeed00.sul.t-online.de!t-online.de!peernews3.colt.net!news0.de.colt.net!news- fra1.dfn.de!npeer.de.kpn-eurorings.net!news-out1.newsfeeds.com!propagator2-maxim!feed- maxim.newsfeeds.com !news.freedom2surf.net!not-for-mail
>Xref: cpmsftngxa06.phx.gbl

microsoft.public.dotnet.framework.aspnet:19474 0
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Can somebody confirm that you have to be in the

Administrators group tobe
>able to debug an ASP.NET application?
>
>Wayne.
>
>
>



.

Nov 18 '05 #6

P: n/a
Local admin... local admin for that machine only. But I do get your point.
They should better design this. I don't recall VB6 requiring such
permissions.
Thanks,
Shawn

"L Wick" <an*******@discussions.microsoft.com> wrote in message
news:d4****************************@phx.gbl...
Unfortunately adding the developers to the Administrators
group isn't feasible in a classroom setting where we are
teaching asp.net programming.

-----Original Message-----
Shawn,

Doing that will give you Launch and Access DCOM

permissions to the machine
debug manager, but it doesn't give you access to be able

to debug entirely.
We have worked several issues like this, and the list of

things that must
be done in order for a non-Administrator to debug is

extensive. There is
no quick fix to make it work, and doing so is not going

to be supported by
us.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and

confers no rights.

--------------------
Reply-To: "Shawn B." <le****@html.com>
From: "Shawn B." <le****@html.com>
References: <bq**********@news.freedom2surf.net>

<WD**************@cpmsftngxa06.phx.gbl>
Subject: Re: debugging
Date: Wed, 3 Dec 2003 09:13:07 -0800
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 63.251.219.69
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl! tk2msftngp13.phx.gblXref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:194776X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Or just add your username to the "debugger users" group.
Thanks,
Shawn
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in messagenews:WD******************@cpmsftngxa06.phx.gbl.. .
Hi Wayne,

There is an MSDN article that talks about developing as a non-Administrator, but it is not supported. From the viewpoint of the ASP.NET team in PSS, you must either be an Administrator or run theASP.NET
process as your domain account via the <processModel> section of the machine.config file.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
>From: "wh" <wa***@nospam.pyesmeadow.com>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: debugging
>Date: Wed, 3 Dec 2003 15:47:45 -0000
>Organization: freedom2surf
>Lines: 6
>Message-ID: <bq**********@news.freedom2surf.net>
>NNTP-Posting-Host: 195.137.79.45
>X-Trace: news.freedom2surf.net 1070466361 11332 195.137.79.45 (3 Dec
2003
15:46:01 GMT)
>X-Complaints-To: ab***@freedom2surf.net
>NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000

(UTC) >X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165 >Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl! newsfeed00.sul.t-online.de!t-onli
n

e.de!peernews3.colt.net!news0.de.colt.net!news-

fra1.dfn.de!npeer.de.kpn-eur
o

rings.net!news-out1.newsfeeds.com!propagator2-maxim!feed-

maxim.newsfeeds.co
m
!news.freedom2surf.net!not-for-mail
>Xref: cpmsftngxa06.phx.gbl
microsoft.public.dotnet.framework.aspnet:19474 0
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Can somebody confirm that you have to be in the

Administrators group tobe
>able to debug an ASP.NET application?
>
>Wayne.
>
>
>


.

Nov 18 '05 #7

P: n/a
Shawn,

VB6 6 (and other Visual Studio 6 languages) have the same requirement.
While there are steps that can be taken to debug as a non-Administrator,
they often don't work and it's not supported.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Reply-To: "Shawn B." <le****@html.com>
From: "Shawn B." <le****@html.com>
References: <bq**********@news.freedom2surf.net> <WD**************@cpmsftngxa06.phx.gbl>
<u$*************@tk2msftngp13.phx.gbl>
<eQ**************@cpmsftngxa06.phx.gbl>
<d4****************************@phx.gbl>Subject: Re: debugging
Date: Thu, 4 Dec 2003 15:44:14 -0800
Lines: 147
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <ul**************@TK2MSFTNGP11.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 63.251.219.69
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
..phx.gbl!TK2MSFTNGP11.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:194549
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Local admin... local admin for that machine only. But I do get your point.
They should better design this. I don't recall VB6 requiring such
permissions.
Thanks,
Shawn

"L Wick" <an*******@discussions.microsoft.com> wrote in message
news:d4****************************@phx.gbl...
Unfortunately adding the developers to the Administrators
group isn't feasible in a classroom setting where we are
teaching asp.net programming.

>-----Original Message-----
>Shawn,
>
>Doing that will give you Launch and Access DCOM

permissions to the machine
>debug manager, but it doesn't give you access to be able

to debug entirely.
> We have worked several issues like this, and the list of

things that must
>be done in order for a non-Administrator to debug is

extensive. There is
>no quick fix to make it work, and doing so is not going

to be supported by
>us.
>
>Jim Cheshire, MCSE, MCSD [MSFT]
>Developer Support
>ASP.NET
>ja******@online.microsoft.com
>
>This post is provided as-is with no warranties and

confers no rights.
>
>--------------------
>>Reply-To: "Shawn B." <le****@html.com>
>>From: "Shawn B." <le****@html.com>
>>References: <bq**********@news.freedom2surf.net>
><WD**************@cpmsftngxa06.phx.gbl>
>>Subject: Re: debugging
>>Date: Wed, 3 Dec 2003 09:13:07 -0800
>>Lines: 65
>>X-Priority: 3
>>X-MSMail-Priority: Normal
>>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>>Message-ID: <u$*************@tk2msftngp13.phx.gbl>
>>Newsgroups: microsoft.public.dotnet.framework.aspnet
>>NNTP-Posting-Host: 63.251.219.69
>>Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!

tk2msftngp13.phx.gbl
>>Xref: cpmsftngxa06.phx.gbl

microsoft.public.dotnet.framework.aspnet:194776
>>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>>
>>Or just add your username to the "debugger users" group.
>>
>>
>>Thanks,
>>Shawn
>>
>>
>>"Jim Cheshire [MSFT]" <ja******@online.microsoft.com>

wrote in message
>>news:WD******************@cpmsftngxa06.phx.gbl.. .
>>> Hi Wayne,
>>>
>>> There is an MSDN article that talks about developing

as a
>>> non-Administrator, but it is not supported. From the

viewpoint of the
>>> ASP.NET team in PSS, you must either be an

Administrator or run the
>>ASP.NET
>>> process as your domain account via the <processModel>

section of the
>>> machine.config file.
>>>
>>> Jim Cheshire, MCSE, MCSD [MSFT]
>>> Developer Support
>>> ASP.NET
>>> ja******@online.microsoft.com
>>>
>>> This post is provided as-is with no warranties and

confers no rights.
>>>
>>> --------------------
>>> >From: "wh" <wa***@nospam.pyesmeadow.com>
>>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>>> >Subject: debugging
>>> >Date: Wed, 3 Dec 2003 15:47:45 -0000
>>> >Organization: freedom2surf
>>> >Lines: 6
>>> >Message-ID: <bq**********@news.freedom2surf.net>
>>> >NNTP-Posting-Host: 195.137.79.45
>>> >X-Trace: news.freedom2surf.net 1070466361 11332

195.137.79.45 (3 Dec
>2003
>>> 15:46:01 GMT)
>>> >X-Complaints-To: ab***@freedom2surf.net
>>> >NNTP-Posting-Date: Wed, 3 Dec 2003 15:46:01 +0000

(UTC)
>>> >X-Priority: 3
>>> >X-MSMail-Priority: Normal
>>> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>>> >X-MimeOLE: Produced By Microsoft MimeOLE

V6.00.2800.1165
>>> >Path:
>>>
>>cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!

newsfeed00.sul.t-online.de!t-onli
>n
>>>
>>e.de!peernews3.colt.net!news0.de.colt.net!news-

fra1.dfn.de!npeer.de.kpn-eur
>o
>>>
>>rings.net!news-out1.newsfeeds.com!propagator2-maxim!feed-

maxim.newsfeeds.co
>m
>>> !news.freedom2surf.net!not-for-mail
>>> >Xref: cpmsftngxa06.phx.gbl
>>microsoft.public.dotnet.framework.aspnet:19474 0
>>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>>> >
>>> >Can somebody confirm that you have to be in the

Administrators group to
>>be
>>> >able to debug an ASP.NET application?
>>> >
>>> >Wayne.
>>> >
>>> >
>>> >
>>>
>>
>>
>>
>
>.
>



Nov 18 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.