By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,666 Members | 1,909 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,666 IT Pros & Developers. It's quick & easy.

Working with VS.NET 2003 Question

P: n/a
Hi:
Is it possible for me to create/open web application from remote machine
other than port 80? And create application directly under virtual web site
instead of creating a virtual directory?
Because there is a developing server in our company running IIS with
multiple web sites, each one has its own port number. In real scenario, no
applications will run under virtual directory, but directly under a site.

Thanks!

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
Nov 18 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Hardy,

Just create the new Web application at a URL that points to the correct
location. For example:

http://rootsite:8080

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Hardy Wang" <ha********@marketrend.com>
Subject: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 10:22:01 -0500
Lines: 16
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
.phx.gbl!TK2MSFTNGP10.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191241
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi:
Is it possible for me to create/open web application from remote machineother than port 80? And create application directly under virtual web site
instead of creating a virtual directory?
Because there is a developing server in our company running IIS with
multiple web sites, each one has its own port number. In real scenario, no
applications will run under virtual directory, but directly under a site.

Thanks!

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy


Nov 18 '05 #2

P: n/a
Thanks!
How about not to create a virtual directory?

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:vc**************@cpmsftngxa07.phx.gbl...
Hardy,

Just create the new Web application at a URL that points to the correct
location. For example:

http://rootsite:8080

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Hardy Wang" <ha********@marketrend.com>
Subject: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 10:22:01 -0500
Lines: 16
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08 phx.gbl!TK2MSFTNGP10.phx.gbl
Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191241X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi:
Is it possible for me to create/open web application from remote

machine
other than port 80? And create application directly under virtual web siteinstead of creating a virtual directory?
Because there is a developing server in our company running IIS with
multiple web sites, each one has its own port number. In real scenario, noapplications will run under virtual directory, but directly under a site.

Thanks!

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy

Nov 18 '05 #3

P: n/a
Hardy,

If you create the application at http://server:##, it won't create a
virtual directory.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>Subject: Re: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 11:56:55 -0500
Lines: 66
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
..phx.gbl!TK2MSFTNGP12.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191289
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Thanks!
How about not to create a virtual directory?

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:vc**************@cpmsftngxa07.phx.gbl...
Hardy,

Just create the new Web application at a URL that points to the correct
location. For example:

http://rootsite:8080

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
>From: "Hardy Wang" <ha********@marketrend.com>
>Subject: Working with VS.NET 2003 Question
>Date: Wed, 19 Nov 2003 10:22:01 -0500
>Lines: 16
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0

8
phx.gbl!TK2MSFTNGP10.phx.gbl
>Xref: cpmsftngxa07.phx.gblmicrosoft.public.dotnet.framework.aspnet:191241 >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Hi:
> Is it possible for me to create/open web application from remote

machine
>other than port 80? And create application directly under virtual website >instead of creating a virtual directory?
> Because there is a developing server in our company running IIS with
>multiple web sites, each one has its own port number. In real scenario,no >applications will run under virtual directory, but directly under a site. >
> Thanks!
>
>--
>WWW: http://hardywang.1accesshost.com
>ICQ: 3359839
>yours Hardy
>
>
>



Nov 18 '05 #4

P: n/a
No, it doesn't work.

I have machine named "webserver", I created a virtual site called "Test" at
address http://webserver:500/, phyicical file is at e:\test of webserver, I
shared e drive of that machine.
Now I use my VS.NET 2003 to create web application,
http://webserver:500/Test , IF I REMOVE TEST IN LAST PART, THE OK BUTTON IS
EVEN GRAYED. Now I get error from VS.NET:
Unabled to create Web Project "Test". The file path "\\webserver\e\Test"
does not response to the Url http://webserver:500/Test. The two need to map
to the same location. HTTP error 404: Object not found.

\\webserver\e\Test could be accessed from my explorer, the folder does exist
there. I copied a manully created ASPX file to that folder, I can visit
http://webserver:500/2.aspx without any problem.

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:O5****************@cpmsftngxa07.phx.gbl...
Hardy,

If you create the application at http://server:##, it won't create a
virtual directory.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>
Subject: Re: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 11:56:55 -0500
Lines: 66
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08 phx.gbl!TK2MSFTNGP12.phx.gbl
Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191289
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Thanks!
How about not to create a virtual directory?

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:vc**************@cpmsftngxa07.phx.gbl...
Hardy,

Just create the new Web application at a URL that points to the correct
location. For example:

http://rootsite:8080

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
>From: "Hardy Wang" <ha********@marketrend.com>
>Subject: Working with VS.NET 2003 Question
>Date: Wed, 19 Nov 2003 10:22:01 -0500
>Lines: 16
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0
8 phx.gbl!TK2MSFTNGP10.phx.gbl
>Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:191241
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Hi:
> Is it possible for me to create/open web application from remote
machine
>other than port 80? And create application directly under virtual web

site
>instead of creating a virtual directory?
> Because there is a developing server in our company running IIS with >multiple web sites, each one has its own port number. In real
scenario,no
>applications will run under virtual directory, but directly under a

site. >
> Thanks!
>
>--
>WWW: http://hardywang.1accesshost.com
>ICQ: 3359839
>yours Hardy
>
>
>


Nov 18 '05 #5

P: n/a
Hardy,

When you enter the path, make sure you don't put a trailing slash. That's
the only reason that the OK button would be disabled. I assure you it
works. I've done it a thousand times.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>
<u$**************@TK2MSFTNGP12.phx.gbl>
<O5**************@cpmsftngxa07.phx.gbl>Subject: Re: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 14:50:14 -0500
Lines: 132
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <OA**************@TK2MSFTNGP11.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
.phx.gbl!TK2MSFTNGP11.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191364
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

No, it doesn't work.

I have machine named "webserver", I created a virtual site called "Test" at
address http://webserver:500/, phyicical file is at e:\test of webserver, I
shared e drive of that machine.
Now I use my VS.NET 2003 to create web application,
http://webserver:500/Test , IF I REMOVE TEST IN LAST PART, THE OK BUTTON IS
EVEN GRAYED. Now I get error from VS.NET:
Unabled to create Web Project "Test". The file path "\\webserver\e\Test"
does not response to the Url http://webserver:500/Test. The two need to map
to the same location. HTTP error 404: Object not found.

\\webserver\e\Test could be accessed from my explorer, the folder does existthere. I copied a manully created ASPX file to that folder, I can visit
http://webserver:500/2.aspx without any problem.

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:O5****************@cpmsftngxa07.phx.gbl...
Hardy,

If you create the application at http://server:##, it won't create a
virtual directory.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
>From: "Hardy Wang" <ha********@marketrend.com>
>References: <O3**************@TK2MSFTNGP10.phx.gbl>

<vc**************@cpmsftngxa07.phx.gbl>
>Subject: Re: Working with VS.NET 2003 Question
>Date: Wed, 19 Nov 2003 11:56:55 -0500
>Lines: 66
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0

8
phx.gbl!TK2MSFTNGP12.phx.gbl
>Xref: cpmsftngxa07.phx.gblmicrosoft.public.dotnet.framework.aspnet:191289 >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Thanks!
>How about not to create a virtual directory?
>
>--
>WWW: http://hardywang.1accesshost.com
>ICQ: 3359839
>yours Hardy
>"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
>news:vc**************@cpmsftngxa07.phx.gbl...
>> Hardy,
>>
>> Just create the new Web application at a URL that points to the correct >> location. For example:
>>
>> http://rootsite:8080
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> Developer Support
>> ASP.NET
>> ja******@online.microsoft.com
>>
>> This post is provided as-is with no warranties and confers no rights.
>>
>> --------------------
>> >From: "Hardy Wang" <ha********@marketrend.com>
>> >Subject: Working with VS.NET 2003 Question
>> >Date: Wed, 19 Nov 2003 10:22:01 -0500
>> >Lines: 16
>> >X-Priority: 3
>> >X-MSMail-Priority: Normal
>> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>> >Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>> >Path:
>>


cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSF TNGXA05.phx.gbl!TK2MSFTNGP 0
8
>> phx.gbl!TK2MSFTNGP10.phx.gbl
>> >Xref: cpmsftngxa07.phx.gbl
>microsoft.public.dotnet.framework.aspnet:191241
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >Hi:
>> > Is it possible for me to create/open web application from remote
>> machine
>> >other than port 80? And create application directly under virtual web
>site
>> >instead of creating a virtual directory?
>> > Because there is a developing server in our company running IIS

with >> >multiple web sites, each one has its own port number. In realscenario, >no
>> >applications will run under virtual directory, but directly under a

site.
>> >
>> > Thanks!
>> >
>> >--
>> >WWW: http://hardywang.1accesshost.com
>> >ICQ: 3359839
>> >yours Hardy
>> >
>> >
>> >
>>
>
>
>



Nov 18 '05 #6

P: n/a
A
Hi,

create the project/website http://webserver:500/Test
save your project, close it
move all the files from test dir to the top dir
"hack" the ***.csproj.webinfo and the ***.sln files, to point to the correct
(new) paths..
(delete the test application under your new website, the top is an
application in it self)
open your solution

;o)

Regards

Agge
"Hardy Wang" <ha********@marketrend.com> skrev i en meddelelse
news:OA**************@TK2MSFTNGP11.phx.gbl...
No, it doesn't work.

I have machine named "webserver", I created a virtual site called "Test" at address http://webserver:500/, phyicical file is at e:\test of webserver, I shared e drive of that machine.
Now I use my VS.NET 2003 to create web application,
http://webserver:500/Test , IF I REMOVE TEST IN LAST PART, THE OK BUTTON IS EVEN GRAYED. Now I get error from VS.NET:
Unabled to create Web Project "Test". The file path "\\webserver\e\Test"
does not response to the Url http://webserver:500/Test. The two need to map to the same location. HTTP error 404: Object not found.

\\webserver\e\Test could be accessed from my explorer, the folder does exist there. I copied a manully created ASPX file to that folder, I can visit
http://webserver:500/2.aspx without any problem.

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:O5****************@cpmsftngxa07.phx.gbl...
Hardy,

If you create the application at http://server:##, it won't create a
virtual directory.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl>

<vc**************@cpmsftngxa07.phx.gbl>
Subject: Re: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 11:56:55 -0500
Lines: 66
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
phx.gbl!TK2MSFTNGP12.phx.gbl
Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191289X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Thanks!
How about not to create a virtual directory?

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:vc**************@cpmsftngxa07.phx.gbl...
> Hardy,
>
> Just create the new Web application at a URL that points to the correct> location. For example:
>
> http://rootsite:8080
>
> Jim Cheshire, MCSE, MCSD [MSFT]
> Developer Support
> ASP.NET
> ja******@online.microsoft.com
>
> This post is provided as-is with no warranties and confers no rights.
>
> --------------------
> >From: "Hardy Wang" <ha********@marketrend.com>
> >Subject: Working with VS.NET 2003 Question
> >Date: Wed, 19 Nov 2003 10:22:01 -0500
> >Lines: 16
> >X-Priority: 3
> >X-MSMail-Priority: Normal
> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
> >Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
> >Path:
>


cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0
8
> phx.gbl!TK2MSFTNGP10.phx.gbl
> >Xref: cpmsftngxa07.phx.gbl
microsoft.public.dotnet.framework.aspnet:191241
> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >
> >Hi:
> > Is it possible for me to create/open web application from remote
> machine
> >other than port 80? And create application directly under virtual website
> >instead of creating a virtual directory?
> > Because there is a developing server in our company running IIS with> >multiple web sites, each one has its own port number. In real scenario,no
> >applications will run under virtual directory, but directly under a

site.
> >
> > Thanks!
> >
> >--
> >WWW: http://hardywang.1accesshost.com
> >ICQ: 3359839
> >yours Hardy
> >
> >
> >
>


Nov 18 '05 #7

P: n/a
Cool!!!!!

It works!!!!

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:fy**************@cpmsftngxa07.phx.gbl...
Hardy,

When you enter the path, make sure you don't put a trailing slash. That's
the only reason that the OK button would be disabled. I assure you it
works. I've done it a thousand times.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>
<u$**************@TK2MSFTNGP12.phx.gbl>
<O5**************@cpmsftngxa07.phx.gbl>
Subject: Re: Working with VS.NET 2003 Question
Date: Wed, 19 Nov 2003 14:50:14 -0500
Lines: 132
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <OA**************@TK2MSFTNGP11.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08 phx.gbl!TK2MSFTNGP11.phx.gbl
Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191364
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

No, it doesn't work.

I have machine named "webserver", I created a virtual site called "Test" ataddress http://webserver:500/, phyicical file is at e:\test of webserver, Ishared e drive of that machine.
Now I use my VS.NET 2003 to create web application,
http://webserver:500/Test , IF I REMOVE TEST IN LAST PART, THE OK BUTTON ISEVEN GRAYED. Now I get error from VS.NET:
Unabled to create Web Project "Test". The file path "\\webserver\e\Test"
does not response to the Url http://webserver:500/Test. The two need to mapto the same location. HTTP error 404: Object not found.

\\webserver\e\Test could be accessed from my explorer, the folder does

exist
there. I copied a manully created ASPX file to that folder, I can visit
http://webserver:500/2.aspx without any problem.

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:O5****************@cpmsftngxa07.phx.gbl...
Hardy,

If you create the application at http://server:##, it won't create a
virtual directory.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
>From: "Hardy Wang" <ha********@marketrend.com>
>References: <O3**************@TK2MSFTNGP10.phx.gbl>
<vc**************@cpmsftngxa07.phx.gbl>
>Subject: Re: Working with VS.NET 2003 Question
>Date: Wed, 19 Nov 2003 11:56:55 -0500
>Lines: 66
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>Path:


cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0
8 phx.gbl!TK2MSFTNGP12.phx.gbl
>Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:191289
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Thanks!
>How about not to create a virtual directory?
>
>--
>WWW: http://hardywang.1accesshost.com
>ICQ: 3359839
>yours Hardy
>"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
>news:vc**************@cpmsftngxa07.phx.gbl...
>> Hardy,
>>
>> Just create the new Web application at a URL that points to the correct >> location. For example:
>>
>> http://rootsite:8080
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> Developer Support
>> ASP.NET
>> ja******@online.microsoft.com
>>
>> This post is provided as-is with no warranties and confers no rights. >>
>> --------------------
>> >From: "Hardy Wang" <ha********@marketrend.com>
>> >Subject: Working with VS.NET 2003 Question
>> >Date: Wed, 19 Nov 2003 10:22:01 -0500
>> >Lines: 16
>> >X-Priority: 3
>> >X-MSMail-Priority: Normal
>> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>> >Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>> >Path:
>>
cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSF TNGXA05.phx.gbl!TK2MSFTNGP

0 8
>> phx.gbl!TK2MSFTNGP10.phx.gbl
>> >Xref: cpmsftngxa07.phx.gbl
>microsoft.public.dotnet.framework.aspnet:191241
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >Hi:
>> > Is it possible for me to create/open web application from remote >> machine
>> >other than port 80? And create application directly under virtual web >site
>> >instead of creating a virtual directory?
>> > Because there is a developing server in our company running IIS

with
>> >multiple web sites, each one has its own port number. In real

scenario,
>no
>> >applications will run under virtual directory, but directly under a
site.
>> >
>> > Thanks!
>> >
>> >--
>> >WWW: http://hardywang.1accesshost.com
>> >ICQ: 3359839
>> >yours Hardy
>> >
>> >
>> >
>>
>
>
>


Nov 18 '05 #8

P: n/a
I'm glad I'm not crazy. :) Glad it's working, Hardy.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Hardy Wang" <ha********@marketrend.com>
References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>
<u$**************@TK2MSFTNGP12.phx.gbl>
<O5**************@cpmsftngxa07.phx.gbl>
<OA**************@TK2MSFTNGP11.phx.gbl>
<fy**************@cpmsftngxa07.phx.gbl>Subject: Re: Working with VS.NET 2003 Question
Date: Thu, 20 Nov 2003 15:00:16 -0500
Lines: 196
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <u3**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
phx.gbl!TK2MSFTNGP12.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191652
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Cool!!!!!

It works!!!!

--
WWW: http://hardywang.1accesshost.com
ICQ: 3359839
yours Hardy
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:fy**************@cpmsftngxa07.phx.gbl...
Hardy,

When you enter the path, make sure you don't put a trailing slash. That's
the only reason that the OK button would be disabled. I assure you it
works. I've done it a thousand times.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
>From: "Hardy Wang" <ha********@marketrend.com>
>References: <O3**************@TK2MSFTNGP10.phx.gbl> <vc**************@cpmsftngxa07.phx.gbl>
<u$**************@TK2MSFTNGP12.phx.gbl>
<O5**************@cpmsftngxa07.phx.gbl>
>Subject: Re: Working with VS.NET 2003 Question
>Date: Wed, 19 Nov 2003 14:50:14 -0500
>Lines: 132
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <OA**************@TK2MSFTNGP11.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0

8
phx.gbl!TK2MSFTNGP11.phx.gbl
>Xref: cpmsftngxa07.phx.gblmicrosoft.public.dotnet.framework.aspnet:191364 >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>No, it doesn't work.
>
>I have machine named "webserver", I created a virtual site called "Test"at >address http://webserver:500/, phyicical file is at e:\test of webserver,I
>shared e drive of that machine.
>Now I use my VS.NET 2003 to create web application,
>http://webserver:500/Test , IF I REMOVE TEST IN LAST PART, THE OK BUTTONIS >EVEN GRAYED. Now I get error from VS.NET:
>Unabled to create Web Project "Test". The file path "\\webserver\e\Test"
>does not response to the Url http://webserver:500/Test. The two need tomap >to the same location. HTTP error 404: Object not found.
>
>\\webserver\e\Test could be accessed from my explorer, the folder does

exist
>there. I copied a manully created ASPX file to that folder, I can visit
>http://webserver:500/2.aspx without any problem.
>
>--
>WWW: http://hardywang.1accesshost.com
>ICQ: 3359839
>yours Hardy
>"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
>news:O5****************@cpmsftngxa07.phx.gbl...
>> Hardy,
>>
>> If you create the application at http://server:##, it won't create a
>> virtual directory.
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> Developer Support
>> ASP.NET
>> ja******@online.microsoft.com
>>
>> This post is provided as-is with no warranties and confers no rights.
>>
>>
>> --------------------
>> >From: "Hardy Wang" <ha********@marketrend.com>
>> >References: <O3**************@TK2MSFTNGP10.phx.gbl>
>> <vc**************@cpmsftngxa07.phx.gbl>
>> >Subject: Re: Working with VS.NET 2003 Question
>> >Date: Wed, 19 Nov 2003 11:56:55 -0500
>> >Lines: 66
>> >X-Priority: 3
>> >X-MSMail-Priority: Normal
>> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>> >Message-ID: <u$**************@TK2MSFTNGP12.phx.gbl>
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>> >Path:
>>


cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSF TNGXA05.phx.gbl!TK2MSFTNGP 0 8
>> phx.gbl!TK2MSFTNGP12.phx.gbl
>> >Xref: cpmsftngxa07.phx.gbl
>microsoft.public.dotnet.framework.aspnet:191289
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >Thanks!
>> >How about not to create a virtual directory?
>> >
>> >--
>> >WWW: http://hardywang.1accesshost.com
>> >ICQ: 3359839
>> >yours Hardy
>> >"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in
message >> >news:vc**************@cpmsftngxa07.phx.gbl...
>> >> Hardy,
>> >>
>> >> Just create the new Web application at a URL that points to the

correct
>> >> location. For example:
>> >>
>> >> http://rootsite:8080
>> >>
>> >> Jim Cheshire, MCSE, MCSD [MSFT]
>> >> Developer Support
>> >> ASP.NET
>> >> ja******@online.microsoft.com
>> >>
>> >> This post is provided as-is with no warranties and confers no

rights. >> >>
>> >> --------------------
>> >> >From: "Hardy Wang" <ha********@marketrend.com>
>> >> >Subject: Working with VS.NET 2003 Question
>> >> >Date: Wed, 19 Nov 2003 10:22:01 -0500
>> >> >Lines: 16
>> >> >X-Priority: 3
>> >> >X-MSMail-Priority: Normal
>> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>> >> >Message-ID: <O3**************@TK2MSFTNGP10.phx.gbl>
>> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >> >NNTP-Posting-Host: mail.marketrend.com 204.50.147.226
>> >> >Path:
>> >>
>>

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MS FTNGXA05.phx.gbl!TK2MSFTNG P 0
>> 8
>> >> phx.gbl!TK2MSFTNGP10.phx.gbl
>> >> >Xref: cpmsftngxa07.phx.gbl
>> >microsoft.public.dotnet.framework.aspnet:191241
>> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >> >
>> >> >Hi:
>> >> > Is it possible for me to create/open web application fromremote >> >> machine
>> >> >other than port 80? And create application directly under virtualweb >> >site
>> >> >instead of creating a virtual directory?
>> >> > Because there is a developing server in our company running

IIS >with
>> >> >multiple web sites, each one has its own port number. In real
>scenario,
>> >no
>> >> >applications will run under virtual directory, but directly under a >> site.
>> >> >
>> >> > Thanks!
>> >> >
>> >> >--
>> >> >WWW: http://hardywang.1accesshost.com
>> >> >ICQ: 3359839
>> >> >yours Hardy
>> >> >
>> >> >
>> >> >
>> >>
>> >
>> >
>> >
>>
>
>
>



Nov 18 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.