468,291 Members | 1,415 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,291 developers. It's quick & easy.

404 Error in ASP.NET pages under Windows Server 2003

My ASP.NET application is working fine when I run under IIS Personal Web
Server in Windows 2000 machine. However, after I upload all the files to the
Windows Server 2003 machine, and tried to run the application, it has 404
error on all .aspx files. Even I re-compile and build the whole project in
Windows Server 2003, it couldn't help.

any ideas??
Nov 17 '05 #1
4 3796
"Matthew Louden" <ma*******@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
My ASP.NET application is working fine when I run under IIS Personal Web
Server in Windows 2000 machine. However, after I upload all the files to the Windows Server 2003 machine, and tried to run the application, it has 404
error on all .aspx files. Even I re-compile and build the whole project in
Windows Server 2003, it couldn't help.

any ideas??


Re-check the web site's home directory, or if it is a virtual directory,
that it has been created.

R
Nov 17 '05 #2
By Default, Windows Server 2003 is totally locked down.
With a default installation og Windows Server 2003 with
IIS added, you will only be able to serve static pages.
You need to allow the ASP.NET application to run.

Make sure you have turned on ASP.NET for your websites.

This setting is found under IIS Manager -> Web Service
Extensions. When you click on that folder, you will see
a list of applications to the right.

Select the ASP.NET one and then click Allow.

If you plan to run Asp pages on that server you will also
want to do the same thing for ASP.

Good Luck,

Keith
-----Original Message-----
My ASP.NET application is working fine when I run under IIS Personal WebServer in Windows 2000 machine. However, after I upload all the files to theWindows Server 2003 machine, and tried to run the application, it has 404error on all .aspx files. Even I re-compile and build the whole project inWindows Server 2003, it couldn't help.

any ideas??
.

Nov 17 '05 #3
Keith:

I just went to IIS Manager -> Web Service Extensions. I clicked on that
folder, you I couldn't see ASP.NET application on the right.

I then tried to add ASPX extension in a button, but I don't know the path.

Any ideas??
"Keith" <an*******@discussions.microsoft.com> wrote in message
news:05****************************@phx.gbl...
By Default, Windows Server 2003 is totally locked down.
With a default installation og Windows Server 2003 with
IIS added, you will only be able to serve static pages.
You need to allow the ASP.NET application to run.

Make sure you have turned on ASP.NET for your websites.

This setting is found under IIS Manager -> Web Service
Extensions. When you click on that folder, you will see
a list of applications to the right.

Select the ASP.NET one and then click Allow.

If you plan to run Asp pages on that server you will also
want to do the same thing for ASP.

Good Luck,

Keith
-----Original Message-----
My ASP.NET application is working fine when I run under

IIS Personal Web
Server in Windows 2000 machine. However, after I upload

all the files to the
Windows Server 2003 machine, and tried to run the

application, it has 404
error on all .aspx files. Even I re-compile and build

the whole project in
Windows Server 2003, it couldn't help.

any ideas??
.

Nov 17 '05 #4
Here is what you should have by default...

All Unknown CGI Extensions
All Unknown ISAPI Extensions
Active Server pages
ASP.NET v1.1.4322
Front Page Server Extensions 2002
Internet Data Connector
Server Side Includes
WebDAV

If you are missing the ASP.NET v1.1.4322 you may need to
go back through and manage your application server.

I probably should have asked what version of 2003 that
you are using also. This applies to Standard and
Enterprise edition. I haven't installed Web edition, so
I am not real sure how it works. Any way you look at it,
You should have all of these for IIS. If you don't, you
will need to manage that aspect of the server. It sounds
like ASP.NET was not installed on your server at all.
Once that gets installed you can allow ASP.NET pages.

Keith
-----Original Message-----
Keith:

I just went to IIS Manager -> Web Service Extensions. I clicked on thatfolder, you I couldn't see ASP.NET application on the right.
I then tried to add ASPX extension in a button, but I don't know the path.
Any ideas??
"Keith" <an*******@discussions.microsoft.com> wrote in messagenews:05****************************@phx.gbl...
By Default, Windows Server 2003 is totally locked down.
With a default installation og Windows Server 2003 with
IIS added, you will only be able to serve static pages.
You need to allow the ASP.NET application to run.

Make sure you have turned on ASP.NET for your websites.

This setting is found under IIS Manager -> Web Service
Extensions. When you click on that folder, you will see a list of applications to the right.

Select the ASP.NET one and then click Allow.

If you plan to run Asp pages on that server you will also want to do the same thing for ASP.

Good Luck,

Keith
>-----Original Message-----
>My ASP.NET application is working fine when I run
under IIS Personal Web
>Server in Windows 2000 machine. However, after I
upload all the files to the
>Windows Server 2003 machine, and tried to run the

application, it has 404
>error on all .aspx files. Even I re-compile and build

the whole project in
>Windows Server 2003, it couldn't help.
>
>any ideas??
>
>
>.
>

.

Nov 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Morten Gulbrandsen | last post: by
6 posts views Thread by Peter Frost | last post: by
1 post views Thread by Keith | last post: by
reply views Thread by Matthew Louden | last post: by
3 posts views Thread by Matthew Louden | last post: by
3 posts views Thread by Angelo Brusati | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.