By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,412 Members | 993 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,412 IT Pros & Developers. It's quick & easy.

Web.config file

P: n/a
Hello,
The file structure on the server is:

/FileUpload
- Web.config
- upload.aspx

I try to run the upload.aspx but it gives me a runtime error message like
this:
----------------
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
--------------

Web.config file is like this:
---------
<configuration>

<system.web>
<customErrors mode="Off"/>
</system.web>

</configuration>
-----------

The same file works on my local server. What can be the reason?

Nov 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Have you modified the web.config file, with the tag: <customErrors
mode="Off"/>

For security purposes, ASP.NET will only show errors when you view the site
on the local machine. In your case, as you are viewing the files from a
server, you need to turn off the custom errors, so that you can see the
error message, which will help you to debug the problem.

Hope this helps,

Mun


"Murat Dikici" <mu***@websty.net> wrote in message
news:Ok**************@TK2MSFTNGP10.phx.gbl...
Hello,
The file structure on the server is:

/FileUpload
- Web.config
- upload.aspx

I try to run the upload.aspx but it gives me a runtime error message like
this:
----------------
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
--------------

Web.config file is like this:
---------
<configuration>

<system.web>
<customErrors mode="Off"/>
</system.web>

</configuration>
-----------

The same file works on my local server. What can be the reason?

Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.