By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,133 Members | 1,113 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,133 IT Pros & Developers. It's quick & easy.

Server error in blank webservice

P: n/a
Hello all,

I don't know what to do anymore, I thought I was not coding my stuff
correctly, but I am having problems with Visual Studio it seems. When I
create a new webservice on my local machine, remove the comments around the
Hello World service and build it, everything works fine. Then, when I do the
same on a remote server, it gives me the error message below.

One thing I noticed is that I have to open the new project on the remote
machine using frontpage server extensions. Other than that, I am not doing
anything differently on my local machine than I am doing on the server. Does
anyone have a solution for this problem?

Here's the error message:
Server Error in '/MyTest' Application.
----------------------------------------------------------------------------
----

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'MyTest.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="MyTest.Global" %>
Source File: c:\inetpub\wwwroot\MyTest\global.asax Line: 1
----------------------------------------------------------------------------
----
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET
Version:1.1.4322.573
Nov 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Have you checked that the "bin" folder exists in the
C:\inetpub\wwwroot\MyTest folder, and that the ASPNET user has access to it?
It might be easier to test things by manually FTP'ing your webservice files
to the server rather than using frontpage server extensions.

Mun

"Daniel Rimmelzwaan" <ri*********@xhotmail.com> wrote in message
news:eY**************@TK2MSFTNGP10.phx.gbl...
Hello all,

I don't know what to do anymore, I thought I was not coding my stuff
correctly, but I am having problems with Visual Studio it seems. When I
create a new webservice on my local machine, remove the comments around the Hello World service and build it, everything works fine. Then, when I do the same on a remote server, it gives me the error message below.

One thing I noticed is that I have to open the new project on the remote
machine using frontpage server extensions. Other than that, I am not doing
anything differently on my local machine than I am doing on the server. Does anyone have a solution for this problem?

Here's the error message:
Server Error in '/MyTest' Application.
-------------------------------------------------------------------------- -- ----

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'MyTest.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="MyTest.Global" %>
Source File: c:\inetpub\wwwroot\MyTest\global.asax Line: 1
-------------------------------------------------------------------------- -- ----
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573

Nov 17 '05 #2

P: n/a
Do you mean develop this project on my local machine and when it's built
copying it to the server? That may work for this particular project, but at
some point we'll be working on things in a team, so this should be resolved
at some point.

All folders exist on the server by the way, and the dll is created. I tried
deleting the dll and rebuilding the project, but it still didn't work.

Is there maybe a setting that I can change on the server so it lets me just
create the solution there?

"Munsifali Rashid" <mun@**RemoveToReply**vefuk.com> wrote in message
news:%2***************@tk2msftngp13.phx.gbl...
Have you checked that the "bin" folder exists in the
C:\inetpub\wwwroot\MyTest folder, and that the ASPNET user has access to it? It might be easier to test things by manually FTP'ing your webservice files to the server rather than using frontpage server extensions.

Mun

"Daniel Rimmelzwaan" <ri*********@xhotmail.com> wrote in message
news:eY**************@TK2MSFTNGP10.phx.gbl...
Hello all,

I don't know what to do anymore, I thought I was not coding my stuff
correctly, but I am having problems with Visual Studio it seems. When I
create a new webservice on my local machine, remove the comments around

the
Hello World service and build it, everything works fine. Then, when I do

the
same on a remote server, it gives me the error message below.

One thing I noticed is that I have to open the new project on the remote
machine using frontpage server extensions. Other than that, I am not doing anything differently on my local machine than I am doing on the server.

Does
anyone have a solution for this problem?

Here's the error message:
Server Error in '/MyTest' Application.


--------------------------------------------------------------------------
--
----

Parser Error
Description: An error occurred during the parsing of a resource required

to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'MyTest.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="MyTest.Global" %>
Source File: c:\inetpub\wwwroot\MyTest\global.asax Line: 1


--------------------------------------------------------------------------
--
----
Version Information: Microsoft .NET Framework Version:1.1.4322.573;

ASP.NET
Version:1.1.4322.573


Nov 17 '05 #3

P: n/a
Alright, I just got off the phone with MS support and they were able to
solve this for me. It turned out that a line was missing from my
machine.config file in the Microsoft.NET\Framework\v1.1.4322\CONFIG folder.
In this file, a statement must be there that says <add assembly="*"/>, which
makes the framework look in the bin folder of this particular project when
it creates an instance of the application (or something to that effect).

Just thought I'd share that with you. Thanks for your time.
Daniel.

"Daniel Rimmelzwaan" <ri*********@xhotmail.com> wrote in message
news:eY**************@TK2MSFTNGP10.phx.gbl...
Hello all,

I don't know what to do anymore, I thought I was not coding my stuff
correctly, but I am having problems with Visual Studio it seems. When I
create a new webservice on my local machine, remove the comments around the Hello World service and build it, everything works fine. Then, when I do the same on a remote server, it gives me the error message below.

One thing I noticed is that I have to open the new project on the remote
machine using frontpage server extensions. Other than that, I am not doing
anything differently on my local machine than I am doing on the server. Does anyone have a solution for this problem?

Here's the error message:
Server Error in '/MyTest' Application.
-------------------------------------------------------------------------- -- ----

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'MyTest.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="MyTest.Global" %>
Source File: c:\inetpub\wwwroot\MyTest\global.asax Line: 1
-------------------------------------------------------------------------- -- ----
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573

Nov 17 '05 #4

P: n/a
Hmm, interesting. I would've thought that Visual Studio would automatically
add this information, or that it would be a default setting in
machine.config, to use the assemblies in the bin folder.

Good to hear you got it sorted out though :-)

Mun

"Daniel Rimmelzwaan" <ri*********@xhotmail.com> wrote in message
news:uo**************@tk2msftngp13.phx.gbl...
Alright, I just got off the phone with MS support and they were able to
solve this for me. It turned out that a line was missing from my
machine.config file in the Microsoft.NET\Framework\v1.1.4322\CONFIG folder. In this file, a statement must be there that says <add assembly="*"/>, which makes the framework look in the bin folder of this particular project when
it creates an instance of the application (or something to that effect).

Just thought I'd share that with you. Thanks for your time.
Daniel.


Nov 17 '05 #5

P: n/a
I suspect that this was removed during installation of Microsoft CRM, which
is a security (and any other type) hell for developers. I've been having all
sorts of weird errors on my server ever since we installed it.

"Munsifali Rashid" <mun@**RemoveToReply**vefuk.com> wrote in message
news:eH*************@TK2MSFTNGP11.phx.gbl...
Hmm, interesting. I would've thought that Visual Studio would automatically add this information, or that it would be a default setting in
machine.config, to use the assemblies in the bin folder.

Good to hear you got it sorted out though :-)

Mun

"Daniel Rimmelzwaan" <ri*********@xhotmail.com> wrote in message
news:uo**************@tk2msftngp13.phx.gbl...
Alright, I just got off the phone with MS support and they were able to
solve this for me. It turned out that a line was missing from my
machine.config file in the Microsoft.NET\Framework\v1.1.4322\CONFIG

folder.
In this file, a statement must be there that says <add assembly="*"/>,

which
makes the framework look in the bin folder of this particular project when it creates an instance of the application (or something to that effect).

Just thought I'd share that with you. Thanks for your time.
Daniel.


Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.