By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,501 Members | 1,660 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,501 IT Pros & Developers. It's quick & easy.

Cannot view any .aspx page without .aspx.cs present

P: n/a
I am using .Net 2003 on a XPPro running IIS.

I am unable to view any of my ASPX webforms in a browser
unless I modify the .ASPX file
and replace Codebehind="employee.aspx.cs" with
src="employee.aspx.cs".

It looks like my bin/employee.dll file is not being used.
Instead, my employee.aspx.cs file
is being used.

Why is my .dll file being ignored?

These problems are happening on all of my ASP.Net
webforms.

Here's what I tried to get my webforms working. #1:)
should work but doesn't #2:) works but why?
Also, the following is true if I try to place my forms
into production or attempt to view
them in development.

1:) I created a new virtual directory and placed my
employee.aspx and web.config and bin/employee.dll
files into the virtual directory. I then tried to view
employee.aspx in a browser but get the
Server Error message below.

2:) I then copied my employee.aspx.CS file to the virtual
directory and changed the employee.aspx
line: Codebehind="employee.aspx.cs" to
src="employee.aspx.cs". I then tried to view my
..aspx page in a browser and now everything works! It
doesn't even matter if my employee.dll file
is in the virtual directory root or bin/. I can even
delete my .dll file and the page still
works as long as the .aspx.cs file is in the root. Also,
the src="employee.aspx.cs" has to be
there otherwise I get a Parser Error message.

What does this mean? How can I get my Asp.net
applications to work normally without the need for
the src= in the .aspx file?

Any ideas?

Thanks,

Jerry
----------------------------------------------------------
----------------------
Server Error in '/test1' Application.
----------------------------------------------------------
----------------------

Runtime Error
Description: An application error occurred on the server.
The current custom
error settings for this application prevent the details
of the application error
from being viewed remotely (for security reasons). It
could, however, be viewed
by browsers running on the local server machine.

Details: To enable the details of this specific error
message to be viewable on
remote machines, please create a <customErrors> tag
within a "web.config" configuration
file located in the root directory of the current web
application. This <customErrors>
tag should then have its "mode" attribute set to "Off".

Nov 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Jerry,

Did you follow the instructions in the error message you received? You'll
need to do that in order for us to know what the error is.

Jim Cheshire [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Content-Class: urn:content-classes:message
From: "Jerry Tovar" <Je********@Msn.Com>
Sender: "Jerry Tovar" <Je********@Msn.Com>
Subject: Cannot view any .aspx page without .aspx.cs present
Date: Thu, 23 Oct 2003 07:49:52 -0700
Lines: 74
Message-ID: <0a****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
Thread-Index: AcOZdOqt7tNuX5EcQiq49+oIB4MUkg==
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:186060
NNTP-Posting-Host: TK2MSFTNGXA14 10.40.1.166
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

I am using .Net 2003 on a XPPro running IIS.

I am unable to view any of my ASPX webforms in a browser
unless I modify the .ASPX file
and replace Codebehind="employee.aspx.cs" with
src="employee.aspx.cs".

It looks like my bin/employee.dll file is not being used.
Instead, my employee.aspx.cs file
is being used.

Why is my .dll file being ignored?

These problems are happening on all of my ASP.Net
webforms.

Here's what I tried to get my webforms working. #1:)
should work but doesn't #2:) works but why?
Also, the following is true if I try to place my forms
into production or attempt to view
them in development.

1:) I created a new virtual directory and placed my
employee.aspx and web.config and bin/employee.dll
files into the virtual directory. I then tried to view
employee.aspx in a browser but get the
Server Error message below.

2:) I then copied my employee.aspx.CS file to the virtual
directory and changed the employee.aspx
line: Codebehind="employee.aspx.cs" to
src="employee.aspx.cs". I then tried to view my
.aspx page in a browser and now everything works! It
doesn't even matter if my employee.dll file
is in the virtual directory root or bin/. I can even
delete my .dll file and the page still
works as long as the .aspx.cs file is in the root. Also,
the src="employee.aspx.cs" has to be
there otherwise I get a Parser Error message.

What does this mean? How can I get my Asp.net
applications to work normally without the need for
the src= in the .aspx file?

Any ideas?

Thanks,

Jerry
----------------------------------------------------------
----------------------
Server Error in '/test1' Application.
----------------------------------------------------------
----------------------

Runtime Error
Description: An application error occurred on the server.
The current custom
error settings for this application prevent the details
of the application error
from being viewed remotely (for security reasons). It
could, however, be viewed
by browsers running on the local server machine.

Details: To enable the details of this specific error
message to be viewable on
remote machines, please create a <customErrors> tag
within a "web.config" configuration
file located in the root directory of the current web
application. This <customErrors>
tag should then have its "mode" attribute set to "Off".


Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.