By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,446 Members | 2,998 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,446 IT Pros & Developers. It's quick & easy.

Parser Error on the base project created by Visual Studio

P: n/a
CES
All,
I've just started to use VBStudio, up tell now I've coded with note pad, so
this is all new to me. I'm trying to create my first project but I'm running
into problems.

I've created a base ASP.net web application and used the default name
WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build the
project by going to File Menu Build\Build Solution (Ctr+Shift+B) :

In the Output window I get:

------ Build started: Project: WebApplication1, Configuration: Debug
..NET ------
Preparing resources...
Updating references...
Performing main compilation...
Building satellite assemblies...
---------------------- Done ----------------------
Build: 1 succeeded, 0 failed, 0 skipped
I then when I hit F5 to run the project, and IE displays this Parser Error
message:

Parser Error Message: Could not load type 'WebApplication1.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="WebApplication1.Global" %>

Source File: \\server\\_temp\WebApplication1\global.asax Line: 1

I've checked the security privileges on the WebApplication1 and the
"aspnet_wp account" and the "Internet Guest Account" have "Full Control"
access. Additionally the "aspnet_wp account" has full privileges on
Windows\Microsoft.NET\Framework\v1.1.4322 and
WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.

The only way I can get the page WebForm1.aspx to load and not throw an error
is by removing both of the Inherits properties from these files:

WebForm1.aspx:
<%@ Page Language="vb" AutoEventWireup="false"
Inherits="WebApplication1.WebForm1"%>

Global.asax:
<%@ Application Codebehind="Global.asax.vb"
Inherits="WebApplication1.Global" %>

But that doesn't seem to make any sense, if the page won't work as is why
are the Inherits="WebApplication1.WebForm1 and
Inherits="WebApplication1.Global" setup by default???

Is it me or am I doing something wrong???
Nov 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi,

[...]
Is it me or am I doing something wrong???


I think you should configure your web directory in IIS as application.

Cheers,
--
Maras
Nov 17 '05 #2

P: n/a
CES
I"m not sure what you mean but Application Settings under the Home Directory
Tab for the web site have values of
Application Name : Default Application
Starting point: <Default Web Site>
Execute Permissions: Scripts Only
Application Protection: Medium (Pooled)

Which are the defaults.

CES

"Maras" <m.********@nospam.wp.pl> wrote in message
news:bm**********@news.onet.pl...
Hi,

[...]
Is it me or am I doing something wrong???


I think you should configure your web directory in IIS as application.

Cheers,
--
Maras

Nov 17 '05 #3

P: n/a
try running aspnet_regiis.exe -c
it sits in
c:\WINNT\Microsoft.NET\Framework\v1.0.3705\
or wherever your framework is installed
"CES" <NO**@NOEMAIL.com> wrote in message
news:O3*************@TK2MSFTNGP10.phx.gbl...
I"m not sure what you mean but Application Settings under the Home Directory Tab for the web site have values of
Application Name : Default Application
Starting point: <Default Web Site>
Execute Permissions: Scripts Only
Application Protection: Medium (Pooled)

Which are the defaults.

CES

"Maras" <m.********@nospam.wp.pl> wrote in message
news:bm**********@news.onet.pl...
Hi,

[...]
Is it me or am I doing something wrong???


I think you should configure your web directory in IIS as application.

Cheers,
--
Maras


Nov 17 '05 #4

P: n/a
CES
George,
Tried your suggestion but I'm still getting the error message...I did
however isolate the problem to IIS and not the code (I copied the
application to me web site and it runs just fine).

Any other suggestions would be appreciated.
CES

"George Durzi" <gdurzi@nospam_hotmail.com> wrote in message
news:%2***************@TK2MSFTNGP09.phx.gbl...
try running aspnet_regiis.exe -c
it sits in
c:\WINNT\Microsoft.NET\Framework\v1.0.3705\
or wherever your framework is installed
"CES" <NO**@NOEMAIL.com> wrote in message
news:O3*************@TK2MSFTNGP10.phx.gbl...
I"m not sure what you mean but Application Settings under the Home

Directory
Tab for the web site have values of
Application Name : Default Application
Starting point: <Default Web Site>
Execute Permissions: Scripts Only
Application Protection: Medium (Pooled)

Which are the defaults.

CES

"Maras" <m.********@nospam.wp.pl> wrote in message
news:bm**********@news.onet.pl...
Hi,

[...]

> Is it me or am I doing something wrong???

I think you should configure your web directory in IIS as application.

Cheers,
--
Maras



Nov 17 '05 #5

P: n/a
CES
All,
I've started a new threed please reply their - Setting up a Web Application
on IIS 5.1
CES
"CES" <NO**@NOEMAIL.com> wrote in message
news:uo**************@TK2MSFTNGP10.phx.gbl...
All,
I've just started to use VBStudio, up tell now I've coded with note pad, so this is all new to me. I'm trying to create my first project but I'm running into problems.

I've created a base ASP.net web application and used the default name
WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build the project by going to File Menu Build\Build Solution (Ctr+Shift+B) :

In the Output window I get:

------ Build started: Project: WebApplication1, Configuration: Debug
.NET ------
Preparing resources...
Updating references...
Performing main compilation...
Building satellite assemblies...
---------------------- Done ----------------------
Build: 1 succeeded, 0 failed, 0 skipped
I then when I hit F5 to run the project, and IE displays this Parser Error
message:

Parser Error Message: Could not load type 'WebApplication1.Global'.

Source Error:

Line 1: <%@ Application Codebehind="Global.asax.vb"
Inherits="WebApplication1.Global" %>

Source File: \\server\\_temp\WebApplication1\global.asax Line: 1

I've checked the security privileges on the WebApplication1 and the
"aspnet_wp account" and the "Internet Guest Account" have "Full Control"
access. Additionally the "aspnet_wp account" has full privileges on
Windows\Microsoft.NET\Framework\v1.1.4322 and
WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.

The only way I can get the page WebForm1.aspx to load and not throw an error is by removing both of the Inherits properties from these files:

WebForm1.aspx:
<%@ Page Language="vb" AutoEventWireup="false"
Inherits="WebApplication1.WebForm1"%>

Global.asax:
<%@ Application Codebehind="Global.asax.vb"
Inherits="WebApplication1.Global" %>

But that doesn't seem to make any sense, if the page won't work as is why
are the Inherits="WebApplication1.WebForm1 and
Inherits="WebApplication1.Global" setup by default???

Is it me or am I doing something wrong???

Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.