By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,166 Members | 1,370 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,166 IT Pros & Developers. It's quick & easy.

Breakpoint is ignored

P: n/a
I set a breakpoint in a project, however the breakpoint is ignored. This was
in the TimeTracker project from the Asp.Net site.

I added it at the Login method of the TTUser class (TTUser.vb). I know I
have the right insertion point where I want to begin stepping, because I
changed "return username" to "return string.empty", and even when I put in
the right login info, it doesn't let me enter the app. So this test told me
that I have the right point.

So right click to the left window of "userName =
CStr(SqlHelper.ExecuteScalar..." and select Insert Breakpoint.

Then when I login, the app takes me to the project hours entry page without
stopping.

Why is the breakpoint ignored? Is it possible to step through the app?

Nov 17 '05 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Tim,

You are running the code in debug mode breakpoints are ignored in
release mode.

Ken
--------------
"Tim Cali" <Ca******@yahoo.com> wrote in message
news:eo**************@TK2MSFTNGP10.phx.gbl...
I set a breakpoint in a project, however the breakpoint is ignored. This was in the TimeTracker project from the Asp.Net site.

I added it at the Login method of the TTUser class (TTUser.vb). I know I
have the right insertion point where I want to begin stepping, because I
changed "return username" to "return string.empty", and even when I put in
the right login info, it doesn't let me enter the app. So this test told me that I have the right point.

So right click to the left window of "userName =
CStr(SqlHelper.ExecuteScalar..." and select Insert Breakpoint.

Then when I login, the app takes me to the project hours entry page without stopping.

Why is the breakpoint ignored? Is it possible to step through the app?


Nov 17 '05 #2

P: n/a
I don't understand. Please tell me what I must do to remedy this. (Newbie
here)

"Ken Tucker" <vb***@bellsouth.net> wrote in message
news:uq**************@TK2MSFTNGP10.phx.gbl...
Tim,

You are running the code in debug mode breakpoints are ignored in
release mode.

Ken
--------------
"Tim Cali" <Ca******@yahoo.com> wrote in message
news:eo**************@TK2MSFTNGP10.phx.gbl...
I set a breakpoint in a project, however the breakpoint is ignored. This

was
in the TimeTracker project from the Asp.Net site.

I added it at the Login method of the TTUser class (TTUser.vb). I know I
have the right insertion point where I want to begin stepping, because I
changed "return username" to "return string.empty", and even when I put in the right login info, it doesn't let me enter the app. So this test told

me
that I have the right point.

So right click to the left window of "userName =
CStr(SqlHelper.ExecuteScalar..." and select Insert Breakpoint.

Then when I login, the app takes me to the project hours entry page

without
stopping.

Why is the breakpoint ignored? Is it possible to step through the app?



Nov 17 '05 #3

P: n/a
Tim Cali wrote:
I don't understand. Please tell me what I must do to remedy this. (Newbie
here)

"Ken Tucker" <vb***@bellsouth.net> wrote in message
news:uq**************@TK2MSFTNGP10.phx.gbl...
Tim,

You are running the code in debug mode breakpoints are ignored in
release mode.

Ken
--------------
"Tim Cali" <Ca******@yahoo.com> wrote in message
news:eo**************@TK2MSFTNGP10.phx.gbl...
I set a breakpoint in a project, however the breakpoint is ignored. This


was
in the TimeTracker project from the Asp.Net site.

I added it at the Login method of the TTUser class (TTUser.vb). I know I
have the right insertion point where I want to begin stepping, because I
changed "return username" to "return string.empty", and even when I put
in
the right login info, it doesn't let me enter the app. So this test told


me
that I have the right point.

So right click to the left window of "userName =
CStr(SqlHelper.ExecuteScalar..." and select Insert Breakpoint.

Then when I login, the app takes me to the project hours entry page


without
stopping.

Why is the breakpoint ignored? Is it possible to step through the app?




I think he was trying to say make sure your IDE is running in Debug
mode, not Release mode. Also, when you're running, do your breakpoints
show up as red dots, or do they also have question marks (?) inside the
red dot? If there are ?, then it's not running with debug symbols
loaded. Make sure you build and run in Debug mode.
--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET

Nov 17 '05 #4

P: n/a
"Craig Deelsnyder" <cd******@NOSPAMyahoo.com> schrieb:
I think he was trying to say make sure your IDE is running
in Debug mode, not Release mode. Also, when you're running,
do your breakpoints show up as red dots, or do they also have
question marks (?) inside the red dot? If there are ?, then it's
not running with debug symbols loaded. Make sure you
build and run in Debug mode.


Notice that it's possible to switch between Release and Debug mode with a
combobox embedded in the toolbar of VS.NET.

--
Herfried K. Wagner
MVP VB Classic, VB.NET
<http://www.mvps.org/dotnet>
Nov 17 '05 #5

P: n/a
Ok, thanks. The app is in debug mode, so the problem persists.

Is there anything else I can try?

Does it matter that this is an asp.net app? I activate it in IE through
http:// localhost/ttwebvbvs
"Craig Deelsnyder" <cd******@NOSPAMyahoo.com> wrote in message
news:#r*************@tk2msftngp13.phx.gbl...
Tim Cali wrote:
I don't understand. Please tell me what I must do to remedy this. (Newbie here)
I think he was trying to say make sure your IDE is running in Debug
mode, not Release mode. Also, when you're running, do your breakpoints
show up as red dots, or do they also have question marks (?) inside the
red dot? If there are ?, then it's not running with debug symbols
loaded. Make sure you build and run in Debug mode.
--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET

Nov 17 '05 #6

P: n/a
Are you saying you brought up the web browser and typed "http://
localhost/ttwebvbvs" into the address bar?

If so, the debugger has now idea you have done this, how could it?

You must either run the app through the IDE (by pressing F5) or use the
attach to process under the Debug|Processes menu.

Pressing F5 is definitely the easier route.
Good luck
Brian W

"Tim Cali" <Ca******@yahoo.com> wrote in message
news:uT**************@TK2MSFTNGP10.phx.gbl...
Ok, thanks. The app is in debug mode, so the problem persists.

Is there anything else I can try?

Does it matter that this is an asp.net app? I activate it in IE through
http:// localhost/ttwebvbvs
"Craig Deelsnyder" <cd******@NOSPAMyahoo.com> wrote in message
news:#r*************@tk2msftngp13.phx.gbl...
Tim Cali wrote:
I don't understand. Please tell me what I must do to remedy this. (Newbie here)

I think he was trying to say make sure your IDE is running in Debug
mode, not Release mode. Also, when you're running, do your breakpoints
show up as red dots, or do they also have question marks (?) inside the
red dot? If there are ?, then it's not running with debug symbols
loaded. Make sure you build and run in Debug mode.
--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET


Nov 17 '05 #7

P: n/a
> Are you saying you brought up the web browser and typed "http://
localhost/ttwebvbvs" into the address bar?
Yes
If so, the debugger has now idea you have done this, how could it?
Why wouldn't it? Is this a fully compiled application? I'm from the VBA
world (newbie to .Net).
Pressing F5 is definitely the easier route.
Ok, so I do this, and I see the message:
"Running the project requires setting an initial web page. To set this page,
right-click the desired page in the Solution Explorer and select "Set As
Start Page".

Ok, so I select some page, and do that, but still get that message, no
matter which page I set as start page.


"Brian W" <brianw@gold_death_2_spam_rush.com> wrote in message
news:O$**************@TK2MSFTNGP10.phx.gbl... Are you saying you brought up the web browser and typed "http://
localhost/ttwebvbvs" into the address bar?

If so, the debugger has now idea you have done this, how could it?

You must either run the app through the IDE (by pressing F5) or use the
attach to process under the Debug|Processes menu.

Pressing F5 is definitely the easier route.
Good luck
Brian W

"Tim Cali" <Ca******@yahoo.com> wrote in message
news:uT**************@TK2MSFTNGP10.phx.gbl...
Ok, thanks. The app is in debug mode, so the problem persists.

Is there anything else I can try?

Does it matter that this is an asp.net app? I activate it in IE through
http:// localhost/ttwebvbvs
"Craig Deelsnyder" <cd******@NOSPAMyahoo.com> wrote in message
news:#r*************@tk2msftngp13.phx.gbl...
Tim Cali wrote:

> I don't understand. Please tell me what I must do to remedy this.

(Newbie
> here)
>

I think he was trying to say make sure your IDE is running in Debug
mode, not Release mode. Also, when you're running, do your breakpoints show up as red dots, or do they also have question marks (?) inside the red dot? If there are ?, then it's not running with debug symbols
loaded. Make sure you build and run in Debug mode.
--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET



Nov 17 '05 #8

P: n/a
Cor
Hi Tim,
I would make in this case a new empty Asp.net application.
And would put then in the page load event from the created webform only the
syntax
\\\
dim test as integer = 1
///
I would set a breakpoint on that and run in debug mode, it's a simple test,
but then I would know if my system was working in the right way.

Cor
Nov 17 '05 #9

P: n/a
Thanks. Yes, it is working. I added a breakpoint like you suggested it,
F5'ed the new asp.net app's Web Form, and VS stopped on that line.
Then I F10'ed through the line.

"Cor" <no*@non.com> wrote in message
news:3f***********************@reader22.wxs.nl...
Hi Tim,
I would make in this case a new empty Asp.net application.
And would put then in the page load event from the created webform only the syntax
\\\
dim test as integer = 1
///
I would set a breakpoint on that and run in debug mode, it's a simple test, but then I would know if my system was working in the right way.

Cor

Nov 17 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.