471,075 Members | 749 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,075 software developers and data experts.

Debugging problem

I've been unable to debug a .NET web application with Visual Studio.
Every time I try to run it, I get the error message:

Error while trying to run project: Unable to start debugging on the
web server. Server side-error occurred on sending debug HTTP request.

I know there are several posts from users who experienced the same
problem, but none of the solutions are working for me. Based on
information I read in previous posts, the gotdotnet and microsoft
websites, as well as VS help, I have tried the following things:
-Added new account ASPNET and ensured that process aspnet_wp.exe is
running.

-Verified that web.config is properly formed with no syntax errors and
has the debug attribute set to true.

-Reinstalled the dotnet framework

-Verified IIS security settings and gave the web application a name in
the Properties dialog box for the application.
I'm running Windows XP Pro with IIS 5.1. If anyone has any other
suggestions on how to resolve the problem, please let me know.

Thanks,

Kevin
Nov 17 '05 #1
6 1920
Tap
Do you have permission set for that application folder on
the IIS ?
-----Original Message-----
I've been unable to debug a .NET web application with Visual Studio.Every time I try to run it, I get the error message:

Error while trying to run project: Unable to start debugging on theweb server. Server side-error occurred on sending debug HTTP request.
I know there are several posts from users who experienced the sameproblem, but none of the solutions are working for me. Based oninformation I read in previous posts, the gotdotnet and microsoftwebsites, as well as VS help, I have tried the following things:

-Added new account ASPNET and ensured that process aspnet_wp.exe isrunning.

-Verified that web.config is properly formed with no syntax errors andhas the debug attribute set to true.

-Reinstalled the dotnet framework

-Verified IIS security settings and gave the web application a name inthe Properties dialog box for the application.
I'm running Windows XP Pro with IIS 5.1. If anyone has any othersuggestions on how to resolve the problem, please let me know.
Thanks,

Kevin
.

Nov 17 '05 #2
I have it set to allow for anonymous access and integrated Windows
authentication. Is this what you are referring to?
"Tap" <em***@email.com> wrote in message news:<00****************************@phx.gbl>...
Do you have permission set for that application folder on
the IIS ?
-----Original Message-----
I've been unable to debug a .NET web application with

Visual Studio.
Every time I try to run it, I get the error message:

Error while trying to run project: Unable to start

debugging on the
web server. Server side-error occurred on sending debug

HTTP request.

I know there are several posts from users who experienced

the same
problem, but none of the solutions are working for me.

Based on
information I read in previous posts, the gotdotnet and

microsoft
websites, as well as VS help, I have tried the following

things:


-Added new account ASPNET and ensured that process

aspnet_wp.exe is
running.

-Verified that web.config is properly formed with no

syntax errors and
has the debug attribute set to true.

-Reinstalled the dotnet framework

-Verified IIS security settings and gave the web

application a name in
the Properties dialog box for the application.
I'm running Windows XP Pro with IIS 5.1. If anyone has

any other
suggestions on how to resolve the problem, please let me

know.

Thanks,

Kevin
.

Nov 17 '05 #3
Is your ASPNET account a memeber of the Debugger Users and VS Developers
groups?
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
I have it set to allow for anonymous access and integrated Windows
authentication. Is this what you are referring to?
"Tap" <em***@email.com> wrote in message

news:<00****************************@phx.gbl>...
Do you have permission set for that application folder on
the IIS ?
-----Original Message-----
I've been unable to debug a .NET web application with

Visual Studio.
Every time I try to run it, I get the error message:

Error while trying to run project: Unable to start

debugging on the
web server. Server side-error occurred on sending debug

HTTP request.

I know there are several posts from users who experienced

the same
problem, but none of the solutions are working for me.

Based on
information I read in previous posts, the gotdotnet and

microsoft
websites, as well as VS help, I have tried the following

things:


-Added new account ASPNET and ensured that process

aspnet_wp.exe is
running.

-Verified that web.config is properly formed with no

syntax errors and
has the debug attribute set to true.

-Reinstalled the dotnet framework

-Verified IIS security settings and gave the web

application a name in
the Properties dialog box for the application.
I'm running Windows XP Pro with IIS 5.1. If anyone has

any other
suggestions on how to resolve the problem, please let me

know.

Thanks,

Kevin
.

Nov 17 '05 #4
I'm not sure.. how do I verify this?

"Scott M." <s-***@badspamsnet.net> wrote in message news:<#$*************@TK2MSFTNGP10.phx.gbl>...
Is your ASPNET account a memeber of the Debugger Users and VS Developers
groups?
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
I have it set to allow for anonymous access and integrated Windows
authentication. Is this what you are referring to?
"Tap" <em***@email.com> wrote in message

news:<00****************************@phx.gbl>...
Do you have permission set for that application folder on
the IIS ?

>-----Original Message-----
>I've been unable to debug a .NET web application with Visual Studio. >Every time I try to run it, I get the error message:
>
>Error while trying to run project: Unable to start debugging on the >web server. Server side-error occurred on sending debug HTTP request. >
>I know there are several posts from users who experienced the same >problem, but none of the solutions are working for me. Based on >information I read in previous posts, the gotdotnet and microsoft >websites, as well as VS help, I have tried the following things: >
>
>-Added new account ASPNET and ensured that process aspnet_wp.exe is >running.
>
>-Verified that web.config is properly formed with no syntax errors and >has the debug attribute set to true.
>
>-Reinstalled the dotnet framework
>
>-Verified IIS security settings and gave the web application a name in >the Properties dialog box for the application.
>
>
>I'm running Windows XP Pro with IIS 5.1. If anyone has any other >suggestions on how to resolve the problem, please let me know. >
>Thanks,
>
>Kevin
>.
>

Nov 17 '05 #5
On the machine that has the ASPNET account, go into Control Panel and then
Administrative Tools then Computer Management.

Once there expand the Local Users And Groups section. Under Users, double
click the ASPNET account and look at the tab called Member Of.

By default, the ASPNET account is not a member of the Debugger Users or VS
Developers groups, so don't be surprised to not see these groups listed.

If they are not listed, then go into the Groups section and then the
Debugger Users group. Add the ASPNET account to that group, then repeat the
process for the VS Developers group.

Hope this helps!
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
I'm not sure.. how do I verify this?

"Scott M." <s-***@badspamsnet.net> wrote in message

news:<#$*************@TK2MSFTNGP10.phx.gbl>...
Is your ASPNET account a memeber of the Debugger Users and VS Developers
groups?
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
I have it set to allow for anonymous access and integrated Windows
authentication. Is this what you are referring to?
"Tap" <em***@email.com> wrote in message

news:<00****************************@phx.gbl>...
> Do you have permission set for that application folder on
> the IIS ?
>
> >-----Original Message-----
> >I've been unable to debug a .NET web application with

Visual Studio.
> >Every time I try to run it, I get the error message:
> >
> >Error while trying to run project: Unable to start

debugging on the
> >web server. Server side-error occurred on sending debug

HTTP request.
> >
> >I know there are several posts from users who experienced

the same
> >problem, but none of the solutions are working for me.

Based on
> >information I read in previous posts, the gotdotnet and

microsoft
> >websites, as well as VS help, I have tried the following

things:
> >
> >
> >-Added new account ASPNET and ensured that process

aspnet_wp.exe is
> >running.
> >
> >-Verified that web.config is properly formed with no

syntax errors and
> >has the debug attribute set to true.
> >
> >-Reinstalled the dotnet framework
> >
> >-Verified IIS security settings and gave the web

application a name in
> >the Properties dialog box for the application.
> >
> >
> >I'm running Windows XP Pro with IIS 5.1. If anyone has

any other
> >suggestions on how to resolve the problem, please let me

know.
> >
> >Thanks,
> >
> >Kevin
> >.
> >

Nov 17 '05 #6
Scott,

I added ASPNET to the Debugger Users and VS Developers groups as you
instructed, and rebooted. I tried to run the program again, but still
got the same error. I have verified that the ASPNET account was added
to both groups correctly, and don't know what else to check at this
point. Do you have any other suggestions?

Thanks for your help,

Kevin
"Scott M." <s-***@badspamsnet.net> wrote in message news:<uC**************@tk2msftngp13.phx.gbl>...
On the machine that has the ASPNET account, go into Control Panel and then
Administrative Tools then Computer Management.

Once there expand the Local Users And Groups section. Under Users, double
click the ASPNET account and look at the tab called Member Of.

By default, the ASPNET account is not a member of the Debugger Users or VS
Developers groups, so don't be surprised to not see these groups listed.

If they are not listed, then go into the Groups section and then the
Debugger Users group. Add the ASPNET account to that group, then repeat the
process for the VS Developers group.

Hope this helps!
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
I'm not sure.. how do I verify this?

"Scott M." <s-***@badspamsnet.net> wrote in message

news:<#$*************@TK2MSFTNGP10.phx.gbl>...
Is your ASPNET account a memeber of the Debugger Users and VS Developers
groups?
"Kevin" <ke******@imvlimited.com> wrote in message
news:d3**************************@posting.google.c om...
> I have it set to allow for anonymous access and integrated Windows
> authentication. Is this what you are referring to?
>
>
> "Tap" <em***@email.com> wrote in message news:<00****************************@phx.gbl>... > > Do you have permission set for that application folder on
> > the IIS ?
> >
> > >-----Original Message-----
> > >I've been unable to debug a .NET web application with Visual Studio. > > >Every time I try to run it, I get the error message:
> > >
> > >Error while trying to run project: Unable to start debugging on the > > >web server. Server side-error occurred on sending debug HTTP request. > > >
> > >I know there are several posts from users who experienced the same > > >problem, but none of the solutions are working for me. Based on > > >information I read in previous posts, the gotdotnet and microsoft > > >websites, as well as VS help, I have tried the following things: > > >
> > >
> > >-Added new account ASPNET and ensured that process aspnet_wp.exe is > > >running.
> > >
> > >-Verified that web.config is properly formed with no syntax errors and > > >has the debug attribute set to true.
> > >
> > >-Reinstalled the dotnet framework
> > >
> > >-Verified IIS security settings and gave the web application a name in > > >the Properties dialog box for the application.
> > >
> > >
> > >I'm running Windows XP Pro with IIS 5.1. If anyone has any other > > >suggestions on how to resolve the problem, please let me know. > > >
> > >Thanks,
> > >
> > >Kevin
> > >.
> > >

Nov 17 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Don Hans | last post: by
16 posts views Thread by Serdar Kalaycý | last post: by
2 posts views Thread by Alex Clark | last post: by
1 post views Thread by Jason Smith | last post: by
3 posts views Thread by Yves Gagnon | last post: by
reply views Thread by leo001 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.