By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,394 Members | 1,443 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,394 IT Pros & Developers. It's quick & easy.

Deploy ASPX, browse, get HTTP Error 404

P: n/a
I have an asp.net application. I have used VStudio Web
Deployment Project to create the MSI file. I copy the
MSI file from my developer PC to my test server running
Win2003Server Web Edition. I run the MSI to install -
looks good so far - I see the global directory, etc.
I try opening the app in IE via www.myweb.com/aspxfolder;
where aspxfolder is the global directory. I get the
wonderful "HTTP Error 404 - File or directory not found"
page. So, I created a test.html file in the same global
directory and browsed to
www.myweb.com/aspxfolder/test.html - and I see my test
HTML. So, this has to be some type of aspx installation
or aspx execution security issue???? I am not sure where
to start because I basically accepted all defaults on
installation of w2003WE and the web deployment project in
VS.NET.
Help? Thanks!
-Larry

Nov 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
You're browsing to the folder?
That means IIS serves up the default page for the folder, normally
default.asp
The Start Page in the Web Project and the default page in IIS can and often
are different.

Try browsing to an aspx page like you did with the html.
I suspect IIS is serving up default.asp and you don't have a page in your
project by that name.

-fs

"Larry Brindise" <la*********@tradegear.com> wrote in message
news:03****************************@phx.gbl...
I have an asp.net application. I have used VStudio Web
Deployment Project to create the MSI file. I copy the
MSI file from my developer PC to my test server running
Win2003Server Web Edition. I run the MSI to install -
looks good so far - I see the global directory, etc.
I try opening the app in IE via www.myweb.com/aspxfolder;
where aspxfolder is the global directory. I get the
wonderful "HTTP Error 404 - File or directory not found"
page. So, I created a test.html file in the same global
directory and browsed to
www.myweb.com/aspxfolder/test.html - and I see my test
HTML. So, this has to be some type of aspx installation
or aspx execution security issue???? I am not sure where
to start because I basically accepted all defaults on
installation of w2003WE and the web deployment project in
VS.NET.
Help? Thanks!
-Larry

Nov 17 '05 #2

P: n/a
Thanks for the attempt.
Actually, the VS.NET web deployment wizard is really
smart. It actually sets the default page in the global
directory to default.aspx, so you don't even have to mess
with that.

Whether I browse to the folder (expecting the default
page to be loaded), or I browse explicitly to that
page ".../default.aspx", I get the same problematic
result.
I've gone over the IIS configs - the fact that I can
browse to my test.html proves it is not that iis doesn't
like the folder configs. I'm convinced it has to be
something with aspx security.

-Larry
-----Original Message-----
You're browsing to the folder?
That means IIS serves up the default page for the folder, normallydefault.asp
The Start Page in the Web Project and the default page in IIS can and oftenare different.

Try browsing to an aspx page like you did with the html.
I suspect IIS is serving up default.asp and you don't have a page in yourproject by that name.

-fs

"Larry Brindise" <la*********@tradegear.com> wrote in messagenews:03****************************@phx.gbl...
I have an asp.net application. I have used VStudio Web
Deployment Project to create the MSI file. I copy the
MSI file from my developer PC to my test server running
Win2003Server Web Edition. I run the MSI to install -
looks good so far - I see the global directory, etc.
I try opening the app in IE via www.myweb.com/aspxfolder; where aspxfolder is the global directory. I get the
wonderful "HTTP Error 404 - File or directory not found" page. So, I created a test.html file in the same global directory and browsed to
www.myweb.com/aspxfolder/test.html - and I see my test
HTML. So, this has to be some type of aspx installation or aspx execution security issue???? I am not sure where to start because I basically accepted all defaults on
installation of w2003WE and the web deployment project in VS.NET.
Help? Thanks!
-Larry

.

Nov 17 '05 #3

P: n/a
I truly appreciate your persistence. I already checked
both of these. This is really unexpected, however, it is
the first asp.net app I'm deploying, so I don't know what
to expect. I'll post a response here when I get the
answer - perhaps it'll cost me $245.
-Larry
-----Original Message-----
If it's security related, you could check your web.config for authorizationsection.
Should have something like:
allow = "*"
in there.
If it was security I'd expect you to get either redirected as per yourweb.config Authentication settings or an access denied before you'd get a404 (not found).

sorry can't help any more than that.
-fs

"Larry Brindise" <la*********@tradegear.com> wrote in messagenews:02****************************@phx.gbl...
Thanks for the attempt.
Actually, the VS.NET web deployment wizard is really
smart. It actually sets the default page in the global
directory to default.aspx, so you don't even have to mess with that.

Whether I browse to the folder (expecting the default
page to be loaded), or I browse explicitly to that
page ".../default.aspx", I get the same problematic
result.
I've gone over the IIS configs - the fact that I can
browse to my test.html proves it is not that iis doesn't like the folder configs. I'm convinced it has to be
something with aspx security.

-Larry
>-----Original Message-----
>You're browsing to the folder?
>That means IIS serves up the default page for the

folder, normally
>default.asp
>The Start Page in the Web Project and the default page

in IIS can and often
>are different.
>
>Try browsing to an aspx page like you did with the html. >I suspect IIS is serving up default.asp and you don't

have a page in your
>project by that name.
>
>-fs
>
>
>
>"Larry Brindise" <la*********@tradegear.com> wrote in

message
>news:03****************************@phx.gbl...
>> I have an asp.net application. I have used VStudio Web >> Deployment Project to create the MSI file. I copy the >> MSI file from my developer PC to my test server running >> Win2003Server Web Edition. I run the MSI to install - >> looks good so far - I see the global directory, etc.
>> I try opening the app in IE via

www.myweb.com/aspxfolder;
>> where aspxfolder is the global directory. I get the
>> wonderful "HTTP Error 404 - File or directory not

found"
>> page. So, I created a test.html file in the same

global
>> directory and browsed to
>> www.myweb.com/aspxfolder/test.html - and I see my test >> HTML. So, this has to be some type of aspx

installation
>> or aspx execution security issue???? I am not sure

where
>> to start because I basically accepted all defaults on >> installation of w2003WE and the web deployment
project in
>> VS.NET.
>> Help? Thanks!
>> -Larry
>>
>
>
>.
>

.

Nov 17 '05 #4

P: n/a
Are the actual files in the actual directory? If you use Windows Explorer -
are they under \inetpub\wwwroot\aspxfolder ???
"Larry Brindise" <la*********@tradegear.com> wrote in message
news:07****************************@phx.gbl...
I truly appreciate your persistence. I already checked
both of these. This is really unexpected, however, it is
the first asp.net app I'm deploying, so I don't know what
to expect. I'll post a response here when I get the
answer - perhaps it'll cost me $245.
-Larry
-----Original Message-----
If it's security related, you could check your

web.config for authorization
section.
Should have something like:
allow = "*"
in there.
If it was security I'd expect you to get either

redirected as per your
web.config Authentication settings or an access denied

before you'd get a
404 (not found).

sorry can't help any more than that.
-fs

"Larry Brindise" <la*********@tradegear.com> wrote in

message
news:02****************************@phx.gbl...
Thanks for the attempt.
Actually, the VS.NET web deployment wizard is really
smart. It actually sets the default page in the global
directory to default.aspx, so you don't even have to mess with that.

Whether I browse to the folder (expecting the default
page to be loaded), or I browse explicitly to that
page ".../default.aspx", I get the same problematic
result.
I've gone over the IIS configs - the fact that I can
browse to my test.html proves it is not that iis doesn't like the folder configs. I'm convinced it has to be
something with aspx security.

-Larry
>-----Original Message-----
>You're browsing to the folder?
>That means IIS serves up the default page for the
folder, normally
>default.asp
>The Start Page in the Web Project and the default page
in IIS can and often
>are different.
>
>Try browsing to an aspx page like you did with the html. >I suspect IIS is serving up default.asp and you don't
have a page in your
>project by that name.
>
>-fs
>
>
>
>"Larry Brindise" <la*********@tradegear.com> wrote in
message
>news:03****************************@phx.gbl...
>> I have an asp.net application. I have used VStudio Web >> Deployment Project to create the MSI file. I copy the >> MSI file from my developer PC to my test server running >> Win2003Server Web Edition. I run the MSI to install - >> looks good so far - I see the global directory, etc.
>> I try opening the app in IE via
www.myweb.com/aspxfolder;
>> where aspxfolder is the global directory. I get the
>> wonderful "HTTP Error 404 - File or directory not
found"
>> page. So, I created a test.html file in the same
global
>> directory and browsed to
>> www.myweb.com/aspxfolder/test.html - and I see my test >> HTML. So, this has to be some type of aspx
installation
>> or aspx execution security issue???? I am not sure
where
>> to start because I basically accepted all defaults on >> installation of w2003WE and the web deployment project in
>> VS.NET.
>> Help? Thanks!
>> -Larry
>>
>
>
>.
>

.


Nov 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.