468,161 Members | 1,952 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,161 developers. It's quick & easy.

Framework 1.0 ad 1.1 running side by side configuration problems?

All,
I deployed my website that requires V1.1 in the
production server. I installed the framework v1.1 with
the dotnetfx.exe /c:"install /noaspupgrade" and
everything went fine.

Then, I installed my app via and installation pkg.
without a proble,
Then, I ran the following command to tell IIS to run my
app with V1.1
aspnet_regiis.exe w3svc\1\1root\Myapp
which did the job.

However, when I try to run it it gives me a blank page:
Page caanot be displayed
.....
....
TTP Error 500.

Q1. How can I make visible the actual error rather than
the default error page?
Q2. Should be 2 separate ASP.Net processes running for
the 2 diiferent versions: aspnet_wp.exe?
Q3. Do I need to configure something on the IIS?

I remembered that when I installed V1.0 long time ago, I
had to start the aspnet_wp.exe manually for the fist
time.

PS: I deployed the same app in two other testing-servers
and they worked fine. However, they only had V1.1
installed.
Nov 17 '05 #1
5 1789
Hi Juan,

I have reviewed your issue. Due to the nature of your issue I need to do
additional research to determine the best way to provide assistance.

Best regards,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! ¨C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 17 '05 #2
Jacob,
Thank you for your effort. Actually, the problem is
that I'm running both framework versions side by side in
the same server. When I installed the V1.1 I did it
as "noaspupgrade" not to affect any website on the
server. In order to make my website use the new release I
had to run the aspnet_regiis.exe w3svc\1\1root\Myapp from
the new release directory. Thus, when I see the
properties for this website it DOES reflect the change;
however, when I run it (Login.aspx) It does not egt
serviced (Page cannot be displayed. Error on the server)

Thank you for your help in advance.
JP

-----Original Message-----
Hi Juan,

Based on my research and experience, I want to share the following information with you:

1. To see the more information about the error message, please try to configure the Internet Explorer script debugging options. To do this, follow these steps:

1) Open Internet Explorer.
2) On the "Tools" menu, click "Internet Options".
3) In the "Internet Options" dialog box, click "Advanced".4) Click to clear the "Disable script debugging " check box.5) Click to select the "Display a notification about every script error" check box.
6) Click "OK".

2. To check and configure which .NET Framework is used in IIS, please perform the following steps:

1) Open "Internet Information Services".
2) Right click the folder of your web application and select "Properties".3) In the Directory tab, click the "Configuration¡*" button.4) Select the ".aspx" extension and double click it.
5) In the field of "Executable", you will find which version aspnet_isapi.dll is used.
6) If you want to change it, please click the "Browse¡*" button.
Does it answer your question? If I have misunderstood your concern, please let me know.

Best regards,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! ¨C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.
.

Nov 17 '05 #3
Hi,

check if isapifilter of the site/computer is set to the 1.1 framework.

Natty Gur, CTO
Dao2Com Ltd.
34th Elkalay st. Raanana
Israel , 43000
Phone Numbers:
Office: +972-(0)9-7740261
Fax: +972-(0)9-7740261
Mobile: +972-(0)58-888377
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #4
HI Juan,

Please perform the following steps on your side and tell me if you see any
new error message:

1) Open Internet Explorer.
2) On the "Tools" menu, click "Internet Options".
3) In the "Internet Options" dialog box, click "Advanced".
4) Click to clear the "Show friendly HTTP error messages " check box.
5) Click "Apply" and "OK".
6) Test your web application again

Best regrds,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! ¨C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 17 '05 #5
HI Juan,

Please perform the following steps on your side and tell me if you see any
new error message:

1) Open Internet Explorer.
2) On the "Tools" menu, click "Internet Options".
3) In the "Internet Options" dialog box, click "Advanced".
4) Click to clear the "Show friendly HTTP error messages " check box.
5) Click "Apply" and "OK".
6) Test your web application again

Best regrds,

Jacob Yang
Microsoft Online Partner Support
<MCSD>
Get Secure! ¨C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Richard | last post: by
10 posts views Thread by Aaron | last post: by
29 posts views Thread by =?Utf-8?B?SGVybWF3aWg=?= | last post: by
13 posts views Thread by dancer | last post: by
reply views Thread by kamranasdasdas | last post: by
reply views Thread by gcreed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.