468,535 Members | 1,657 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,535 developers. It's quick & easy.

"Access to performance data was denied.."

"... to ASPNet as attempted from C:\WINNT\System32\WBEM\WinMgmt.exe."

This error keeps appearing in the Windows 2000 Server Event Viewer.

Any ideas on what's causing this or how to prevent it?

Thanks,
Craig Santoli
Nov 17 '05 #1
2 6795
Craig Hi,

Windows 2000 limits WMI-data access to Windows 2000 administrators. If
you attempt to access information from an unprivileged account, the
Application log records the following event:

Event ID 1000 Source Perflib
Description:
Access to performance data was denied to ASPNet as attempted from
C:\WINNT\System32\WinMgmt.exe


Natty Gur, CTO
Dao2Com Ltd.
34th Elkalay st. Raanana
Israel , 43000
Phone Numbers:
Office: +972-(0)9-7740261
Fax: +972-(0)9-7740261
Mobile: +972-(0)58-888377
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #2
I also started seeing a lot of these (in my case, after installing MSFT
Reporting Services).

As Natty implied, the fix is to give the ASPNET user access to the WMI
API. You can do this like so:

Open the "Computer Management" app
Expand the "Services and Applications" section
Right-click the "WMI Control" entry & select "Properties"
Go to the "Security" tab
Expand the "Root" node and then select the "WMI" node
Click the "Security" button
Add the "ASPNET" user & give it access

In my case, at least, restarting the ReportServer service was required
for this change to take effect.

Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

8 posts views Thread by Frances Del Rio | last post: by
1 post views Thread by Winterminute | last post: by
6 posts views Thread by ASP.Confused | last post: by
reply views Thread by ASP.Confused | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.