470,636 Members | 1,430 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,636 developers. It's quick & easy.

debugger not automatically attaching aspnet_wp.exe as a debugged process


Hi--

All of sudden (?) the VS.NET v1 IDE is NOT automatically attaching
aspnet_wp.exe as a debugged process.

Why?

Here is the situation.

VS.NET (v1)

Framework (latest version)

VB.NET code

ASP.NET application

Run code in IDE by choosing >Debug, >Start.

Code launches.

Go to the IDE, choose >Debug, >Processes.

The process "aspnet_wp.exe" is listed in the "Available Processes" list but
it is NOT listed in the "Debugged Processes" list.

It should be in the "Debugged Processes" list automatically!!!

As a result, the code will NOT hit any breakpoints.

How can this be fixed?

(Note that I know that I can select "aspnet_wp.exe" in the "Available
Processes" list and choose >Attach, >Common Language Runtime, and the
breakpoints will work and the process will become listed in the "Debugged
Processes" list. However, one should not have to set this manually every
time.)

Any ideas?

Please advise.

Thank you very much.

--Mark


Nov 17 '05 #1
1 4582
Hi Mark,

In your project properties, do you have ASP.NET Debugging enabled?

Jim Cheshire [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Reply-To: "Mark Kamoski" <mk******@yahoo.com>
From: "Mark Kamoski" <mk******@yahoo.com>
Subject: debugger not automatically attaching aspnet_wp.exe as a debugged processDate: Fri, 1 Aug 2003 18:03:51 -0400
Lines: 50
Organization: Mark Kamoski
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <#H*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 12.0.36.32
Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftn gp13.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:164266
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
Hi--

All of sudden (?) the VS.NET v1 IDE is NOT automatically attaching
aspnet_wp.exe as a debugged process.

Why?

Here is the situation.

VS.NET (v1)

Framework (latest version)

VB.NET code

ASP.NET application

Run code in IDE by choosing >Debug, >Start.

Code launches.

Go to the IDE, choose >Debug, >Processes.

The process "aspnet_wp.exe" is listed in the "Available Processes" list but
it is NOT listed in the "Debugged Processes" list.

It should be in the "Debugged Processes" list automatically!!!

As a result, the code will NOT hit any breakpoints.

How can this be fixed?

(Note that I know that I can select "aspnet_wp.exe" in the "Available
Processes" list and choose >Attach, >Common Language Runtime, and the
breakpoints will work and the process will become listed in the "Debugged
Processes" list. However, one should not have to set this manually every
time.)

Any ideas?

Please advise.

Thank you very much.

--Mark



Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Saradhi | last post: by
reply views Thread by Jim Heavey | last post: by
2 posts views Thread by Leo | last post: by
1 post views Thread by the_kiddie98 | last post: by
2 posts views Thread by seagul01729 | last post: by
reply views Thread by Arpan | last post: by
1 post views Thread by Korara | last post: by
???
reply views Thread by Stoney L | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.