469,568 Members | 1,676 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,568 developers. It's quick & easy.

Trying to start an application

Hi,

I've upgraded to .NET 2003 and I opened an .NET 2002 app
and let the new IDE convert it to .NET 2003 project.

Then I tried to start the application but it keeps on
saying "Error while trying to run project. Unable to start
debugging on the web server. The project is not configured
to be debugged. Click Help for more information".

I click Help and in web.config I have debug="true", but it
also says that the debug verb should be associated
with .aspx. But you can't see any example on that in the
help section how to accomplish the debug verb.

Anyone that can help me start an application?

TIA

/Kenneth
Nov 17 '05 #1
5 1593
Kenneth,

I doubt that DEBUG is not mapped to ASPX, but you can check that by
right-clicking your application in IIS, clicking properties, clicking the
Home Directory tab (or Directory if it's the root site), clicking the
Configuration button, and making sure that DEBUG appears in the list of
verbs for ASPX.

It is also possible that your execute permissions are not set to Scripts
Only. You'll want to check that as well.

Hope that helps.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Content-Class: urn:content-classes:message
From: "Kenneth" <ke***********@chello.se>
Sender: "Kenneth" <ke***********@chello.se>
Subject: Trying to start an application
Date: Wed, 30 Jul 2003 01:42:58 -0700
Lines: 20
Message-ID: <0a****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Thread-Index: AcNWdpPzdp3fCAsYT2edGc5rxBooow==
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163268
NNTP-Posting-Host: TK2MSFTNGXA09 10.40.1.161
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi,

I've upgraded to .NET 2003 and I opened an .NET 2002 app
and let the new IDE convert it to .NET 2003 project.

Then I tried to start the application but it keeps on
saying "Error while trying to run project. Unable to start
debugging on the web server. The project is not configured
to be debugged. Click Help for more information".

I click Help and in web.config I have debug="true", but it
also says that the debug verb should be associated
with .aspx. But you can't see any example on that in the
help section how to accomplish the debug verb.

Anyone that can help me start an application?

TIA

/Kenneth


Nov 17 '05 #2
Jim,

The Configuration button is disabled, so I can't check
that. By right-clicking my app in IIS, do you mean that I
right-click the directory where the app resides or what do
you mean?

My execute permissions are set to Scripts only.

/Kenneth
-----Original Message-----
Kenneth,

I doubt that DEBUG is not mapped to ASPX, but you can check that byright-clicking your application in IIS, clicking properties, clicking theHome Directory tab (or Directory if it's the root site), clicking theConfiguration button, and making sure that DEBUG appears in the list ofverbs for ASPX.

It is also possible that your execute permissions are not set to ScriptsOnly. You'll want to check that as well.

Hope that helps.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
Content-Class: urn:content-classes:message
From: "Kenneth" <ke***********@chello.se>
Sender: "Kenneth" <ke***********@chello.se>
Subject: Trying to start an application
Date: Wed, 30 Jul 2003 01:42:58 -0700
Lines: 20
Message-ID: <0a****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Thread-Index: AcNWdpPzdp3fCAsYT2edGc5rxBooow==
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163268NNTP-Posting-Host: TK2MSFTNGXA09 10.40.1.161
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi,

I've upgraded to .NET 2003 and I opened an .NET 2002 app
and let the new IDE convert it to .NET 2003 project.

Then I tried to start the application but it keeps on
saying "Error while trying to run project. Unable to startdebugging on the web server. The project is not configuredto be debugged. Click Help for more information".

I click Help and in web.config I have debug="true", but italso says that the debug verb should be associated
with .aspx. But you can't see any example on that in the
help section how to accomplish the debug verb.

Anyone that can help me start an application?

TIA

/Kenneth


.

Nov 17 '05 #3
Kenneth,

If the Configuration button is disabled, it means that you haven't set that
folder as an app root.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Content-Class: urn:content-classes:message
From: "Kenneth" <ke***********@chello.se>
Sender: "Kenneth" <ke***********@chello.se>
References: <0a****************************@phx.gbl> <fY**************@cpmsftngxa06.phx.gbl>Subject: RE: Trying to start an application
Date: Wed, 30 Jul 2003 13:13:54 -0700
Lines: 87
Message-ID: <06****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Thread-Index: AcNW1xmmTcKhzxJ9S8SzNvZjpCM+VQ==
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163543
NNTP-Posting-Host: TK2MSFTNGXA09 10.40.1.161
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Jim,

The Configuration button is disabled, so I can't check
that. By right-clicking my app in IIS, do you mean that I
right-click the directory where the app resides or what do
you mean?

My execute permissions are set to Scripts only.

/Kenneth
-----Original Message-----
Kenneth,

I doubt that DEBUG is not mapped to ASPX, but you can

check that by
right-clicking your application in IIS, clicking

properties, clicking the
Home Directory tab (or Directory if it's the root site),

clicking the
Configuration button, and making sure that DEBUG appears

in the list of
verbs for ASPX.

It is also possible that your execute permissions are not

set to Scripts
Only. You'll want to check that as well.

Hope that helps.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and

confers no rights.

--------------------
Content-Class: urn:content-classes:message
From: "Kenneth" <ke***********@chello.se>
Sender: "Kenneth" <ke***********@chello.se>
Subject: Trying to start an application
Date: Wed, 30 Jul 2003 01:42:58 -0700
Lines: 20
Message-ID: <0a****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Thread-Index: AcNWdpPzdp3fCAsYT2edGc5rxBooow==
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gblmicrosoft.public.dotnet.framework.aspnet:163268NNTP-Posting-Host: TK2MSFTNGXA09 10.40.1.161
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Hi,

I've upgraded to .NET 2003 and I opened an .NET 2002 app
and let the new IDE convert it to .NET 2003 project.

Then I tried to start the application but it keeps on
saying "Error while trying to run project. Unable tostartdebugging on the web server. The project is notconfiguredto be debugged. Click Help for more information".

I click Help and in web.config I have debug="true", butitalso says that the debug verb should be associated
with .aspx. But you can't see any example on that in the
help section how to accomplish the debug verb.

Anyone that can help me start an application?

TIA

/Kenneth


.


Nov 17 '05 #4
Jim,

I guess I should do things in a certain order, should I?

First create a new website in IIS, then create a new
project in VS.NET that points to the newly cretaed website?

/Kenneth

-----Original Message-----
Kenneth,

If the Configuration button is disabled, it means that you haven't set thatfolder as an app root.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com


Nov 17 '05 #5
Kenneth,

It depends. If you want to create a new Web site (a new virtual server)
and create a new application at the root of that Web site, you can
certainly do that. You just need to make sure that on the Directory tab,
the application is created. When it is, the button at the bottom will say
"Remove". If the button says "Create", you need to click it to create the
app root.

When you create a new ASP.NET application from VS.NET, if the FrontPage
Server Extensions are on the Web server, they will be used to create the
new application, set the app root, and set the executable bit, regardless
of what you are using for Web Access Mode in VS.NET. If the Server
Extensions are not there, we will use ADSI calls from VS.NET to do the same
thing. In both cases, the app root should be set.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
Content-Class: urn:content-classes:message
From: "Kenneth" <ke***********@chello.se>
Sender: "Kenneth" <ke***********@chello.se>
References: <0a****************************@phx.gbl> <fY**************@cpmsftngxa06.phx.gbl>
<06****************************@phx.gbl>
<O$**************@cpmsftngxa06.phx.gbl>Subject: RE: Trying to start an application
Date: Wed, 30 Jul 2003 22:51:21 -0700
Lines: 23
Message-ID: <55****************************@phx.gbl>
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Thread-Index: AcNXJ8SWUbQQIm53Q3aI8mA3EfrCdg==
Newsgroups: microsoft.public.dotnet.framework.aspnet
Path: cpmsftngxa06.phx.gbl
Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163647
NNTP-Posting-Host: TK2MSFTNGXA08 10.40.1.160
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Jim,

I guess I should do things in a certain order, should I?

First create a new website in IIS, then create a new
project in VS.NET that points to the newly cretaed website?

/Kenneth

-----Original Message-----
Kenneth,

If the Configuration button is disabled, it means that

you haven't set that
folder as an app root.

Jim Cheshire
Developer Support
ASP.NET
ja******@online.microsoft.com



Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Frank Wilson | last post: by
reply views Thread by suresh191 | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.