470,636 Members | 1,477 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,636 developers. It's quick & easy.

Identity System

Hi,

How can i get my ASP Page or Web Service to run as the LocalSystem rather
than a user?

cheers
Nov 17 '05 #1
7 1290
The default user for all apps is set in your machine.config file in your
local .NET installation folder (in a folder called config). If you look in
that file, in the <processModel> section user="machine" is pry what is set
right now. You can change that to SYSTEM as you want, but it is highly
recommended you don't do that (for security reasons). But it's your call.

In addition, I'm not sure, you may be able to define this in your local
web.config also, and thus override the machine.config setting. Haven't
investigated that myself, so dunno if you can do on an app by app basis...

Another alternative is to use impersonation, and set the user you want all
visitors to run under....

--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET
"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
news:uB**************@tk2msftngp13.phx.gbl...
Hi,

How can i get my ASP Page or Web Service to run as the LocalSystem rather
than a user?

cheers

Nov 17 '05 #2
Hi,

I think what you meant is ASP.NET impersonation.

You could add a line in web.config to run an application as a configurable identity. For example:

<identity impersonate="true" userName="contoso\Jane" password="pass"/>

Please refer to http://msdn.microsoft.com/library/en...asp?frame=true for details.

Thanks very much.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!References: <uB**************@tk2msftngp13.phx.gbl>
!Subject: Re: Identity System
!Date: Sun, 27 Jul 2003 20:26:12 -0500
!Lines: 30
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:162483
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!The default user for all apps is set in your machine.config file in your
!local .NET installation folder (in a folder called config). If you look in
!that file, in the <processModel> section user="machine" is pry what is set
!right now. You can change that to SYSTEM as you want, but it is highly
!recommended you don't do that (for security reasons). But it's your call.
!
!In addition, I'm not sure, you may be able to define this in your local
!web.config also, and thus override the machine.config setting. Haven't
!investigated that myself, so dunno if you can do on an app by app basis...
!
!Another alternative is to use impersonation, and set the user you want all
!visitors to run under....
!
!--
!Craig Deelsnyder
!Microsoft MVP - ASP/ASP.NET
!
!
!"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!news:uB**************@tk2msftngp13.phx.gbl...
!> Hi,
!>
!> How can i get my ASP Page or Web Service to run as the LocalSystem rather
!> than a user?
!>
!> cheers
!>
!>
!
!
!
Nov 17 '05 #3
One other thing....

how to i get my application to run with the rights of the local system
account? What would i enter in the username & password (in the web.config
file).

again....many thanks

Arran

"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
news:PP**************@cpmsftngxa06.phx.gbl...
Hello Arran,

You are welcome. Thanks very much for participating the community.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
!From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!References: <uB**************@tk2msftngp13.phx.gbl> <#7**************@TK2MSFTNGP12.phx.gbl> <Tm**************@cpmsftngxa06.phx.gbl>
!Subject: Re: Identity System
!Date: Tue, 29 Jul 2003 08:50:15 +0100
!Lines: 88
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
!Message-ID: <#s**************@TK2MSFTNGP09.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: 212.219.119.220
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:162908 !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!Thanks for the info.
!
!
!
!"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!news:Tm**************@cpmsftngxa06.phx.gbl...
!> Hi,
!>
!> I think what you meant is ASP.NET impersonation.
!>
!> You could add a line in web.config to run an application as a configurable !identity. For example:
!>
!> <identity impersonate="true" userName="contoso\Jane" password="pass"/>
!>
!> Please refer to
!http://msdn.microsoft.com/library/en...netimpersonati
o !n.asp?frame=true for details.
!>
!> Thanks very much.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!> !References: <uB**************@tk2msftngp13.phx.gbl>
!> !Subject: Re: Identity System
!> !Date: Sun, 27 Jul 2003 20:26:12 -0500
!> !Lines: 30
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:162483
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !The default user for all apps is set in your machine.config file in your !> !local .NET installation folder (in a folder called config). If you look !in
!> !that file, in the <processModel> section user="machine" is pry what is
!set
!> !right now. You can change that to SYSTEM as you want, but it is highly !> !recommended you don't do that (for security reasons). But it's your
!call.
!> !
!> !In addition, I'm not sure, you may be able to define this in your local !> !web.config also, and thus override the machine.config setting. Haven't !> !investigated that myself, so dunno if you can do on an app by app
!basis...
!> !
!> !Another alternative is to use impersonation, and set the user you want
!all
!> !visitors to run under....
!> !
!> !--
!> !Craig Deelsnyder
!> !Microsoft MVP - ASP/ASP.NET
!> !
!> !
!> !"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!> !news:uB**************@tk2msftngp13.phx.gbl...
!> !> Hi,
!> !>
!> !> How can i get my ASP Page or Web Service to run as the LocalSystem
!rather
!> !> than a user?
!> !>
!> !> cheers
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!

Nov 17 '05 #4
Hello Arran,

Craig has provided the answer already. :)

Please look in machine.confign file in C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g folder, in the
<processModel> section user="machine" is what is set right now. You can change that to SYSTEM as you want, but it is not
recommended sicne asp.net app will running under a more powerful account.

Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!References: <uB**************@tk2msftngp13.phx.gbl> <#7**************@TK2MSFTNGP12.phx.gbl>
<Tm**************@cpmsftngxa06.phx.gbl> <#s**************@TK2MSFTNGP09.phx.gbl>
<PP**************@cpmsftngxa06.phx.gbl>
!Subject: Re: Identity System
!Date: Wed, 30 Jul 2003 00:35:35 +0100
!Lines: 145
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <er**************@TK2MSFTNGP11.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: host213-122-6-143.in-addr.btopenworld.com 213.122.6.143
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163181
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!One other thing....
!
!how to i get my application to run with the rights of the local system
!account? What would i enter in the username & password (in the web.config
!file).
!
!again....many thanks
!
!Arran
!
!"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!news:PP**************@cpmsftngxa06.phx.gbl...
!> Hello Arran,
!>
!> You are welcome. Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!> !References: <uB**************@tk2msftngp13.phx.gbl>
!<#7**************@TK2MSFTNGP12.phx.gbl>
!> <Tm**************@cpmsftngxa06.phx.gbl>
!> !Subject: Re: Identity System
!> !Date: Tue, 29 Jul 2003 08:50:15 +0100
!> !Lines: 88
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
!> !Message-ID: <#s**************@TK2MSFTNGP09.phx.gbl>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: 212.219.119.220
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:162908
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Thanks for the info.
!> !
!> !
!> !
!> !"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!> !news:Tm**************@cpmsftngxa06.phx.gbl...
!> !> Hi,
!> !>
!> !> I think what you meant is ASP.NET impersonation.
!> !>
!> !> You could add a line in web.config to run an application as a
!configurable
!> !identity. For example:
!> !>
!> !> <identity impersonate="true" userName="contoso\Jane" password="pass"/>
!> !>
!> !> Please refer to
!>
!!http://msdn.microsoft.com/library/en...netimpersonati
!o
!> !n.asp?frame=true for details.
!> !>
!> !> Thanks very much.
!> !>
!> !> Best regards,
!> !> Yanhong Huang
!> !> Microsoft Online Partner Support
!> !>
!> !> Get Secure! - www.microsoft.com/security
!> !> This posting is provided "AS IS" with no warranties, and confers no
!> !rights.
!> !>
!> !> --------------------
!> !> !From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!> !> !References: <uB**************@tk2msftngp13.phx.gbl>
!> !> !Subject: Re: Identity System
!> !> !Date: Sun, 27 Jul 2003 20:26:12 -0500
!> !> !Lines: 30
!> !> !X-Priority: 3
!> !> !X-MSMail-Priority: Normal
!> !> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !> !Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!> !> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !> !NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200
!> !> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!> !> !Xref: cpmsftngxa06.phx.gbl
!> !microsoft.public.dotnet.framework.aspnet:162483
!> !> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !> !
!> !> !The default user for all apps is set in your machine.config file in
!your
!> !> !local .NET installation folder (in a folder called config). If you
!look
!> !in
!> !> !that file, in the <processModel> section user="machine" is pry what is
!> !set
!> !> !right now. You can change that to SYSTEM as you want, but it is
!highly
!> !> !recommended you don't do that (for security reasons). But it's your
!> !call.
!> !> !
!> !> !In addition, I'm not sure, you may be able to define this in your
!local
!> !> !web.config also, and thus override the machine.config setting.
!Haven't
!> !> !investigated that myself, so dunno if you can do on an app by app
!> !basis...
!> !> !
!> !> !Another alternative is to use impersonation, and set the user you want
!> !all
!> !> !visitors to run under....
!> !> !
!> !> !--
!> !> !Craig Deelsnyder
!> !> !Microsoft MVP - ASP/ASP.NET
!> !> !
!> !> !
!> !> !"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!> !> !news:uB**************@tk2msftngp13.phx.gbl...
!> !> !> Hi,
!> !> !>
!> !> !> How can i get my ASP Page or Web Service to run as the LocalSystem
!> !rather
!> !> !> than a user?
!> !> !>
!> !> !> cheers
!> !> !>
!> !> !>
!> !> !
!> !> !
!> !> !
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!
Nov 17 '05 #5
So i have to change it for the whole server. I cant just change it for one
application?

sorry if i am being very stupid here.

thanks

Arran

"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
news:2p**************@cpmsftngxa06.phx.gbl...
Hello Arran,

Craig has provided the answer already. :)

Please look in machine.confign file in C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g folder, in the <processModel> section user="machine" is what is set right now. You can change that to SYSTEM as you want, but it is not recommended sicne asp.net app will running under a more powerful account.

Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
!From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!References: <uB**************@tk2msftngp13.phx.gbl> <#7**************@TK2MSFTNGP12.phx.gbl> <Tm**************@cpmsftngxa06.phx.gbl> <#s**************@TK2MSFTNGP09.phx.gbl> <PP**************@cpmsftngxa06.phx.gbl>
!Subject: Re: Identity System
!Date: Wed, 30 Jul 2003 00:35:35 +0100
!Lines: 145
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <er**************@TK2MSFTNGP11.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: host213-122-6-143.in-addr.btopenworld.com 213.122.6.143 !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163181 !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!One other thing....
!
!how to i get my application to run with the rights of the local system
!account? What would i enter in the username & password (in the web.config !file).
!
!again....many thanks
!
!Arran
!
!"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!news:PP**************@cpmsftngxa06.phx.gbl...
!> Hello Arran,
!>
!> You are welcome. Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!> !References: <uB**************@tk2msftngp13.phx.gbl>
!<#7**************@TK2MSFTNGP12.phx.gbl>
!> <Tm**************@cpmsftngxa06.phx.gbl>
!> !Subject: Re: Identity System
!> !Date: Tue, 29 Jul 2003 08:50:15 +0100
!> !Lines: 88
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
!> !Message-ID: <#s**************@TK2MSFTNGP09.phx.gbl>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: 212.219.119.220
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:162908
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Thanks for the info.
!> !
!> !
!> !
!> !"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!> !news:Tm**************@cpmsftngxa06.phx.gbl...
!> !> Hi,
!> !>
!> !> I think what you meant is ASP.NET impersonation.
!> !>
!> !> You could add a line in web.config to run an application as a
!configurable
!> !identity. For example:
!> !>
!> !> <identity impersonate="true" userName="contoso\Jane" password="pass"/> !> !>
!> !> Please refer to
!>
!!http://msdn.microsoft.com/library/en...pnetimpersonat
i !o
!> !n.asp?frame=true for details.
!> !>
!> !> Thanks very much.
!> !>
!> !> Best regards,
!> !> Yanhong Huang
!> !> Microsoft Online Partner Support
!> !>
!> !> Get Secure! - www.microsoft.com/security
!> !> This posting is provided "AS IS" with no warranties, and confers no
!> !rights.
!> !>
!> !> --------------------
!> !> !From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!> !> !References: <uB**************@tk2msftngp13.phx.gbl>
!> !> !Subject: Re: Identity System
!> !> !Date: Sun, 27 Jul 2003 20:26:12 -0500
!> !> !Lines: 30
!> !> !X-Priority: 3
!> !> !X-MSMail-Priority: Normal
!> !> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !> !Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!> !> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !> !NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200
!> !> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl !> !> !Xref: cpmsftngxa06.phx.gbl
!> !microsoft.public.dotnet.framework.aspnet:162483
!> !> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !> !
!> !> !The default user for all apps is set in your machine.config file in
!your
!> !> !local .NET installation folder (in a folder called config). If you
!look
!> !in
!> !> !that file, in the <processModel> section user="machine" is pry what is !> !set
!> !> !right now. You can change that to SYSTEM as you want, but it is
!highly
!> !> !recommended you don't do that (for security reasons). But it's your !> !call.
!> !> !
!> !> !In addition, I'm not sure, you may be able to define this in your
!local
!> !> !web.config also, and thus override the machine.config setting.
!Haven't
!> !> !investigated that myself, so dunno if you can do on an app by app
!> !basis...
!> !> !
!> !> !Another alternative is to use impersonation, and set the user you want !> !all
!> !> !visitors to run under....
!> !> !
!> !> !--
!> !> !Craig Deelsnyder
!> !> !Microsoft MVP - ASP/ASP.NET
!> !> !
!> !> !
!> !> !"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!> !> !news:uB**************@tk2msftngp13.phx.gbl...
!> !> !> Hi,
!> !> !>
!> !> !> How can i get my ASP Page or Web Service to run as the LocalSystem !> !rather
!> !> !> than a user?
!> !> !>
!> !> !> cheers
!> !> !>
!> !> !>
!> !> !
!> !> !
!> !> !
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!

Nov 17 '05 #6
If you were running a hosting service, hosting clients that ran ASP.Net
sites, would you want them to simply allow their apps to run under your
SYSTEM account?

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
http://www.takempis.com
Complex things are made up of
lots of simple things.

"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
news:Ox***************@tk2msftngp13.phx.gbl...
So i have to change it for the whole server. I cant just change it for one application?

sorry if i am being very stupid here.

thanks

Arran

"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
news:2p**************@cpmsftngxa06.phx.gbl...
Hello Arran,

Craig has provided the answer already. :)

Please look in machine.confign file in C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g folder, in the
<processModel> section user="machine" is what is set right now. You can

change that to SYSTEM as you want, but it is not
recommended sicne asp.net app will running under a more powerful account.
Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no

rights.

--------------------
!From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!References: <uB**************@tk2msftngp13.phx.gbl>

<#7**************@TK2MSFTNGP12.phx.gbl>
<Tm**************@cpmsftngxa06.phx.gbl>

<#s**************@TK2MSFTNGP09.phx.gbl>
<PP**************@cpmsftngxa06.phx.gbl>
!Subject: Re: Identity System
!Date: Wed, 30 Jul 2003 00:35:35 +0100
!Lines: 145
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <er**************@TK2MSFTNGP11.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: host213-122-6-143.in-addr.btopenworld.com

213.122.6.143
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
!Xref: cpmsftngxa06.phx.gbl

microsoft.public.dotnet.framework.aspnet:163181
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!One other thing....
!
!how to i get my application to run with the rights of the local system
!account? What would i enter in the username & password (in the

web.config
!file).
!
!again....many thanks
!
!Arran
!
!"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
!news:PP**************@cpmsftngxa06.phx.gbl...
!> Hello Arran,
!>
!> You are welcome. Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!> !References: <uB**************@tk2msftngp13.phx.gbl>
!<#7**************@TK2MSFTNGP12.phx.gbl>
!> <Tm**************@cpmsftngxa06.phx.gbl>
!> !Subject: Re: Identity System
!> !Date: Tue, 29 Jul 2003 08:50:15 +0100
!> !Lines: 88
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
!> !Message-ID: <#s**************@TK2MSFTNGP09.phx.gbl>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: 212.219.119.220
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:162908
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Thanks for the info.
!> !
!> !
!> !
!> !"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message !> !news:Tm**************@cpmsftngxa06.phx.gbl...
!> !> Hi,
!> !>
!> !> I think what you meant is ASP.NET impersonation.
!> !>
!> !> You could add a line in web.config to run an application as a
!configurable
!> !identity. For example:
!> !>
!> !> <identity impersonate="true" userName="contoso\Jane"

password="pass"/>
!> !>
!> !> Please refer to
!>

!!http://msdn.microsoft.com/library/en...pnetimpersonat i
!o
!> !n.asp?frame=true for details.
!> !>
!> !> Thanks very much.
!> !>
!> !> Best regards,
!> !> Yanhong Huang
!> !> Microsoft Online Partner Support
!> !>
!> !> Get Secure! - www.microsoft.com/security
!> !> This posting is provided "AS IS" with no warranties, and confers no !> !rights.
!> !>
!> !> --------------------
!> !> !From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!> !> !References: <uB**************@tk2msftngp13.phx.gbl>
!> !> !Subject: Re: Identity System
!> !> !Date: Sun, 27 Jul 2003 20:26:12 -0500
!> !> !Lines: 30
!> !> !X-Priority: 3
!> !> !X-MSMail-Priority: Normal
!> !> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !> !Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!> !> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !> !NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200 !> !> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!> !> !Xref: cpmsftngxa06.phx.gbl
!> !microsoft.public.dotnet.framework.aspnet:162483
!> !> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !> !
!> !> !The default user for all apps is set in your machine.config file in !your
!> !> !local .NET installation folder (in a folder called config). If you !look
!> !in
!> !> !that file, in the <processModel> section user="machine" is pry

what is
!> !set
!> !> !right now. You can change that to SYSTEM as you want, but it is
!highly
!> !> !recommended you don't do that (for security reasons). But it's

your
!> !call.
!> !> !
!> !> !In addition, I'm not sure, you may be able to define this in your
!local
!> !> !web.config also, and thus override the machine.config setting.
!Haven't
!> !> !investigated that myself, so dunno if you can do on an app by app
!> !basis...
!> !> !
!> !> !Another alternative is to use impersonation, and set the user you

want
!> !all
!> !> !visitors to run under....
!> !> !
!> !> !--
!> !> !Craig Deelsnyder
!> !> !Microsoft MVP - ASP/ASP.NET
!> !> !
!> !> !
!> !> !"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!> !> !news:uB**************@tk2msftngp13.phx.gbl...
!> !> !> Hi,
!> !> !>
!> !> !> How can i get my ASP Page or Web Service to run as the

LocalSystem
!> !rather
!> !> !> than a user?
!> !> !>
!> !> !> cheers
!> !> !>
!> !> !>
!> !> !
!> !> !
!> !> !
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!


Nov 17 '05 #7
Yeah fair point.

only reason i was wanting to run as system was because i am doing some
testing with CDO on a exchange server.

thanks for all the info everyone anyway.

arran

"Kevin Spencer" <ke***@takempis.com> wrote in message
news:O0**************@tk2msftngp13.phx.gbl...
If you were running a hosting service, hosting clients that ran ASP.Net
sites, would you want them to simply allow their apps to run under your
SYSTEM account?

--
HTH,

Kevin Spencer
Microsoft MVP
.Net Developer
http://www.takempis.com
Complex things are made up of
lots of simple things.

"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
news:Ox***************@tk2msftngp13.phx.gbl...
So i have to change it for the whole server. I cant just change it for one
application?

sorry if i am being very stupid here.

thanks

Arran

"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message
news:2p**************@cpmsftngxa06.phx.gbl...
Hello Arran,

Craig has provided the answer already. :)

Please look in machine.confign file in

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g folder, in the
<processModel> section user="machine" is what is set right now. You can
change that to SYSTEM as you want, but it is not
recommended sicne asp.net app will running under a more powerful account.
Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no

rights.

--------------------
!From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!References: <uB**************@tk2msftngp13.phx.gbl>

<#7**************@TK2MSFTNGP12.phx.gbl>
<Tm**************@cpmsftngxa06.phx.gbl>

<#s**************@TK2MSFTNGP09.phx.gbl>
<PP**************@cpmsftngxa06.phx.gbl>
!Subject: Re: Identity System
!Date: Wed, 30 Jul 2003 00:35:35 +0100
!Lines: 145
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <er**************@TK2MSFTNGP11.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: host213-122-6-143.in-addr.btopenworld.com

213.122.6.143
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
!Xref: cpmsftngxa06.phx.gbl

microsoft.public.dotnet.framework.aspnet:163181
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!One other thing....
!
!how to i get my application to run with the rights of the local
system !account? What would i enter in the username & password (in the

web.config
!file).
!
!again....many thanks
!
!Arran
!
!"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message !news:PP**************@cpmsftngxa06.phx.gbl...
!> Hello Arran,
!>
!> You are welcome. Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "Arran Pearce" <ar**********@bacoll.ac.uk>
!> !References: <uB**************@tk2msftngp13.phx.gbl>
!<#7**************@TK2MSFTNGP12.phx.gbl>
!> <Tm**************@cpmsftngxa06.phx.gbl>
!> !Subject: Re: Identity System
!> !Date: Tue, 29 Jul 2003 08:50:15 +0100
!> !Lines: 88
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
!> !Message-ID: <#s**************@TK2MSFTNGP09.phx.gbl>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: 212.219.119.220
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl !> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:162908
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Thanks for the info.
!> !
!> !
!> !
!> !"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> wrote in message !> !news:Tm**************@cpmsftngxa06.phx.gbl...
!> !> Hi,
!> !>
!> !> I think what you meant is ASP.NET impersonation.
!> !>
!> !> You could add a line in web.config to run an application as a
!configurable
!> !identity. For example:
!> !>
!> !> <identity impersonate="true" userName="contoso\Jane"

password="pass"/>
!> !>
!> !> Please refer to
!>

!!http://msdn.microsoft.com/library/en...pnetimpersonat i
!o
!> !n.asp?frame=true for details.
!> !>
!> !> Thanks very much.
!> !>
!> !> Best regards,
!> !> Yanhong Huang
!> !> Microsoft Online Partner Support
!> !>
!> !> Get Secure! - www.microsoft.com/security
!> !> This posting is provided "AS IS" with no warranties, and confers no !> !rights.
!> !>
!> !> --------------------
!> !> !From: "Craig Deelsnyder" <cd******@NOSPAMyahoo.com>
!> !> !References: <uB**************@tk2msftngp13.phx.gbl>
!> !> !Subject: Re: Identity System
!> !> !Date: Sun, 27 Jul 2003 20:26:12 -0500
!> !> !Lines: 30
!> !> !X-Priority: 3
!> !> !X-MSMail-Priority: Normal
!> !> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !> !Message-ID: <#7**************@TK2MSFTNGP12.phx.gbl>
!> !> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !> !NNTP-Posting-Host: c-66-41-16-200.mn.client2.attbi.com 66.41.16.200 !> !> !Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!> !> !Xref: cpmsftngxa06.phx.gbl
!> !microsoft.public.dotnet.framework.aspnet:162483
!> !> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !> !
!> !> !The default user for all apps is set in your machine.config file in
!your
!> !> !local .NET installation folder (in a folder called config). If you !look
!> !in
!> !> !that file, in the <processModel> section user="machine" is pry what
is
!> !set
!> !> !right now. You can change that to SYSTEM as you want, but it

is !highly
!> !> !recommended you don't do that (for security reasons). But it's

your
!> !call.
!> !> !
!> !> !In addition, I'm not sure, you may be able to define this in your !local
!> !> !web.config also, and thus override the machine.config setting.
!Haven't
!> !> !investigated that myself, so dunno if you can do on an app by app !> !basis...
!> !> !
!> !> !Another alternative is to use impersonation, and set the user

you want
!> !all
!> !> !visitors to run under....
!> !> !
!> !> !--
!> !> !Craig Deelsnyder
!> !> !Microsoft MVP - ASP/ASP.NET
!> !> !
!> !> !
!> !> !"Arran Pearce" <ar**********@bacoll.ac.uk> wrote in message
!> !> !news:uB**************@tk2msftngp13.phx.gbl...
!> !> !> Hi,
!> !> !>
!> !> !> How can i get my ASP Page or Web Service to run as the

LocalSystem
!> !rather
!> !> !> than a user?
!> !> !>
!> !> !> cheers
!> !> !>
!> !> !>
!> !> !
!> !> !
!> !> !
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!



Nov 17 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

13 posts views Thread by PinkBishop | last post: by
3 posts views Thread by Przemo Karlikowski | last post: by
???
reply views Thread by Stoney L | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.