By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,544 Members | 2,065 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,544 IT Pros & Developers. It's quick & easy.

Debug error - The project is not configured to be debugged (I've tried everything!)

P: n/a
Hi,

I am running v1.1.4322 on Win2K server and unable to debug a ASP.Net
application running locally, using a full URL (ie www.mysite.com).
When I hit F5, I get the following error message:

<debugger_error_message>
Error while trying to run project: Unable to start debugging on the
web server.
The project is not configured to be debugged.
</debugger_error_message>

This error is decribed in
http://support.microsoft.com/default...b;EN-US;306156, which
states that this error can occur because:
- The ASP.NET Application does not have a Web.Config file.
- The Execute Permissions property for the current project folder in
Internet Services Manager is set to None.

Naturally, this is the first thing I checked and sure enought, my
application has both a Web.Config file and Execute permissions for my
site is set 'Scripts Only'. I elevated permissions to 'Scripts and
Executables' which made no difference.
This problem has been discussed before, and I have followed the advice
of numerous postings, including:

1). I have checked the project's web.config file and the debug
attribute is set to true:
<compilation debug="true" />

2). I have URLScan Installed, so I have modified urlscan.ini to
include:
[AllowVerbs]
DEBUG

[AllowExtensions]
.aspx
.asmx

3). I have reinstalled ASP.NET by running:
"C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet _regiis.exe" -i

4). In Internet Services Manager under the 'Home Directory' tab, I
have checked that the .aspx expension is correctly mapped to
C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll and note
that the verbs GET,HEAD,POST,DEBUG are permitted.

5). Also under the 'Home Directory' tab, selecting the 'Configuration'
button and 'App Debugging' tab, I have checked 'Enable ASP Serer Side
debugging'.

6). Also in Internet Services Manager under the Directory Security
tab, I have checked that the Authentication Methods, Anonymous Access
and Integrated Windows Authentication are selected.

7). I have checked that my user account is a member of the Debugger
Users group. I am also a member of the Administrators group.

8). Right clicking on my project, and selecting the Properties ->
Configuration Properties -> Debugging, I have checked that 'APS.Net
Debugging' is checked, 'Always use Internet Explorer when debugging
web pages' is ticked and the 'Start URL' is the default page in my
site (ie 'http://www.mysite.com/login.aspx').

9). Also, under 'Configuration Properties -> Debugging', the 'Active
Solution Configuration' for all assembilies in my project is set for
debug.

10). I have restarted IIS by running iisreset.exe.
A few things I havn't implemented (because the instructions were
vauge) include:

A MSDN article helpfully suggested that I:
"Start the application without debugging. (From the Debug menu, choose
Start Without Debugging.) Attach to the appropriate IIS process or
worker process. By default, inetinfo.exe for ATL Server applications
or aspnet_wp.exe for ASP.NET applications. Use the following
procedures to determine which process an ASP.NET or ATL Server
application runs under. To check which process an ASP.NET application
runs under". No advice on how I go about attaching an appropriate IIS
process or worker process, so I have been unable to check this.

Another helpful MSDN article suggested that I check:
"Does the machine running IIS server have Visual Studio .NET Remote
Components installed?". How would I know and where would I get '.NET
Remote Components'?
Please, please help. This is driving me nuts.

Thanks,

Stephen
Nov 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
have you run the iis lockdown tool? if so you need to re-add the DEBUG verb.
If you search this newsgroup you will find a ton of answers to your question
because it comes up a lot.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
Hi,

I am running v1.1.4322 on Win2K server and unable to debug a ASP.Net
application running locally, using a full URL (ie www.mysite.com).
When I hit F5, I get the following error message:

<debugger_error_message>
Error while trying to run project: Unable to start debugging on the
web server.
The project is not configured to be debugged.
</debugger_error_message>

This error is decribed in
http://support.microsoft.com/default...b;EN-US;306156, which
states that this error can occur because:
- The ASP.NET Application does not have a Web.Config file.
- The Execute Permissions property for the current project folder in
Internet Services Manager is set to None.

Naturally, this is the first thing I checked and sure enought, my
application has both a Web.Config file and Execute permissions for my
site is set 'Scripts Only'. I elevated permissions to 'Scripts and
Executables' which made no difference.
This problem has been discussed before, and I have followed the advice
of numerous postings, including:

1). I have checked the project's web.config file and the debug
attribute is set to true:
<compilation debug="true" />

2). I have URLScan Installed, so I have modified urlscan.ini to
include:
[AllowVerbs]
DEBUG

[AllowExtensions]
.aspx
.asmx

3). I have reinstalled ASP.NET by running:
"C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet _regiis.exe" -i

4). In Internet Services Manager under the 'Home Directory' tab, I
have checked that the .aspx expension is correctly mapped to
C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll and note
that the verbs GET,HEAD,POST,DEBUG are permitted.

5). Also under the 'Home Directory' tab, selecting the 'Configuration'
button and 'App Debugging' tab, I have checked 'Enable ASP Serer Side
debugging'.

6). Also in Internet Services Manager under the Directory Security
tab, I have checked that the Authentication Methods, Anonymous Access
and Integrated Windows Authentication are selected.

7). I have checked that my user account is a member of the Debugger
Users group. I am also a member of the Administrators group.

8). Right clicking on my project, and selecting the Properties ->
Configuration Properties -> Debugging, I have checked that 'APS.Net
Debugging' is checked, 'Always use Internet Explorer when debugging
web pages' is ticked and the 'Start URL' is the default page in my
site (ie 'http://www.mysite.com/login.aspx').

9). Also, under 'Configuration Properties -> Debugging', the 'Active
Solution Configuration' for all assembilies in my project is set for
debug.

10). I have restarted IIS by running iisreset.exe.
A few things I havn't implemented (because the instructions were
vauge) include:

A MSDN article helpfully suggested that I:
"Start the application without debugging. (From the Debug menu, choose
Start Without Debugging.) Attach to the appropriate IIS process or
worker process. By default, inetinfo.exe for ATL Server applications
or aspnet_wp.exe for ASP.NET applications. Use the following
procedures to determine which process an ASP.NET or ATL Server
application runs under. To check which process an ASP.NET application
runs under". No advice on how I go about attaching an appropriate IIS
process or worker process, so I have been unable to check this.

Another helpful MSDN article suggested that I check:
"Does the machine running IIS server have Visual Studio .NET Remote
Components installed?". How would I know and where would I get '.NET
Remote Components'?
Please, please help. This is driving me nuts.

Thanks,

Stephen

Nov 17 '05 #2

P: n/a
2 more options left:
Find and fix your problem using this
http://gotdotnet.com/team/csharp/lea...erproblems.doc

OR

It seems you require special attention. You can post your question to the
debug newsgroup. Microsoft actively monitors this group for debugging
problems. You may want to list the steps taken so that they can cut straight
to the matter.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
Alvin,

I'm pretty sure I have addresses the IIS Lockdown problem under
section 2:
2). I have URLScan Installed, so I have modified urlscan.ini to
include:
[AllowVerbs]
DEBUG

[AllowExtensions]
.aspx
.asmx
Do I need to add anything else to the urlscan.ini file, or is there
something I'm missing?

Thanks

Stephen

"Alvin Bruney" <vapordan_spam_me_not@hotmail_no_spamhotmail.com > wrote in

message news:<Og**************@TK2MSFTNGP11.phx.gbl>... have you run the iis lockdown tool? if so you need to re-add the DEBUG verb. If you search this newsgroup you will find a ton of answers to your question because it comes up a lot.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
Hi,

I am running v1.1.4322 on Win2K server and unable to debug a ASP.Net
application running locally, using a full URL (ie www.mysite.com).
When I hit F5, I get the following error message:

<debugger_error_message>
Error while trying to run project: Unable to start debugging on the
web server.
The project is not configured to be debugged.
</debugger_error_message>

This error is decribed in
http://support.microsoft.com/default...b;EN-US;306156, which
states that this error can occur because:
- The ASP.NET Application does not have a Web.Config file.
- The Execute Permissions property for the current project folder in
Internet Services Manager is set to None.

Naturally, this is the first thing I checked and sure enought, my
application has both a Web.Config file and Execute permissions for my
site is set 'Scripts Only'. I elevated permissions to 'Scripts and
Executables' which made no difference.
This problem has been discussed before, and I have followed the advice
of numerous postings, including:

1). I have checked the project's web.config file and the debug
attribute is set to true:
<compilation debug="true" />

2). I have URLScan Installed, so I have modified urlscan.ini to
include:
[AllowVerbs]
DEBUG

[AllowExtensions]
.aspx
.asmx

3). I have reinstalled ASP.NET by running:
"C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet _regiis.exe" -i

4). In Internet Services Manager under the 'Home Directory' tab, I
have checked that the .aspx expension is correctly mapped to
C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll and note
that the verbs GET,HEAD,POST,DEBUG are permitted.

5). Also under the 'Home Directory' tab, selecting the 'Configuration'
button and 'App Debugging' tab, I have checked 'Enable ASP Serer Side
debugging'.

6). Also in Internet Services Manager under the Directory Security
tab, I have checked that the Authentication Methods, Anonymous Access
and Integrated Windows Authentication are selected.

7). I have checked that my user account is a member of the Debugger
Users group. I am also a member of the Administrators group.

8). Right clicking on my project, and selecting the Properties ->
Configuration Properties -> Debugging, I have checked that 'APS.Net
Debugging' is checked, 'Always use Internet Explorer when debugging
web pages' is ticked and the 'Start URL' is the default page in my
site (ie 'http://www.mysite.com/login.aspx').

9). Also, under 'Configuration Properties -> Debugging', the 'Active
Solution Configuration' for all assembilies in my project is set for
debug.

10). I have restarted IIS by running iisreset.exe.
A few things I havn't implemented (because the instructions were
vauge) include:

A MSDN article helpfully suggested that I:
"Start the application without debugging. (From the Debug menu, choose
Start Without Debugging.) Attach to the appropriate IIS process or
worker process. By default, inetinfo.exe for ATL Server applications
or aspnet_wp.exe for ASP.NET applications. Use the following
procedures to determine which process an ASP.NET or ATL Server
application runs under. To check which process an ASP.NET application
runs under". No advice on how I go about attaching an appropriate IIS
process or worker process, so I have been unable to check this.

Another helpful MSDN article suggested that I check:
"Does the machine running IIS server have Visual Studio .NET Remote
Components installed?". How would I know and where would I get '.NET
Remote Components'?
Please, please help. This is driving me nuts.

Thanks,

Stephen

Nov 17 '05 #3

P: n/a
Alvin,

I have looked at this gotdotnet article and the only advice for my
error message "The project is not configured to be debugged" is:

"You need to make sure that your web is configured for debugging. To
do this, you need set 'debug = true' in the 'web.config' file. You may
find this file in your web project folder."

This was the first thing I checked.

Which group do you suggest I post to (microsoft.public.dotnet.*)? I
can't see a specific debug group.

Thanks,

Stephen
"Alvin Bruney" <vapordan_spam_me_not@hotmail_no_spamhotmail.com > wrote in message news:<e8**************@tk2msftngp13.phx.gbl>...
2 more options left:
Find and fix your problem using this
http://gotdotnet.com/team/csharp/lea...erproblems.doc

OR

It seems you require special attention. You can post your question to the
debug newsgroup. Microsoft actively monitors this group for debugging
problems. You may want to list the steps taken so that they can cut straight
to the matter.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
Alvin,

I'm pretty sure I have addresses the IIS Lockdown problem under
section 2:
> 2). I have URLScan Installed, so I have modified urlscan.ini to
> include:
> [AllowVerbs]
> DEBUG
>
> [AllowExtensions]
> .aspx
> .asmx


Do I need to add anything else to the urlscan.ini file, or is there
something I'm missing?

Thanks

Stephen

"Alvin Bruney" <vapordan_spam_me_not@hotmail_no_spamhotmail.com > wrote in

message news:<Og**************@TK2MSFTNGP11.phx.gbl>...
have you run the iis lockdown tool? if so you need to re-add the DEBUG verb. If you search this newsgroup you will find a ton of answers to your question because it comes up a lot.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
> Hi,
>
> I am running v1.1.4322 on Win2K server and unable to debug a ASP.Net
> application running locally, using a full URL (ie www.mysite.com).
> When I hit F5, I get the following error message:
>
> <debugger_error_message>
> Error while trying to run project: Unable to start debugging on the
> web server.
> The project is not configured to be debugged.
> </debugger_error_message>
>
> This error is decribed in
> http://support.microsoft.com/default...b;EN-US;306156, which
> states that this error can occur because:
> - The ASP.NET Application does not have a Web.Config file.
> - The Execute Permissions property for the current project folder in
> Internet Services Manager is set to None.
>
> Naturally, this is the first thing I checked and sure enought, my
> application has both a Web.Config file and Execute permissions for my
> site is set 'Scripts Only'. I elevated permissions to 'Scripts and
> Executables' which made no difference.
>
>
> This problem has been discussed before, and I have followed the advice
> of numerous postings, including:
>
> 1). I have checked the project's web.config file and the debug
> attribute is set to true:
> <compilation debug="true" />
>
> 2). I have URLScan Installed, so I have modified urlscan.ini to
> include:
> [AllowVerbs]
> DEBUG
>
> [AllowExtensions]
> .aspx
> .asmx
>
> 3). I have reinstalled ASP.NET by running:
> "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet _regiis.exe" -i
>
> 4). In Internet Services Manager under the 'Home Directory' tab, I
> have checked that the .aspx expension is correctly mapped to
> C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll and note
> that the verbs GET,HEAD,POST,DEBUG are permitted.
>
> 5). Also under the 'Home Directory' tab, selecting the 'Configuration'
> button and 'App Debugging' tab, I have checked 'Enable ASP Serer Side
> debugging'.
>
> 6). Also in Internet Services Manager under the Directory Security
> tab, I have checked that the Authentication Methods, Anonymous Access
> and Integrated Windows Authentication are selected.
>
> 7). I have checked that my user account is a member of the Debugger
> Users group. I am also a member of the Administrators group.
>
> 8). Right clicking on my project, and selecting the Properties ->
> Configuration Properties -> Debugging, I have checked that 'APS.Net
> Debugging' is checked, 'Always use Internet Explorer when debugging
> web pages' is ticked and the 'Start URL' is the default page in my
> site (ie 'http://www.mysite.com/login.aspx').
>
> 9). Also, under 'Configuration Properties -> Debugging', the 'Active
> Solution Configuration' for all assembilies in my project is set for
> debug.
>
> 10). I have restarted IIS by running iisreset.exe.
>
>
> A few things I havn't implemented (because the instructions were
> vauge) include:
>
> A MSDN article helpfully suggested that I:
> "Start the application without debugging. (From the Debug menu, choose
> Start Without Debugging.) Attach to the appropriate IIS process or
> worker process. By default, inetinfo.exe for ATL Server applications
> or aspnet_wp.exe for ASP.NET applications. Use the following
> procedures to determine which process an ASP.NET or ATL Server
> application runs under. To check which process an ASP.NET application
> runs under". No advice on how I go about attaching an appropriate IIS
> process or worker process, so I have been unable to check this.
>
> Another helpful MSDN article suggested that I check:
> "Does the machine running IIS server have Visual Studio .NET Remote
> Components installed?". How would I know and where would I get '.NET
> Remote Components'?
>
>
> Please, please help. This is driving me nuts.
>
> Thanks,
>
> Stephen

Nov 17 '05 #4

P: n/a
I was having the exact same problem and I finally found the solution.
Apparently if you mistype the virtual directory in the Start URL for
the project, this is the error message you will see.

Stephen Miller wrote:
Alvin,

I have looked at this gotdotnet article and the only advice for my
error message "The project is not configured to be debugged" is:

"You need to make sure that your web is configured for debugging. To
do this, you need set 'debug = true' in the 'web.config' file. You may find this file in your web project folder."

This was the first thing I checked.

Which group do you suggest I post to (microsoft.public.dotnet.*)? I
can't see a specific debug group.

Thanks,

Stephen
"Alvin Bruney" <vapordan_spam_me_not@hotmail_no_spamhotmail.com >

wrote in message news:<e8**************@tk2msftngp13.phx.gbl>...
2 more options left:
Find and fix your problem using this
http://gotdotnet.com/team/csharp/lea...erproblems.doc
OR

It seems you require special attention. You can post your question to the debug newsgroup. Microsoft actively monitors this group for debugging problems. You may want to list the steps taken so that they can cut straight to the matter.

"Stephen Miller" <js******@hotmail.com> wrote in message
news:cd**************************@posting.google.c om...
Alvin,

I'm pretty sure I have addresses the IIS Lockdown problem under
section 2:

> > 2). I have URLScan Installed, so I have modified urlscan.ini to > > include:
> > [AllowVerbs]
> > DEBUG
> >
> > [AllowExtensions]
> > .aspx
> > .asmx

Do I need to add anything else to the urlscan.ini file, or is there something I'm missing?

Thanks

Stephen

"Alvin Bruney" <vapordan_spam_me_not@hotmail_no_spamhotmail.com > wrote in
message news:<Og**************@TK2MSFTNGP11.phx.gbl>...
> have you run the iis lockdown tool? if so you need to re-add
the DEBUG verb.
> If you search this newsgroup you will find a ton of answers to
your question
> because it comes up a lot.
>
> "Stephen Miller" <js******@hotmail.com> wrote in message
> news:cd**************************@posting.google.c om...
> > Hi,
> >
> > I am running v1.1.4322 on Win2K server and unable to debug a

ASP.Net > > application running locally, using a full URL (ie www.mysite.com). > > When I hit F5, I get the following error message:
> >
> > <debugger_error_message>
> > Error while trying to run project: Unable to start debugging on the > > web server.
> > The project is not configured to be debugged.
> > </debugger_error_message>
> >
> > This error is decribed in
> > http://support.microsoft.com/default...b;EN-US;306156, which > > states that this error can occur because:
> > - The ASP.NET Application does not have a Web.Config file.
> > - The Execute Permissions property for the current project folder in > > Internet Services Manager is set to None.
> >
> > Naturally, this is the first thing I checked and sure enought, my > > application has both a Web.Config file and Execute permissions for my > > site is set 'Scripts Only'. I elevated permissions to 'Scripts and > > Executables' which made no difference.
> >
> >
> > This problem has been discussed before, and I have followed the advice > > of numerous postings, including:
> >
> > 1). I have checked the project's web.config file and the debug > > attribute is set to true:
> > <compilation debug="true" />
> >
> > 2). I have URLScan Installed, so I have modified urlscan.ini to > > include:
> > [AllowVerbs]
> > DEBUG
> >
> > [AllowExtensions]
> > .aspx
> > .asmx
> >
> > 3). I have reinstalled ASP.NET by running:
> > "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet _regiis.exe" -i > >
> > 4). In Internet Services Manager under the 'Home Directory' tab, I > > have checked that the .aspx expension is correctly mapped to
> > C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll and note > > that the verbs GET,HEAD,POST,DEBUG are permitted.
> >
> > 5). Also under the 'Home Directory' tab, selecting the 'Configuration' > > button and 'App Debugging' tab, I have checked 'Enable ASP Serer Side > > debugging'.
> >
> > 6). Also in Internet Services Manager under the Directory Security > > tab, I have checked that the Authentication Methods, Anonymous Access > > and Integrated Windows Authentication are selected.
> >
> > 7). I have checked that my user account is a member of the Debugger > > Users group. I am also a member of the Administrators group.
> >
> > 8). Right clicking on my project, and selecting the Properties -> > > Configuration Properties -> Debugging, I have checked that 'APS.Net > > Debugging' is checked, 'Always use Internet Explorer when debugging > > web pages' is ticked and the 'Start URL' is the default page in my > > site (ie 'http://www.mysite.com/login.aspx').
> >
> > 9). Also, under 'Configuration Properties -> Debugging', the 'Active > > Solution Configuration' for all assembilies in my project is set for > > debug.
> >
> > 10). I have restarted IIS by running iisreset.exe.
> >
> >
> > A few things I havn't implemented (because the instructions were > > vauge) include:
> >
> > A MSDN article helpfully suggested that I:
> > "Start the application without debugging. (From the Debug menu, choose > > Start Without Debugging.) Attach to the appropriate IIS process or > > worker process. By default, inetinfo.exe for ATL Server applications > > or aspnet_wp.exe for ASP.NET applications. Use the following
> > procedures to determine which process an ASP.NET or ATL Server > > application runs under. To check which process an ASP.NET application > > runs under". No advice on how I go about attaching an appropriate IIS > > process or worker process, so I have been unable to check this. > >
> > Another helpful MSDN article suggested that I check:
> > "Does the machine running IIS server have Visual Studio .NET Remote > > Components installed?". How would I know and where would I get '.NET > > Remote Components'?
> >
> >
> > Please, please help. This is driving me nuts.
> >
> > Thanks,
> >
> > Stephen


Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.