By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,563 Members | 1,066 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,563 IT Pros & Developers. It's quick & easy.

Problems with Enterprise Localization Framework and .NET FW 1.1

P: n/a
We had downloaded the Enterprise Localization Framework a few months
ago for evaluation and were using it under .NET Framework 1.0. We've
just now upgraded to .NET Framework 1.1 and have started having
problems.

When attempting to generate resource dlls with
LocalizationManagement.exe, I get an exception:

Unable to generate loose file resources: The type initializer for
"Microsoft.Toolkits.EnterpriseLocalization.Element ResourceSet" threw
an exception at at Microsoft.Toolkits.EnterpriseLocalization.ElementR esourceSet.get_FullName()
....

When I use viewer.exe to open a previously compiled satellite dll such
as toolkit.resources.dll, I get the error:
The type initializaer for
"Microsoft.Toolkits.EnterpriseLocalization.Element ResourceSet" threw
an exception.

1. I was wondering if I need to recompile the toolkit against the new
framework but I don't see the source to either LocalizationManagement
nor Viewer. Is it possible to get the source?

2. Do I need to modified the ControlTypes table to reference 1.1.4322
(.NET 1.1) versions of all controls? I'm thinking no because the
table now refers to 1.0.3300 (.NET Beta?) though we were using
1.0.3705 version (.NET 1.0) controls. It's unclear how the
AddControls application works.
Nov 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hello Murphy,

I'm looking for someone who can assist you. Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: mu****@murphysw.com (MarkMurphy)
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!Subject: Problems with Enterprise Localization Framework and .NET FW 1.1
!Date: 17 Jul 2003 15:43:23 -0700
!Organization: http://groups.google.com/
!Lines: 28
!Message-ID: <e0**************************@posting.google.com >
!NNTP-Posting-Host: 208.186.174.93
!Content-Type: text/plain; charset=ISO-8859-1
!Content-Transfer-Encoding: 8bit
!X-Trace: posting.google.com 1058481803 31223 127.0.0.1 (17 Jul 2003 22:43:23 GMT)
!X-Complaints-To: gr**********@google.com
!NNTP-Posting-Date: 17 Jul 2003 22:43:23 GMT
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed 00.sul.t-online.de!t-online.de!diablo.theplanet.net!zen.net.uk!
in.100proofnews.com!tdsnet-transit!newspeer.tds.net!sn-xit-02!sn-xit-06!sn-xit-09!supernews.com!postnews1.google.com!not-
for-mail
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:160094
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!We had downloaded the Enterprise Localization Framework a few months
!ago for evaluation and were using it under .NET Framework 1.0. We've
!just now upgraded to .NET Framework 1.1 and have started having
!problems.
!
!When attempting to generate resource dlls with
!LocalizationManagement.exe, I get an exception:
!
!Unable to generate loose file resources: The type initializer for
!"Microsoft.Toolkits.EnterpriseLocalization.Elemen tResourceSet" threw
!an exception at at Microsoft.Toolkits.EnterpriseLocalization.ElementR esourceSet.get_FullName()
!...
!
!When I use viewer.exe to open a previously compiled satellite dll such
!as toolkit.resources.dll, I get the error:
!The type initializaer for
!"Microsoft.Toolkits.EnterpriseLocalization.Elemen tResourceSet" threw
!an exception.
!
!1. I was wondering if I need to recompile the toolkit against the new
!framework but I don't see the source to either LocalizationManagement
!nor Viewer. Is it possible to get the source?
!
!2. Do I need to modified the ControlTypes table to reference 1.1.4322
!(.NET 1.1) versions of all controls? I'm thinking no because the
!table now refers to 1.0.3300 (.NET Beta?) though we were using
!1.0.3705 version (.NET 1.0) controls. It's unclear how the
!AddControls application works.
!
Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.