469,954 Members | 1,699 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,954 developers. It's quick & easy.

Problem with Validation Using Panels

I'm working on a simple Web application that uses a wizard-style
data-entry paradigm (seven "pages", using "next" and "previous"
buttons), and I'm having a problem with the validation.

On page one (which is actually just a Panel control), when the user
clicks "next," I hide Panel_1 and show Panel_2. However, the
RequiredFieldValidator controls in Panel_1 only appear to work with
Internet Explorer on Windows; when I click "next" using Netscape 4.x
or even (IE on a Mac), I get no validation at all.

However, when I get rid of the panel controls and test using only the
contents of the Panel_1 control and the single Form tag, the
validation controls perform performs perfectly in Netscape.

Is there something I'm missing? Is there a problem using Panel
controls with .NET validation controls? I don't know what to do,
here.

Thanks much for help!

Chris
Nov 17 '05 #1
0 1247

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Vincent V | last post: by
reply views Thread by amessimon | last post: by
2 posts views Thread by Caesar Augustus | last post: by
reply views Thread by Anthony W DiGrigoli | last post: by
6 posts views Thread by ?scar Martins | last post: by
2 posts views Thread by =?Utf-8?B?TWlrZQ==?= | last post: by
reply views Thread by db007 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.