470,590 Members | 2,288 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,590 developers. It's quick & easy.

Error when starting page at this first times

I always found that web page written by ASP.NET (VB.NET) generate error when
starting at the first times. If I click refresh button on the IE again, it
can work as well.

What's wrong ?

Again if I terminate process aspnet_wp.exe, it will generate again ONLY at
the times to read page.

Following is the error seen on screen:

Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Nov 17 '05 #1
2 3711
Do this and post back with the error:

.. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Nov 17 '05 #2
I think it's case sensitive, try Off

you service provider may override this setting in their config also.

Run on the local machine might help also.

"Sara T." <sa****@infoquest.co.th> wrote in message
news:#d**************@TK2MSFTNGP10.phx.gbl...
It still be the same after I set customErrors mode=off.

Any ideas ?
"Chance Hopkins" <ch************@hotmail.com> wrote in message
news:ei*************@TK2MSFTNGP10.phx.gbl...
Do this and post back with the error:

. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>



Nov 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by GBud2004 | last post: by
5 posts views Thread by Nathan Sokalski | last post: by
2 posts views Thread by Raul Rodriguez | last post: by
12 posts views Thread by jonatan | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.