By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,679 Members | 1,592 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,679 IT Pros & Developers. It's quick & easy.

Language and Direction real GURU needed! (Hebrew and maybe arabic) CR or Charset issue?

P: n/a
Hello all!
I wonder if the following subject is a Crystal issue or what?
When ever I have a field that includes hebrew(-RTL language) and
numbers all the spaces beetwen the words and the numbers are moved to
end of field.
in the html source it puts "&nbsp" not in right place, the trues is
that the crystal formula editor acts strange always when working with
hebrew.
What ever I try to do, as changing the script of the font that I
select for the field or changing charset of the page displaying the
[Web Form Viwer] no luck.

Any Ideas or suggestion will be very appreciated.

Thanks,
EFY.
Nov 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Efy Hi,

Can you supplay any sample. I'm working with Crystal report and hebrew
without any problem.

Natty Gur, CTO
Dao2Com Ltd.
28th Baruch Hirsch st. Bnei-Brak
Israel , 51114

Phone Numbers:
Office: +972-(0)3-5786668
Fax: +972-(0)3-5703475
Mobile: +972-(0)58-888377

Know the overall picture
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #2

P: n/a
Efy
Thank you Natti for responding :
Here is a sample of my code of my formula:(Crystal sintax)!
"בסיס זכאות "+totext(next({TIK25781_MVTZAIM.BASIS_ZAKAUT}) ,0) + " "
+{@Db2Heb};
<Comment: '@DB2Heb' is a function returning some hebrew words>
I also tried instead of [+ " "] of formula text to write [+ chr(32)] or
[+ space(1)] always the result is:
<I hope you can see the following Hebrew>>
Instead of:
בסיס זכאות 650 עולים מאתיופיה
I get:
בסיס זכאות650עולים מאתיופיה

Or with other field I get:
עד3ילדים
Insted of:
עד 3 ילדים

just know that I'm using CR.NET with asp.net.
the same report when exported to PDF file or when Showing in windows
form viewer ,displays correctly.

Thank you for any Idea , Maybe if it's OK to call you, so I can explain
the problem better and send you via Email the actual report(maybe I can
create a similar report an a single table access database), but I think
that your office number is wrong.

Lhit...
Efy.

To send me a mail remove the spammer protection prefix 'PleasDontspam_'.

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.