473,581 Members | 3,049 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

disabling html validation does not seem to stck

Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #1
12 2245
and also... yesterday it all seem ok....
And today suddenly VWD desided to check on this page.

I tested... dragging and dropping and image to the designer.
But in the html view... it complains that the "img" tag is missing an "alt"
tag.

Seems like 1. drag-and-drop, and then 2.validation are working on two
different validation models.

1. How can I bring both to the latest validation requiremnts?
2. How do I get the old ones to ignore validation?
Thanks a bunch
Nalaka

"Nalaka" <na******@nospa m.nospam> wrote in message
news:us******** ******@TK2MSFTN GP09.phx.gbl...
Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation
errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #2
Hi...
Also html validation complains about colors like royalblue...
How can I add these new colors to the css... ask it to ignore colors.
Thanks again
Nalaka
"Nalaka" <na******@nospa m.nospam> wrote in message
news:us******** ******@TK2MSFTN GP09.phx.gbl...
Hi,

I suddenly started getting a lot of errors from html validation (some CSS)

so I followed the following instructions to disable it.

If you'd rather not have these types of HTML validation errors show up in
your error-list, you can disable this functionality by selecting the
Tools->Options menu item in VS or Visual Web Developer. Select the
TextEditor->Html->Validation tree option in the left-hand side of the
options window, and uncheck the "Show Errors" checkbox:

But ... the problem is that unclicking check does not seem to stick.

When I click on the page, "show errors" check box checks itself on, and I
cannot get to the design mode.

How can I get visual web developer to stop checking for validation
errors???

Any help is deeply appreciated.

Thanks

Nalaka


Jan 12 '06 #3
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check Accessibility.. ."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospa m.nospam> wrote in message
| news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on, and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #4
Thanks Steven,

After reading this link, I realized that I want VWD to tell me incorrect
markup.
http://msdn2.microsoft.com/en-us/library/f940516c.aspx

But let me swith to the "design mode" from the "Source mode".
VWD reports all these (HTML) inconsistancies as errors, and will not let me
swith to the design mode.
(project compiles fine)

1. How can I switch to the design mode, even when there are validation
checks?
2. Is there a way to downgrade such errors to Warnings?

Coping these pages to another environment did not help.
and no visible difference between ones that does not show errors and
these.... except for may be the file date.
Thanks
Nalaka



"Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check
Accessibility.. ."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the
settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospa m.nospam> wrote in message
| news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on,
and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #5
Hi,
For an example, now... following error now gets generated.
(But this is code generated by the VWD designer itself.)

Error 110 Validation (Internet Explorer 6): Element 'table' cannot be nested
within element 'span'.
Thanks
Nalaka

"Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
Hi Nalaka,

Welcome.
For the VS 2005 ASP.NET html editor, it now includes not only HTML content
validating , but also the Accessiblity checking, so not sure whether the
warning and errors also indicate some accessiblity checking, you can right
click the page in solution explorer and choose the "Check
Accessibility.. ."
item to view the accessibility setting... Also for HTML checking, what's
your current setting , IE6 or XHTML .... ? Seems my local vs 2005
environment default to IE6 and won't be reset by the changes in IDE's html
editor...
Also, you can consider copy the project on some box which has vs 2005 to
check the behavior, if that works ok, you can try comparing the
settings...

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Thu, 12 Jan 2006 12:03:29 -0800
| Lines: 56
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Response
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi...
| Also html validation complains about colors like royalblue...
| How can I add these new colors to the css... ask it to ignore colors.
|
|
| Thanks again
| Nalaka
|
|
| "Nalaka" <na******@nospa m.nospam> wrote in message
| news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > Hi,
| >
| > I suddenly started getting a lot of errors from html validation (some
CSS)
| >
| > so I followed the following instructions to disable it.
| >
| > If you'd rather not have these types of HTML validation errors show up
in
| > your error-list, you can disable this functionality by selecting the
| > Tools->Options menu item in VS or Visual Web Developer. Select the
| > TextEditor->Html->Validation tree option in the left-hand side of the
| > options window, and uncheck the "Show Errors" checkbox:
| >
| >
| >
| >
| >
| > But ... the problem is that unclicking check does not seem to stick.
| >
| > When I click on the page, "show errors" check box checks itself on,
and
I
| > cannot get to the design mode.
| >
| >
| >
| > How can I get visual web developer to stop checking for validation
| > errors???
| >
| >
| >
| >
| >
| > Any help is deeply appreciated.
| >
| >
| >
| > Thanks
| >
| > Nalaka
| >
| >
| >
| >
| >
| >
|
|
|

Jan 13 '06 #6
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or other
markup language syntax error. Is it possible that you post a simpflief aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
<ex************ **@TK2MSFTNGP10 .phx.gbl>
<Nk************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5************ *@TK2MSFTNGP14. phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP14.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3707 31
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
| news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility.. ."
| > item to view the accessibility setting... Also for HTML checking, what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005 to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospa m.nospam>
| > | References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| > | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospa m.nospam> wrote in message
| > | news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors show
up
| > in
| > | > your error-list, you can disable this functionality by selecting the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #7
Hi Steven,
I have a zip file of
1. .aspx
2. aspx.cs
3. .bmp showing color related errors in VWD

I cannot attach the .zip file to this (it complains)
How can I send it to you.

Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
news:1$******** ******@TK2MSFTN GXA02.phx.gbl.. .
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
<ex************ **@TK2MSFTNGP10 .phx.gbl>
<Nk************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5************ *@TK2MSFTNGP14. phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP14.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3707 31
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
| news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility.. ."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospa m.nospam>
| > | References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospa m.nospam> wrote in message
| > | news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #8
Hi Steven
Attached .zip has
1. .aspx
2. .aspx.cs

Notice the color related errors.

I could not attach a screenm shot (.bmp) of errors showing up in VWD.
How can I email it to you?

Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
news:1$******** ******@TK2MSFTN GXA02.phx.gbl.. .
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
<ex************ **@TK2MSFTNGP10 .phx.gbl>
<Nk************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5************ *@TK2MSFTNGP14. phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP14.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3707 31
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
| news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility.. ."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospa m.nospam>
| > | References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospa m.nospam> wrote in message
| > | news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|



Jan 16 '06 #9
Hi Steven
Will email (to st*****@online. microsoft.com) a file with Attached .zip.
Has
1. .aspx
2. .aspx.cs
3. screen shot (.bmp) of the color related errors.
Thanks
Nalaka


"Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
news:1$******** ******@TK2MSFTN GXA02.phx.gbl.. .
If the designer is complaining about can not swtich from source view to
designview, there must exists some serious error, not generic html or
other
markup language syntax error. Is it possible that you post a simpflief
aspx
page's content to me so that we can have a test?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "Nalaka" <na******@nospa m.nospam>
| References: <us************ **@TK2MSFTNGP09 .phx.gbl>
<ex************ **@TK2MSFTNGP10 .phx.gbl>
<Nk************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: Re: disabling html validation does not seem to stck
| Date: Fri, 13 Jan 2006 12:19:09 -0800
| Lines: 127
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <O5************ *@TK2MSFTNGP14. phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP14.phx. gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3707 31
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi,
| For an example, now... following error now gets generated.
| (But this is code generated by the VWD designer itself.)
|
| Error 110 Validation (Internet Explorer 6): Element 'table' cannot be
nested
| within element 'span'.
|
|
| Thanks
| Nalaka
|
|
|
|
|
| "Steven Cheng[MSFT]" <st*****@online .microsoft.com> wrote in message
| news:Nk******** ******@TK2MSFTN GXA02.phx.gbl.. .
| > Hi Nalaka,
| >
| > Welcome.
| > For the VS 2005 ASP.NET html editor, it now includes not only HTML
content
| > validating , but also the Accessiblity checking, so not sure whether
the
| > warning and errors also indicate some accessiblity checking, you can
right
| > click the page in solution explorer and choose the "Check
| > Accessibility.. ."
| > item to view the accessibility setting... Also for HTML checking,
what's
| > your current setting , IE6 or XHTML .... ? Seems my local vs 2005
| > environment default to IE6 and won't be reset by the changes in IDE's
html
| > editor...
| > Also, you can consider copy the project on some box which has vs 2005
to
| > check the behavior, if that works ok, you can try comparing the
| > settings...
| >
| > Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | From: "Nalaka" <na******@nospa m.nospam>
| > | References: <us************ **@TK2MSFTNGP09 .phx.gbl>
| > | Subject: Re: disabling html validation does not seem to stck
| > | Date: Thu, 12 Jan 2006 12:03:29 -0800
| > | Lines: 56
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Response
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <ex************ **@TK2MSFTNGP10 .phx.gbl>
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: m181-9.bctransit.bc. ca 199.60.181.9
| > | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGP10.phx. gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3704 29
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi...
| > | Also html validation complains about colors like royalblue...
| > | How can I add these new colors to the css... ask it to ignore
colors.
| > |
| > |
| > | Thanks again
| > | Nalaka
| > |
| > |
| > | "Nalaka" <na******@nospa m.nospam> wrote in message
| > | news:us******** ******@TK2MSFTN GP09.phx.gbl...
| > | > Hi,
| > | >
| > | > I suddenly started getting a lot of errors from html validation
(some
| > CSS)
| > | >
| > | > so I followed the following instructions to disable it.
| > | >
| > | > If you'd rather not have these types of HTML validation errors
show
up
| > in
| > | > your error-list, you can disable this functionality by selecting
the
| > | > Tools->Options menu item in VS or Visual Web Developer. Select
the
| > | > TextEditor->Html->Validation tree option in the left-hand side of
the
| > | > options window, and uncheck the "Show Errors" checkbox:
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > But ... the problem is that unclicking check does not seem to
stick.
| > | >
| > | > When I click on the page, "show errors" check box checks itself
on,
| > and
| > I
| > | > cannot get to the design mode.
| > | >
| > | >
| > | >
| > | > How can I get visual web developer to stop checking for validation
| > | > errors???
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > Any help is deeply appreciated.
| > | >
| > | >
| > | >
| > | > Thanks
| > | >
| > | > Nalaka
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > |
| > |
| > |
| >
|
|
|

Jan 16 '06 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

81
5136
by: sinister | last post by:
I wanted to spiff up my overly spartan homepage, and started using some CSS templates I found on a couple of weblogs. It looks fine in my browser (IE 6.0), but it doesn't print right. I tested the blogs, and one definitely didn't print right. Surveying the web, my impression is that CSS is very unreliable, because even updated browsers...
2
1952
by: Daniel Stoever | last post by:
I have a client program that talks to an IBM mainframe and recieves 64bit unsigned integers(STCK) that represent date-time values. I need to convert these to native DateTime format for use in my c# code. There appears to be a convert function that takes a long parameter and returns a DateTime but not a ulong. Anyone have or know of any...
2
2993
by: Andy Fish | last post by:
Hi, I have one textbox on the form that needs to have ValidateRequest disabled, but it seems that it can only be enabled/disabled at a page level. assuming I have to disable it at for the whole page, how can I invoke ValidateRequest functionality for the other text boxes individually? I was looking for some kind of method on I can call...
4
1591
by: Arthur Dent | last post by:
Hello all, ive been programming with ASP.NET since it came out, but am just getting my feet with now with v.2. Ive noticed something strange in the way my HTML tables get rendered with 2. I use tables to layout my pages, doing three rows, a header, content and footer. When i do this, i make the tables height=100%, so the footer always shows...
5
1853
by: Rob Roberts | last post by:
Is there any way to change VS2005 to generate HTML 4.01/Strict instead of XHTML 1.0/Transititional? VS2005 puts a DOCTYPE statement specifying XHTML 1.0/Transitional at the top of every new aspx page. Is there any way to change it to specify an HTML 4.01/Strict DOCTYPE instead? Thanks in advance, --Rob Roberts
8
1773
by: goldtech | last post by:
Newbie esp about html validation - seems like something to strive for. Yet many pages even "enterprise" corporate type pages do not validate, yet seem to display well on most browsers. Two questions: 1. What is the reward, the reason to strive for a validating page? 2. Given the code snippet below which does not validate - how can...
11
12102
by: EagleRed | last post by:
I am writing an ASP.NET 2.0 application that uses master pages. I have some pages that must not be cached on the client. In ASP.NET 1.1 I achieved this using metatags: <meta http-equiv="Expires" content="0"> <meta http-equiv="Pragma" content="no-cache"> <meta http-equiv="Cache-Control" content="no-cache"> This tags are part of the...
8
2341
by: =?Utf-8?B?U2hhd24gUmFtaXJleg==?= | last post by:
I am coming at the world from the standpoint of a veteran ASP Classic developer. I am not clear on the advantages of using the ASP.NET control over standard HTML control. With the ASP.NET controls the rendered names are changed and I appear to be limited in what javascript events I can fire. I also can not seem to figure out how to setup...
2
2182
by: msch.prv | last post by:
Is there a specific method to disable field validators in a user control.from within a parent page or does it require an ad hoc approach? The page attribute ValidateRequest does not seem to be available in user controls. TIA for any inputs.
0
7886
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
7809
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language...
0
8159
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
8312
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
0
8183
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the...
1
5685
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes...
0
5366
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3809
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
1
2312
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.