473,597 Members | 2,839 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Question about "Configurat ion Error" Message

Hi, simple(?) question about asp.net configuration..

I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
first start application the follow message shown.
=========
Server Error in '/QuickStartv20' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.

Parser Error Message: An error occurred loading a configuration file: Failed
to start monitoring changes to 'd:\inetpub\www root' because access is denied.

Source Error:
[No relevant source lines]
Source File: d:\inetpub\wwwr oot\web.config Line: 0
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.507 27.42; ASP.NET
Version:2.0.507 27.42
=============== =============== =======

What's the problem? I can't imagine what's wrong...
Is there any body can tell me about, what's wrong???
and How can I fix this???

Have a Good day~~
Dec 2 '05 #1
10 3701
Hi Baho,

Welcome to ASPNET newsgroup.
From your description, after you installed the ASP.NET 2.0 QuickStart
examples on your machine, you get some Erros when starting running the
application, yes?

Based on the error message you pasted, I think this is a file access
permission issue. Seems the ASP.NET process idenitity dosn't have the
sufficient permission to access the webapplicaiton folder. Would you
please help me gather the following info:

1. What's your machine's OS version (IIS version)?

2. Where did you installed the quickstart example, directly under the IIS
default site's physical dir(inetpub\www root...)?

3. What's the current process idenitity which is used to running the
ASP.NET applcation(this depends on the things in #1 , the OS version)...

Please feel free to post here if there're anything else you found or I've
misunderstood.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configurat ion Error" Message
| thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| Subject: Question about "Configurat ion Error" Message
| Date: Thu, 1 Dec 2005 22:40:02 -0800
| Lines: 35
| Message-ID: <85************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi, simple(?) question about asp.net configuration..
|
| I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
| first start application the follow message shown.
| =========
| Server Error in '/QuickStartv20' Application.
----------------------------------------------------------------------------
----
|
| Configuration Error
| Description: An error occurred during the processing of a configuration
file
| required to service this request. Please review the specific error
details
| below and modify your configuration file appropriately.
|
| Parser Error Message: An error occurred loading a configuration file:
Failed
| to start monitoring changes to 'd:\inetpub\www root' because access is
denied.
|
| Source Error:
|
|
| [No relevant source lines]
|
|
| Source File: d:\inetpub\wwwr oot\web.config Line: 0
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:2.0.507 27.42;
ASP.NET
| Version:2.0.507 27.42
| =============== =============== =======
|
| What's the problem? I can't imagine what's wrong...
| Is there any body can tell me about, what's wrong???
| and How can I fix this???
|
| Have a Good day~~
|

Dec 2 '05 #2
Hi Steven

Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
examples on my machine. My machine environment details are
---------------------------------
1. OS version:
Windows XP Professional, SP2
ASP.NET version 2.0.50727

2. IIS physical directory:
D:\Inetpub\wwwr oot

3. QuickStart Sample dir:
D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart

4. current process identifier
aspnet_wp.exe 3628
inetinfo.exe 1968
---------------------------------
Hi Baho,

Welcome to ASPNET newsgroup.
From your description, after you installed the ASP.NET 2.0 QuickStart
examples on your machine, you get some Erros when starting running the
application, yes?

Based on the error message you pasted, I think this is a file access
permission issue. Seems the ASP.NET process idenitity dosn't have the
sufficient permission to access the webapplicaiton folder. Would you
please help me gather the following info:

1. What's your machine's OS version (IIS version)?

2. Where did you installed the quickstart example, directly under the IIS
default site's physical dir(inetpub\www root...)?

3. What's the current process idenitity which is used to running the
ASP.NET applcation(this depends on the things in #1 , the OS version)...

Please feel free to post here if there're anything else you found or I've
misunderstood.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configurat ion Error" Message
| thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| Subject: Question about "Configurat ion Error" Message
| Date: Thu, 1 Dec 2005 22:40:02 -0800
| Lines: 35
| Message-ID: <85************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi, simple(?) question about asp.net configuration..
|
| I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When I'm
| first start application the follow message shown.
| =========
| Server Error in '/QuickStartv20' Application.
----------------------------------------------------------------------------
----
|
| Configuration Error
| Description: An error occurred during the processing of a configuration
file
| required to service this request. Please review the specific error
details
| below and modify your configuration file appropriately.
|
| Parser Error Message: An error occurred loading a configuration file:
Failed
| to start monitoring changes to 'd:\inetpub\www root' because access is
denied.
|
| Source Error:
|
|
| [No relevant source lines]
|
|
| Source File: d:\inetpub\wwwr oot\web.config Line: 0
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:2.0.507 27.42;
ASP.NET
| Version:2.0.507 27.42
| =============== =============== =======
|
| What's the problem? I can't imagine what's wrong...
| Is there any body can tell me about, what's wrong???
| and How can I fix this???
|
| Have a Good day~~
|

Dec 3 '05 #3
Thanks for your quick response Baho,

So your machine is WINXP sp2 /IIS5.
Currently, I'd suggest you first try changing your ASP.NET's running
process's Account from default machine\aspnet to the LOCALSYSTEM to as to
make sure whether this is a permission problem of the asp.net process
idenitity. To change the process identity, you can follow the below steps:

1. locate the machine.config file under your .NET framework 2.0's intalling
folder like:

C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG

2. Open the machine.config file and find the <processModel > element, by
default it is configured as:

<processModel autoConfig="tru e" />

, we need to change it to below:

<processModel autoConfig="tru e" userName="Syste m"/>

so as to let the ASP.NET worker process running under the local system
account(which has the most powerful permission and privileges on local
system...)

3. Restart IIS through "iisreset" command
Then, test your asp.net 2.0 applicaiton again to see whether it can
works......

Also, this is just for testing only, generally we do not recommend asp.net
process running under local system account. Also, the machine.config' s
<processModel > element is used for IIS5 isolate model. For IIS6/win2k3
server, it by default use applicaiton pool model which is different from
this.

Anyway, please have a try to see whether it works and feel free to post
here if there're anything unclear...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| Thread-Topic: Question about "Configurat ion Error" Message
| thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: RE: Question about "Configurat ion Error" Message
| Date: Fri, 2 Dec 2005 18:20:02 -0800
| Lines: 129
| Message-ID: <14************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi Steven
|
| Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| examples on my machine. My machine environment details are
| ---------------------------------
| 1. OS version:
| Windows XP Professional, SP2
| ASP.NET version 2.0.50727
|
| 2. IIS physical directory:
| D:\Inetpub\wwwr oot
|
| 3. QuickStart Sample dir:
| D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart
|
| 4. current process identifier
| aspnet_wp.exe 3628
| inetinfo.exe 1968
| ---------------------------------
|
| > Hi Baho,
| >
| > Welcome to ASPNET newsgroup.
| > From your description, after you installed the ASP.NET 2.0 QuickStart
| > examples on your machine, you get some Erros when starting running the
| > application, yes?
| >
| > Based on the error message you pasted, I think this is a file access
| > permission issue. Seems the ASP.NET process idenitity dosn't have the
| > sufficient permission to access the webapplicaiton folder. Would you
| > please help me gather the following info:
| >
| > 1. What's your machine's OS version (IIS version)?
| >
| > 2. Where did you installed the quickstart example, directly under the
IIS
| > default site's physical dir(inetpub\www root...)?
| >
| > 3. What's the current process idenitity which is used to running the
| > ASP.NET applcation(this depends on the things in #1 , the OS
version)...
| >
| > Please feel free to post here if there're anything else you found or
I've
| > misunderstood.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configurat ion Error" Message
| > | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| > | Subject: Question about "Configurat ion Error" Message
| > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | Lines: 35
| > | Message-ID: <85************ *************** *******@microso ft.com>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi, simple(?) question about asp.net configuration..
| > |
| > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When
I'm
| > | first start application the follow message shown.
| > | =========
| > | Server Error in '/QuickStartv20' Application.
| >
----------------------------------------------------------------------------
| > ----
| > |
| > | Configuration Error
| > | Description: An error occurred during the processing of a
configuration
| > file
| > | required to service this request. Please review the specific error
| > details
| > | below and modify your configuration file appropriately.
| > |
| > | Parser Error Message: An error occurred loading a configuration file:
| > Failed
| > | to start monitoring changes to 'd:\inetpub\www root' because access is
| > denied.
| > |
| > | Source Error:
| > |
| > |
| > | [No relevant source lines]
| > |
| > |
| > | Source File: d:\inetpub\wwwr oot\web.config Line: 0
| > |
| > |
| >
----------------------------------------------------------------------------
| > ----
| > | Version Information: Microsoft .NET Framework Version:2.0.507 27.42;
| > ASP.NET
| > | Version:2.0.507 27.42
| > | =============== =============== =======
| > |
| > | What's the problem? I can't imagine what's wrong...
| > | Is there any body can tell me about, what's wrong???
| > | and How can I fix this???
| > |
| > | Have a Good day~~
| > |
| >
| >
|

Dec 5 '05 #4
Thank you Steven ^^ It's works..

But one more question... You said it was the permission of the asp.net
process. then what's the default permission shoule "default machine\aspnet"
account have for that foler, file or something others?
"Steven Cheng[MSFT]" wrote: Thanks for your quick response Baho,

So your machine is WINXP sp2 /IIS5.
Currently, I'd suggest you first try changing your ASP.NET's running
process's Account from default machine\aspnet to the LOCALSYSTEM to as to
make sure whether this is a permission problem of the asp.net process
idenitity. To change the process identity, you can follow the below steps:

1. locate the machine.config file under your .NET framework 2.0's intalling
folder like:

C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG

2. Open the machine.config file and find the <processModel > element, by
default it is configured as:

<processModel autoConfig="tru e" />

, we need to change it to below:

<processModel autoConfig="tru e" userName="Syste m"/>

so as to let the ASP.NET worker process running under the local system
account(which has the most powerful permission and privileges on local
system...)

3. Restart IIS through "iisreset" command
Then, test your asp.net 2.0 applicaiton again to see whether it can
works......

Also, this is just for testing only, generally we do not recommend asp.net
process running under local system account. Also, the machine.config' s
<processModel > element is used for IIS5 isolate model. For IIS6/win2k3
server, it by default use applicaiton pool model which is different from
this.

Anyway, please have a try to see whether it works and feel free to post
here if there're anything unclear...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| Thread-Topic: Question about "Configurat ion Error" Message
| thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| Subject: RE: Question about "Configurat ion Error" Message
| Date: Fri, 2 Dec 2005 18:20:02 -0800
| Lines: 129
| Message-ID: <14************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Hi Steven
|
| Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| examples on my machine. My machine environment details are
| ---------------------------------
| 1. OS version:
| Windows XP Professional, SP2
| ASP.NET version 2.0.50727
|
| 2. IIS physical directory:
| D:\Inetpub\wwwr oot
|
| 3. QuickStart Sample dir:
| D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart
|
| 4. current process identifier
| aspnet_wp.exe 3628
| inetinfo.exe 1968
| ---------------------------------
|
| > Hi Baho,
| >
| > Welcome to ASPNET newsgroup.
| > From your description, after you installed the ASP.NET 2.0 QuickStart
| > examples on your machine, you get some Erros when starting running the
| > application, yes?
| >
| > Based on the error message you pasted, I think this is a file access
| > permission issue. Seems the ASP.NET process idenitity dosn't have the
| > sufficient permission to access the webapplicaiton folder. Would you
| > please help me gather the following info:
| >
| > 1. What's your machine's OS version (IIS version)?
| >
| > 2. Where did you installed the quickstart example, directly under the
IIS
| > default site's physical dir(inetpub\www root...)?
| >
| > 3. What's the current process idenitity which is used to running the
| > ASP.NET applcation(this depends on the things in #1 , the OS
version)...
| >
| > Please feel free to post here if there're anything else you found or
I've
| > misunderstood.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configurat ion Error" Message
| > | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| > | Subject: Question about "Configurat ion Error" Message
| > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | Lines: 35
| > | Message-ID: <85************ *************** *******@microso ft.com>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi, simple(?) question about asp.net configuration..
| > |
| > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But, When
I'm
| > | first start application the follow message shown.
| > | =========
| > | Server Error in '/QuickStartv20' Application.
| >
----------------------------------------------------------------------------
| > ----
| > |
| > | Configuration Error
| > | Description: An error occurred during the processing of a
configuration
| > file
| > | required to service this request. Please review the specific error
| > details
| > | below and modify your configuration file appropriately.
| > |
| > | Parser Error Message: An error occurred loading a configuration file:
| > Failed
| > | to start monitoring changes to 'd:\inetpub\www root' because access is
| > denied.
| > |
| > | Source Error:
| > |
| > |
| > | [No relevant source lines]
| > |
| > |
| > | Source File: d:\inetpub\wwwr oot\web.config Line: 0
| > |
| > |
| >
----------------------------------------------------------------------------
| > ----
| > | Version Information: Microsoft .NET Framework Version:2.0.507 27.42;
| > ASP.NET
| > | Version:2.0.507 27.42
| > | =============== =============== =======
| > |
| > | What's the problem? I can't imagine what's wrong...
| > | Is there any body can tell me about, what's wrong???
| > | and How can I fix this???
| > |
| > | Have a Good day~~
| > |
| >
| >
|

Dec 5 '05 #5
Thanks for your quick response Baho,

So the problem is that the ASPNET worker process dosn't have sufficient
permission. And as for:

what's the default permission shoule "default machine\aspnet"
account have for that foler, file or something others?
=============== ==========
Good question, here is a msdn article described the permissions a normal
ASP.NET process account should have:

#How To Create a Custom Account to Run ASP.NET
http://msdn.microsoft.com/library/en...asp?frame=true

So as I mentioned before, local system is just used to confirm that this is
a security permission problem. We're recommended to still use the default
Machine\ASPNET account. And you can swtich back your asp.net's process
idenitity back to "Machine" and check the permissions step by step through
the above article....

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Question about "Configurat ion Error" Message
| thread-index: AcX5djq94c8ySid xTxSiSr4DaxOilg ==
| X-WBNR-Posting-Host: 210.182.98.176
| From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
<14************ *************** *******@microso ft.com>
<qL************ *@TK2MSFTNGXA02 .phx.gbl>
| Subject: RE: Question about "Configurat ion Error" Message
| Date: Mon, 5 Dec 2005 00:31:03 -0800
| Lines: 226
| Message-ID: <B9************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GXA03.phx.gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3626 98
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
|
| Thank you Steven ^^ It's works..
|
| But one more question... You said it was the permission of the asp.net
| process. then what's the default permission shoule "default
machine\aspnet"
| account have for that foler, file or something others?
|
| >"Steven Cheng[MSFT]" wrote:
|
| > Thanks for your quick response Baho,
| >
| > So your machine is WINXP sp2 /IIS5.
| > Currently, I'd suggest you first try changing your ASP.NET's running
| > process's Account from default machine\aspnet to the LOCALSYSTEM to as
to
| > make sure whether this is a permission problem of the asp.net process
| > idenitity. To change the process identity, you can follow the below
steps:
| >
| > 1. locate the machine.config file under your .NET framework 2.0's
intalling
| > folder like:
| >
| > C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG
| >
| > 2. Open the machine.config file and find the <processModel > element, by
| > default it is configured as:
| >
| > <processModel autoConfig="tru e" />
| >
| > , we need to change it to below:
| >
| > <processModel autoConfig="tru e" userName="Syste m"/>
| >
| > so as to let the ASP.NET worker process running under the local system
| > account(which has the most powerful permission and privileges on local
| > system...)
| >
| > 3. Restart IIS through "iisreset" command
| >
| >
| > Then, test your asp.net 2.0 applicaiton again to see whether it can
| > works......
| >
| > Also, this is just for testing only, generally we do not recommend
asp.net
| > process running under local system account. Also, the machine.config' s
| > <processModel > element is used for IIS5 isolate model. For IIS6/win2k3
| > server, it by default use applicaiton pool model which is different
from
| > this.
| >
| > Anyway, please have a try to see whether it works and feel free to post
| > here if there're anything unclear...
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| > --------------------
| > | Thread-Topic: Question about "Configurat ion Error" Message
| > | thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| > | X-WBNR-Posting-Host: 210.182.98.176
| > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| > | References: <85************ *************** *******@microso ft.com>
| > <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| > | Subject: RE: Question about "Configurat ion Error" Message
| > | Date: Fri, 2 Dec 2005 18:20:02 -0800
| > | Lines: 129
| > | Message-ID: <14************ *************** *******@microso ft.com>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 7bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| > | Xref: TK2MSFTNGXA02.p hx.gbl
| > microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > |
| > | Hi Steven
| > |
| > | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| > | examples on my machine. My machine environment details are
| > | ---------------------------------
| > | 1. OS version:
| > | Windows XP Professional, SP2
| > | ASP.NET version 2.0.50727
| > |
| > | 2. IIS physical directory:
| > | D:\Inetpub\wwwr oot
| > |
| > | 3. QuickStart Sample dir:
| > | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart
| > |
| > | 4. current process identifier
| > | aspnet_wp.exe 3628
| > | inetinfo.exe 1968
| > | ---------------------------------
| > |
| > | > Hi Baho,
| > | >
| > | > Welcome to ASPNET newsgroup.
| > | > From your description, after you installed the ASP.NET 2.0
QuickStart
| > | > examples on your machine, you get some Erros when starting running
the
| > | > application, yes?
| > | >
| > | > Based on the error message you pasted, I think this is a file
access
| > | > permission issue. Seems the ASP.NET process idenitity dosn't have
the
| > | > sufficient permission to access the webapplicaiton folder. Would
you
| > | > please help me gather the following info:
| > | >
| > | > 1. What's your machine's OS version (IIS version)?
| > | >
| > | > 2. Where did you installed the quickstart example, directly under
the
| > IIS
| > | > default site's physical dir(inetpub\www root...)?
| > | >
| > | > 3. What's the current process idenitity which is used to running
the
| > | > ASP.NET applcation(this depends on the things in #1 , the OS
| > version)...
| > | >
| > | > Please feel free to post here if there're anything else you found
or
| > I've
| > | > misunderstood.
| > | >
| > | > Thanks,
| > | >
| > | > Steven Cheng
| > | > Microsoft Online Support
| > | >
| > | > Get Secure! www.microsoft.com/security
| > | > (This posting is provided "AS IS", with no warranties, and confers
no
| > | > rights.)
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | >
| > | > --------------------
| > | > | Thread-Topic: Question about "Configurat ion Error" Message
| > | > | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| > | > | X-WBNR-Posting-Host: 210.182.98.176
| > | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| > | > | Subject: Question about "Configurat ion Error" Message
| > | > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| > | > | Lines: 35
| > | > | Message-ID: <85************ *************** *******@microso ft.com>
| > | > | MIME-Version: 1.0
| > | > | Content-Type: text/plain;
| > | > | charset="Utf-8"
| > | > | Content-Transfer-Encoding: 7bit
| > | > | X-Newsreader: Microsoft CDO for Windows 2000
| > | > | Content-Class: urn:content-classes:message
| > | > | Importance: normal
| > | > | Priority: normal
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| > | > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| > | > | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| > | > | Xref: TK2MSFTNGXA02.p hx.gbl
| > | > microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| > | > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| > | > |
| > | > | Hi, simple(?) question about asp.net configuration..
| > | > |
| > | > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But,
When
| > I'm
| > | > | first start application the follow message shown.
| > | > | =========
| > | > | Server Error in '/QuickStartv20' Application.
| > | >
| >
----------------------------------------------------------------------------
| > | > ----
| > | > |
| > | > | Configuration Error
| > | > | Description: An error occurred during the processing of a
| > configuration
| > | > file
| > | > | required to service this request. Please review the specific
error
| > | > details
| > | > | below and modify your configuration file appropriately.
| > | > |
| > | > | Parser Error Message: An error occurred loading a configuration
file:
| > | > Failed
| > | > | to start monitoring changes to 'd:\inetpub\www root' because
access is
| > | > denied.
| > | > |
| > | > | Source Error:
| > | > |
| > | > |
| > | > | [No relevant source lines]
| > | > |
| > | > |
| > | > | Source File: d:\inetpub\wwwr oot\web.config Line: 0
| > | > |
| > | > |
| > | >
| >
----------------------------------------------------------------------------
| > | > ----
| > | > | Version Information: Microsoft .NET Framework
Version:2.0.507 27.42;
| > | > ASP.NET
| > | > | Version:2.0.507 27.42
| > | > | =============== =============== =======
| > | > |
| > | > | What's the problem? I can't imagine what's wrong...
| > | > | Is there any body can tell me about, what's wrong???
| > | > | and How can I fix this???
| > | > |
| > | > | Have a Good day~~
| > | > |
| > | >
| > | >
| > |
| >
| >
|

Dec 5 '05 #6
Hi Baho,

Any further questions or anything else we can help, if so, please feel free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
<14************ *************** *******@microso ft.com>
<qL************ *@TK2MSFTNGXA02 .phx.gbl>
<B9************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online. microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configurat ion Error" Message
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| Message-ID: <52************ *@TK2MSFTNGXA02 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.p hx.gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3627 01
| NNTP-Posting-Host: tomcatimport2.p hx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =============== ==========
| Good question, here is a msdn article described the permissions a normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that this
is
| a security permission problem. We're recommended to still use the default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configurat ion Error" Message
| | thread-index: AcX5djq94c8ySid xTxSiSr4DaxOilg ==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | References: <85************ *************** *******@microso ft.com>
| <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| <14************ *************** *******@microso ft.com>
| <qL************ *@TK2MSFTNGXA02 .phx.gbl>
| | Subject: RE: Question about "Configurat ion Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9************ *************** *******@microso ft.com>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.p hx.gbl
| microsoft.publi c.dotnet.framew ork.aspnet:3626 98
| | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | > Thanks for your quick response Baho,
| | >
| | > So your machine is WINXP sp2 /IIS5.
| | > Currently, I'd suggest you first try changing your ASP.NET's running
| | > process's Account from default machine\aspnet to the LOCALSYSTEM to
as
| to
| | > make sure whether this is a permission problem of the asp.net process
| | > idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | > 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | > folder like:
| | >
| | > C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG
| | >
| | > 2. Open the machine.config file and find the <processModel > element,
by
| | > default it is configured as:
| | >
| | > <processModel autoConfig="tru e" />
| | >
| | > , we need to change it to below:
| | >
| | > <processModel autoConfig="tru e" userName="Syste m"/>
| | >
| | > so as to let the ASP.NET worker process running under the local
system
| | > account(which has the most powerful permission and privileges on
local
| | > system...)
| | >
| | > 3. Restart IIS through "iisreset" command
| | >
| | >
| | > Then, test your asp.net 2.0 applicaiton again to see whether it can
| | > works......
| | >
| | > Also, this is just for testing only, generally we do not recommend
| asp.net
| | > process running under local system account. Also, the
machine.config' s
| | > <processModel > element is used for IIS5 isolate model. For
IIS6/win2k3
| | > server, it by default use applicaiton pool model which is different
| from
| | > this.
| | >
| | > Anyway, please have a try to see whether it works and feel free to
post
| | > here if there're anything unclear...
| | >
| | > Thanks,
| | >
| | > Steven Cheng
| | > Microsoft Online Support
| | >
| | > Get Secure! www.microsoft.com/security
| | > (This posting is provided "AS IS", with no warranties, and confers no
| | > rights.)
| | >
| | >
| | >
| | > --------------------
| | > | Thread-Topic: Question about "Configurat ion Error" Message
| | > | thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| | > | X-WBNR-Posting-Host: 210.182.98.176
| | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | > | References: <85************ *************** *******@microso ft.com>
| | > <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| | > | Subject: RE: Question about "Configurat ion Error" Message
| | > | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | > | Lines: 129
| | > | Message-ID: <14************ *************** *******@microso ft.com>
| | > | MIME-Version: 1.0
| | > | Content-Type: text/plain;
| | > | charset="Utf-8"
| | > | Content-Transfer-Encoding: 7bit
| | > | X-Newsreader: Microsoft CDO for Windows 2000
| | > | Content-Class: urn:content-classes:message
| | > | Importance: normal
| | > | Priority: normal
| | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | > | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | > | Xref: TK2MSFTNGXA02.p hx.gbl
| | > microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| | > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | > |
| | > | Hi Steven
| | > |
| | > | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| | > | examples on my machine. My machine environment details are
| | > | ---------------------------------
| | > | 1. OS version:
| | > | Windows XP Professional, SP2
| | > | ASP.NET version 2.0.50727
| | > |
| | > | 2. IIS physical directory:
| | > | D:\Inetpub\wwwr oot
| | > |
| | > | 3. QuickStart Sample dir:
| | > | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart
| | > |
| | > | 4. current process identifier
| | > | aspnet_wp.exe 3628
| | > | inetinfo.exe 1968
| | > | ---------------------------------
| | > |
| | > | > Hi Baho,
| | > | >
| | > | > Welcome to ASPNET newsgroup.
| | > | > From your description, after you installed the ASP.NET 2.0
| QuickStart
| | > | > examples on your machine, you get some Erros when starting
running
| the
| | > | > application, yes?
| | > | >
| | > | > Based on the error message you pasted, I think this is a file
| access
| | > | > permission issue. Seems the ASP.NET process idenitity dosn't have
| the
| | > | > sufficient permission to access the webapplicaiton folder. Would
| you
| | > | > please help me gather the following info:
| | > | >
| | > | > 1. What's your machine's OS version (IIS version)?
| | > | >
| | > | > 2. Where did you installed the quickstart example, directly under
| the
| | > IIS
| | > | > default site's physical dir(inetpub\www root...)?
| | > | >
| | > | > 3. What's the current process idenitity which is used to running
| the
| | > | > ASP.NET applcation(this depends on the things in #1 , the OS
| | > version)...
| | > | >
| | > | > Please feel free to post here if there're anything else you found
| or
| | > I've
| | > | > misunderstood.
| | > | >
| | > | > Thanks,
| | > | >
| | > | > Steven Cheng
| | > | > Microsoft Online Support
| | > | >
| | > | > Get Secure! www.microsoft.com/security
| | > | > (This posting is provided "AS IS", with no warranties, and
confers
| no
| | > | > rights.)
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | >
| | > | > --------------------
| | > | > | Thread-Topic: Question about "Configurat ion Error" Message
| | > | > | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| | > | > | X-WBNR-Posting-Host: 210.182.98.176
| | > | > | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | > | > | Subject: Question about "Configurat ion Error" Message
| | > | > | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | > | > | Lines: 35
| | > | > | Message-ID: <85************ *************** *******@microso ft.com>
| | > | > | MIME-Version: 1.0
| | > | > | Content-Type: text/plain;
| | > | > | charset="Utf-8"
| | > | > | Content-Transfer-Encoding: 7bit
| | > | > | X-Newsreader: Microsoft CDO for Windows 2000
| | > | > | Content-Class: urn:content-classes:message
| | > | > | Importance: normal
| | > | > | Priority: normal
| | > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | > | > | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | > | > | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | > | > | Path:
| TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | > | > | Xref: TK2MSFTNGXA02.p hx.gbl
| | > | > microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| | > | > | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | > | > |
| | > | > | Hi, simple(?) question about asp.net configuration..
| | > | > |
| | > | > | I've installed ASP.NET 2.0 QuickStart Sample successfully. But,
| When
| | > I'm
| | > | > | first start application the follow message shown.
| | > | > | =========
| | > | > | Server Error in '/QuickStartv20' Application.
| | > | >
| | >
|
----------------------------------------------------------------------------
| | > | > ----
| | > | > |
| | > | > | Configuration Error
| | > | > | Description: An error occurred during the processing of a
| | > configuration
| | > | > file
| | > | > | required to service this request. Please review the specific
| error
| | > | > details
| | > | > | below and modify your configuration file appropriately.
| | > | > |
| | > | > | Parser Error Message: An error occurred loading a configuration
| file:
| | > | > Failed
| | > | > | to start monitoring changes to 'd:\inetpub\www root' because
| access is
| | > | > denied.
| | > | > |
| | > | > | Source Error:
| | > | > |
| | > | > |
| | > | > | [No relevant source lines]
| | > | > |
| | > | > |
| | > | > | Source File: d:\inetpub\wwwr oot\web.config Line: 0
| | > | > |
| | > | > |
| | > | >
| | >
|
----------------------------------------------------------------------------
| | > | > ----
| | > | > | Version Information: Microsoft .NET Framework
| Version:2.0.507 27.42;
| | > | > ASP.NET
| | > | > | Version:2.0.507 27.42
| | > | > | =============== =============== =======
| | > | > |
| | > | > | What's the problem? I can't imagine what's wrong...
| | > | > | Is there any body can tell me about, what's wrong???
| | > | > | and How can I fix this???
| | > | > |
| | > | > | Have a Good day~~
| | > | > |
| | > | >
| | > | >
| | > |
| | >
| | >
| |
|
|

Dec 7 '05 #7
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me. Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1. Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
Hi Baho,

Any further questions or anything else we can help, if so, please feel free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
<14************ *************** *******@microso ft.com>
<qL************ *@TK2MSFTNGXA02 .phx.gbl>
<B9************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online. microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configurat ion Error" Message
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| Message-ID: <52************ *@TK2MSFTNGXA02 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.p hx.gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3627 01
| NNTP-Posting-Host: tomcatimport2.p hx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =============== ==========
| Good question, here is a msdn article described the permissions a normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that this
is
| a security permission problem. We're recommended to still use the default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configurat ion Error" Message
| | thread-index: AcX5djq94c8ySid xTxSiSr4DaxOilg ==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | References: <85************ *************** *******@microso ft.com>
| <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| <14************ *************** *******@microso ft.com>
| <qL************ *@TK2MSFTNGXA02 .phx.gbl>
| | Subject: RE: Question about "Configurat ion Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9************ *************** *******@microso ft.com>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.p hx.gbl
| microsoft.publi c.dotnet.framew ork.aspnet:3626 98
| | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's running
| | process's Account from default machine\aspnet to the LOCALSYSTEM to
as
| to
| | make sure whether this is a permission problem of the asp.net process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG
| | >
| | 2. Open the machine.config file and find the <processModelel ement,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="tru e" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="tru e" userName="Syste m"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config' s
| | <processModelel ement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configurat ion Error" Message
| | | thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | | References: <85************ *************** *******@microso ft.com>
| | <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| | | Subject: RE: Question about "Configurat ion Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14************ *************** *******@microso ft.com>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | | Xref: TK2MSFTNGXA02.p hx.gbl
| | microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| | | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0 QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwr oot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Quic kStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't have
| the
| | | sufficient permission to access the webapplicaiton folder. Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly under
| the
| | IIS
| | | default site's physical dir(inetpub\www root...)?
| | | >
| | | 3. What's the current process idenitity which is used to running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you found
| or
| | I've
| | | misunderstood.
| | | >
| | | Thanks,
| | | >
| | | Steven Cheng
| | | Microsoft Online Support
| | | >
| | | Get Secure! www.microsoft.com/security
| | | (This posting is provided "AS IS", with no warranties, and
confers
| no
| | | rights.)
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | --------------------
| | | | Thread-Topic: Question about "Configurat ion Error" Message
| | | | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| | | | X-WBNR-Posting-Host: 210.182.98.176
| | | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | | | Subject: Question about "Configurat ion Error" Message
| | | | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | | | Lines: 35
| | | | Message-ID: <85************ *************** *******@microso ft.com>
| | | | MIME-Version: 1.0
| | | | Content-Type: text/plain;
| | | | charset="Utf-8"
| | | | Content-Transfer-Encoding: 7bit
| | | | X-Newsreader: Microsoft CDO for Windows 2000
| | | | Content-Class: urn:content-classes:message
| | | | Importance: normal
| | | | Priority: normal
| | | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | | | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | | | Path:
| TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | | | Xref: TK2MSFTNGXA02.p hx.gbl
| | | microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| | | | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | | |
Oct 9 '06 #8
What happens if you just run http://localhost ?

or http://127.0.0.1 ?

Jeff
"Perryt" <Pe****@discuss ions.microsoft. comwrote in message
news:C2******** *************** ***********@mic rosoft.com...
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me.
Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then
appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1.
Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they
will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
>Hi Baho,

Any further questions or anything else we can help, if so, please feel
free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85************ *************** *******@microso ft.com>
<Df*********** ***@TK2MSFTNGXA 02.phx.gbl>
<14*********** *************** ********@micros oft.com>
<qL*********** **@TK2MSFTNGXA0 2.phx.gbl>
<B9*********** *************** ********@micros oft.com>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online. microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configurat ion Error" Message
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| Message-ID: <52************ *@TK2MSFTNGXA02 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.p hx.gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publ ic.dotnet.frame work.aspnet:362 701
| NNTP-Posting-Host: tomcatimport2.p hx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =============== ==========
| Good question, here is a msdn article described the permissions a
normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that
this
is
| a security permission problem. We're recommended to still use the
default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configurat ion Error" Message
| | thread-index: AcX5djq94c8ySid xTxSiSr4DaxOilg ==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | References: <85************ *************** *******@microso ft.com>
| <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| <14************ *************** *******@microso ft.com>
| <qL************ *@TK2MSFTNGXA02 .phx.gbl>
| | Subject: RE: Question about "Configurat ion Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9************ *************** *******@microso ft.com>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.p hx.gbl
| microsoft.publi c.dotnet.framew ork.aspnet:3626 98
| | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the
asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's
running
| | process's Account from default machine\aspnet to the LOCALSYSTEM
to
as
| to
| | make sure whether this is a permission problem of the asp.net
process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG
| | >
| | 2. Open the machine.config file and find the <processModel >
element,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="tru e" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="tru e" userName="Syste m"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config 's
| | <processModelel ement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers
no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configurat ion Error" Message
| | | thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | | References: <85************ *************** *******@microso ft.com>
| | <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| | | Subject: RE: Question about "Configurat ion Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14************ *************** *******@microso ft.com>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02. phx.gbl!TK2MSFT NGP08.phx.gbl!T K2MSFTNGXA03.ph x.gbl
| | | Xref: TK2MSFTNGXA02.p hx.gbl
| | microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| | | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0
QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwr oot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\Qui ckStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't
have
| the
| | | sufficient permission to access the webapplicaiton folder.
Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly
under
| the
| | IIS
| | | default site's physical dir(inetpub\www root...)?
| | | >
| | | 3. What's the current process idenitity which is used to
running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you
found
| or
| | I've
| | | misunderstood.
| | | >
| | | Thanks,
| | | >
| | | Steven Cheng
| | | Microsoft Online Support
| | | >
| | | Get Secure! www.microsoft.com/security
| | | (This posting is provided "AS IS", with no warranties, and
confers
| no
| | | rights.)
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | >
| | | --------------------
| | | | Thread-Topic: Question about "Configurat ion Error" Message
| | | | thread-index: AcX3CzjCdckva5n JSQO1GEyzHD3TGQ ==
| | | | X-WBNR-Posting-Host: 210.182.98.176
| | | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | | | Subject: Question about "Configurat ion Error" Message
| | | | Date: Thu, 1 Dec 2005 22:40:02 -0800
| | | | Lines: 35
| | | | Message-ID:
<85*********** *************** ********@micros oft.com>
| | | | MIME-Version: 1.0
| | | | Content-Type: text/plain;
| | | | charset="Utf-8"
| | | | Content-Transfer-Encoding: 7bit
| | | | X-Newsreader: Microsoft CDO for Windows 2000
| | | | Content-Class: urn:content-classes:message
| | | | Importance: normal
| | | | Priority: normal
| | | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | | | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | | | Path:
| TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | | | Xref: TK2MSFTNGXA02.p hx.gbl
| | | microsoft.publi c.dotnet.framew ork.aspnet:3622 49
| | | | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | | |

Oct 9 '06 #9
The default.html page I have at Http://localhost loads just fine. Also .ASP
pages load fine it seems to only be th .NET pages that have the issue.

"Jeff Dillon" wrote:
What happens if you just run http://localhost ?

or http://127.0.0.1 ?

Jeff
"Perryt" <Pe****@discuss ions.microsoft. comwrote in message
news:C2******** *************** ***********@mic rosoft.com...
Ok now I have have a question for you.,.

I have a similar problem but this solution as not fixed it for me.
Whenever
I try to start an ASPX or ASMX page via the IIS server
(http://localhost/beachdrne/default.aspx) the browser beeps and then
appears
to just hang. I have reset the machine.Config for both 2.0 and 1.1.
Neither
of these seems to work.

Any ideas?

I can tell you if I create a web site using the file system option they
will
work.

I have uninstalled and reinstalled IIS several times and run the
aspnet_regiis -i several times.
"Steven Cheng[MSFT]" wrote:
Hi Baho,

Any further questions or anything else we can help, if so, please feel
free
to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| X-Tomcat-ID: 139695801
| References: <85************ *************** *******@microso ft.com>
<Df************ **@TK2MSFTNGXA0 2.phx.gbl>
<14************ *************** *******@microso ft.com>
<qL************ *@TK2MSFTNGXA02 .phx.gbl>
<B9************ *************** *******@microso ft.com>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online. microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Mon, 05 Dec 2005 08:57:58 GMT
| Subject: RE: Question about "Configurat ion Error" Message
| X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| Message-ID: <52************ *@TK2MSFTNGXA02 .phx.gbl>
| Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| Lines: 269
| Path: TK2MSFTNGXA02.p hx.gbl
| Xref: TK2MSFTNGXA02.p hx.gbl
microsoft.publi c.dotnet.framew ork.aspnet:3627 01
| NNTP-Posting-Host: tomcatimport2.p hx.gbl 10.201.218.182
|
| Thanks for your quick response Baho,
|
| So the problem is that the ASPNET worker process dosn't have sufficient
| permission. And as for:
|
| what's the default permission shoule "default machine\aspnet"
| account have for that foler, file or something others?
| =============== ==========
| Good question, here is a msdn article described the permissions a
normal
| ASP.NET process account should have:
|
| #How To Create a Custom Account to Run ASP.NET
|
http://msdn.microsoft.com/library/en...asp?frame=true
|
| So as I mentioned before, local system is just used to confirm that
this
is
| a security permission problem. We're recommended to still use the
default
| Machine\ASPNET account. And you can swtich back your asp.net's process
| idenitity back to "Machine" and check the permissions step by step
through
| the above article....
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
| --------------------
| | Thread-Topic: Question about "Configurat ion Error" Message
| | thread-index: AcX5djq94c8ySid xTxSiSr4DaxOilg ==
| | X-WBNR-Posting-Host: 210.182.98.176
| | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | References: <85************ *************** *******@microso ft.com>
| <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| <14************ *************** *******@microso ft.com>
| <qL************ *@TK2MSFTNGXA02 .phx.gbl>
| | Subject: RE: Question about "Configurat ion Error" Message
| | Date: Mon, 5 Dec 2005 00:31:03 -0800
| | Lines: 226
| | Message-ID: <B9************ *************** *******@microso ft.com>
| | MIME-Version: 1.0
| | Content-Type: text/plain;
| | charset="Utf-8"
| | Content-Transfer-Encoding: 7bit
| | X-Newsreader: Microsoft CDO for Windows 2000
| | Content-Class: urn:content-classes:message
| | Importance: normal
| | Priority: normal
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | Path: TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GXA03.phx.gbl
| | Xref: TK2MSFTNGXA02.p hx.gbl
| microsoft.publi c.dotnet.framew ork.aspnet:3626 98
| | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| |
| | Thank you Steven ^^ It's works..
| |
| | But one more question... You said it was the permission of the
asp.net
| | process. then what's the default permission shoule "default
| machine\aspnet"
| | account have for that foler, file or something others?
| |
| | >"Steven Cheng[MSFT]" wrote:
| |
| | Thanks for your quick response Baho,
| | >
| | So your machine is WINXP sp2 /IIS5.
| | Currently, I'd suggest you first try changing your ASP.NET's
running
| | process's Account from default machine\aspnet to the LOCALSYSTEM
to
as
| to
| | make sure whether this is a permission problem of the asp.net
process
| | idenitity. To change the process identity, you can follow the below
| steps:
| | >
| | 1. locate the machine.config file under your .NET framework 2.0's
| intalling
| | folder like:
| | >
| | C:\WINDOWS\Micr osoft.NET\Frame work\v2.0.50727 \CONFIG
| | >
| | 2. Open the machine.config file and find the <processModel >
element,
by
| | default it is configured as:
| | >
| | <processModel autoConfig="tru e" />
| | >
| | , we need to change it to below:
| | >
| | <processModel autoConfig="tru e" userName="Syste m"/>
| | >
| | so as to let the ASP.NET worker process running under the local
system
| | account(which has the most powerful permission and privileges on
local
| | system...)
| | >
| | 3. Restart IIS through "iisreset" command
| | >
| | >
| | Then, test your asp.net 2.0 applicaiton again to see whether it can
| | works......
| | >
| | Also, this is just for testing only, generally we do not recommend
| asp.net
| | process running under local system account. Also, the
machine.config' s
| | <processModelel ement is used for IIS5 isolate model. For
IIS6/win2k3
| | server, it by default use applicaiton pool model which is different
| from
| | this.
| | >
| | Anyway, please have a try to see whether it works and feel free to
post
| | here if there're anything unclear...
| | >
| | Thanks,
| | >
| | Steven Cheng
| | Microsoft Online Support
| | >
| | Get Secure! www.microsoft.com/security
| | (This posting is provided "AS IS", with no warranties, and confers
no
| | rights.)
| | >
| | >
| | >
| | --------------------
| | | Thread-Topic: Question about "Configurat ion Error" Message
| | | thread-index: AcX3sBD65EPm92M aQzSgIHOQBE34Gw ==
| | | X-WBNR-Posting-Host: 210.182.98.176
| | | From: "=?Utf-8?B?UmlkZXI=?=" <ba**@newsgroup s.nospam>
| | | References: <85************ *************** *******@microso ft.com>
| | <Df************ **@TK2MSFTNGXA0 2.phx.gbl>
| | | Subject: RE: Question about "Configurat ion Error" Message
| | | Date: Fri, 2 Dec 2005 18:20:02 -0800
| | | Lines: 129
| | | Message-ID: <14************ *************** *******@microso ft.com>
| | | MIME-Version: 1.0
| | | Content-Type: text/plain;
| | | charset="Utf-8"
| | | Content-Transfer-Encoding: 7bit
| | | X-Newsreader: Microsoft CDO for Windows 2000
| | | Content-Class: urn:content-classes:message
| | | Importance: normal
| | | Priority: normal
| | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| | | Newsgroups: microsoft.publi c.dotnet.framew ork.aspnet
| | | NNTP-Posting-Host: TK2MSFTNGXA03.p hx.gbl 10.40.2.250
| | | Path:
TK2MSFTNGXA02.p hx.gbl!TK2MSFTN GP08.phx.gbl!TK 2MSFTNGXA03.phx .gbl
| | | Xref: TK2MSFTNGXA02.p hx.gbl
| | microsoft.publi c.dotnet.framew ork.aspnet:3624 58
| | | X-Tomcat-NG: microsoft.publi c.dotnet.framew ork.aspnet
| | |
| | | Hi Steven
| | |
| | | Yes, I've got error. After you installed the ASP.NET 2.0
QuickStart
| | | examples on my machine. My machine environment details are
| | | ---------------------------------
| | | 1. OS version:
| | | Windows XP Professional, SP2
| | | ASP.NET version 2.0.50727
| | |
| | | 2. IIS physical directory:
| | | D:\Inetpub\wwwr oot
| | |
| | | 3. QuickStart Sample dir:
| | | D:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\Quic kStart
| | |
| | | 4. current process identifier
| | | aspnet_wp.exe 3628
| | | inetinfo.exe 1968
| | | ---------------------------------
| | |
| | | Hi Baho,
| | | >
| | | Welcome to ASPNET newsgroup.
| | | From your description, after you installed the ASP.NET 2.0
| QuickStart
| | | examples on your machine, you get some Erros when starting
running
| the
| | | application, yes?
| | | >
| | | Based on the error message you pasted, I think this is a file
| access
| | | permission issue. Seems the ASP.NET process idenitity dosn't
have
| the
| | | sufficient permission to access the webapplicaiton folder.
Would
| you
| | | please help me gather the following info:
| | | >
| | | 1. What's your machine's OS version (IIS version)?
| | | >
| | | 2. Where did you installed the quickstart example, directly
under
| the
| | IIS
| | | default site's physical dir(inetpub\www root...)?
| | | >
| | | 3. What's the current process idenitity which is used to
running
| the
| | | ASP.NET applcation(this depends on the things in #1 , the OS
| | version)...
| | | >
| | | Please feel free to post here if there're anything else you
found
| or
Oct 9 '06 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
4597
by: Brian Morris | last post by:
I'm new to .NET and just trying a few things out, like emailing. I created a form in Visual Studio .Net to input some information for generating an email and I'm getting the following error when it executes both on my server or on the server of the .NET service provider. I'm obviously missing something very basic and I'm hoping one of you can point out my error. Thank you for your assistance. Brian
0
2244
by: jb_in_marietta | last post by:
I have a Dot Net project that references a COM DLL called "Crypto.dll," which is registered on my machine. I added the reference via the "Add Reference" dialog in Visual Studio Dot Net, and I am successfully accessing methods in this DLL in some of my classes. "Interop.CRYPTOLib" is the name of the interop VS.NET created for me when I added the reference. Frequently, when I try to run my application, I get the error that follows.
15
3871
by: yim | last post by:
Hi all, I got the error message "Arg list too long" when linking a lot of object files. Does anyone know how to resolve this problem ? Thanks for help, Sakun
5
4952
by: TJS | last post by:
trying to display pdf file in browser fails on this line: Response.ContentType = "application/pdf" getting an error about no declaration found for "response" what declaration is needed ???
3
2046
by: Rod | last post by:
I am getting a strange error when I attempt to run my new ASP.NET application through an ISA server. If I go to the ISA server machine and open up IIS and perform a Browse on the virtual directory pointing to the new ASP.NET application, I get the following error message: Parser Error Message: Could not load type NewWebApp.Global Line 1: <%@ Application Codebehind="Global.asax.cs" Inherits=" NewWebApp.Global" %>
1
1854
by: Dgates | last post by:
This request might belong in a "SQL"-related newsgroup, but it's such a pain using Agent to subscribe to a new group (and download its 50,000 messages!) just to ask one question. So, since it deals with an ASP.NET app, I thought I'd ask here. ============================================== I am using Web Data Adminstrator, which I downloaded recently from the Microsoft site. I get an error when I create tables or columns:
3
8820
by: Brian Foree | last post by:
I am developing an ASP.NET application that uses Access 2000 as its backend, and have just started getting the following error on 2 ASP.NET pages that had been working until late last week (and I don't think I made any changes to either page other than changing the user control that creates the header). Server Error in '/myApp' Application. ---------------------------------------------------------------------------- ----
21
7818
by: comp.lang.tcl | last post by:
set php {<? print_r("Hello World"); ?>} puts $php; # PRINTS OUT <? print_r("Hello World"); ?> puts When I try this within TCL I get the following error:
3
2875
by: Michel Couche | last post by:
Hello, I have an ASP.Net application that uses the Wizard control to build a newsletter. There are three steps in the wizard. The customer's specific design data are loaded from a database in step 1 of the wizard and saved into a session variable. In step 2, when the user clicks on a button, I load the design data from the session variable and these are saved for further handling in a HashTable. The HashTable is defined in the...
0
7967
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
7885
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
8272
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
8031
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
8258
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
5847
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
3882
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
1
2403
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
0
1233
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.