By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,162 Members | 1,061 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,162 IT Pros & Developers. It's quick & easy.

Permission error accessing a COM+ proxy

P: 1
I have 2 servers: The first one is a win2003 data server
The second is a win2003 web server

On the first server I created a COM+ app, exported it as a COM+ proxy (did not check the 1.0 compliant box), and installed it on the web server.

In the web server with VB6 I made an small program that calls one of the methods in the proxy that works fine

But from an ASP page using
Server.CreateObject("MyApp.GetYear")it returns an error.

from this forum and many google searches i'm almost 100% certain this is a permission problem in the data server, but I don't know for whom or what.

on the data server:
a) I created a group DataGroup to include the users that will need access

b) In the component services section I've already modified COM Security in MyComputer to allow DataGroup to launch and activate both locally and remotely

c)I've added the DataGroup to the users of the CreatorOwner Role of the application

also per a previous thread in this website (
http://bytes.com/topic/asp-classic/a...ting-com-proxy)

I created duplicates of the IUSR and IWAM accounts of the webserver as local accounts on the data server (with the same passwords) and added them to the DataGroup

Unfortunately none of this has worked and the ASP page still returns an error. I'm not sure what else or what am I still missing.

I don't have this problem when running this same application from the same webserver but pointing to a data server on a machine with win2000 server.

I'll really appreciate any advice
Thanks
Jun 10 '13 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.