By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,867 Members | 1,981 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,867 IT Pros & Developers. It's quick & easy.

Russian characters are showing up as "???"

P: 3
I am reading a record from an Oracle database. The Russian names are showing up as "???"

<%
Response.ContentType = "text/html"
Response.AddHeader "Content-Type", "text/html;charset=UTF-8"
Response.CodePage = 65001
Response.CharSet = "UTF-8"

Dim objConn
Dim rs
Set objConn = Server.CreateObject("ADODB.Connection")

objConn.Open "dsn=orcldsn; uid=admin; pwd=password"

Set rs = Server.CreateObject("ADODB.Recordset")
sqlstr="SELECT e.username, e.fname, e.lname, e.email eemail, m.username, m.email memail FROM tableName e INNER JOIN tableName m ON e.manager_id=m.id WHERE e.username='K5700MAV';"

Set rs = objConn.Execute (sqlstr)

if rs.eof then
response.write "Username does not exist. Please access this link from a course."
response.end
else
rs.MoveFirst
While Not rs.EOF
e_name = Server.URLencode(rs.fields("fname") & " " & rs.fields("lname"))
e_email = rs.fields("eemail")
response.write e_name
rs.MoveNext
Wend
end if
objConn.Close
Set objConn = Nothing
%>
Aug 1 '12 #1

✓ answered by iBar

Enabling the "Force SQL_WCHAR Support" in the Oracle ODBC Driver Configuration fixed the issue.

Thanks

Share this Question
Share on Google+
3 Replies


P: 3
Enabling the "Force SQL_WCHAR Support" in the Oracle ODBC Driver Configuration fixed the issue.

Thanks
Aug 1 '12 #2

ariful alam
100+
P: 185
First check at Oracle using query that the Russian characters show perfectly or not. if there those characters not show perfectly, than check the field data type is set to Unicode supported or not. if not fix it. moreover if you used oracle query window to add record, those will also show data like ???. use form/server side web page to insert data.

Hope it works.
Aug 2 '12 #3

P: 3
Hi Ariful,
Thanks. As mentioned in my previous post, this issue is resolved. I had to enable the "Force SQL_WCHAR Support" for the DSN settings.
Aug 2 '12 #4

Post your reply

Sign in to post your reply or Sign up for a free account.