By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,867 Members | 1,964 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,867 IT Pros & Developers. It's quick & easy.

How to fix "Error accessing the database"?

P: n/a
Hello,

I am running IIS7 with SQL 2008 on 64 bit version of Windows Server 2008. I also have a mix of ASP-based web applications served off of this server. Most of these applications in ASP.NET, but 3 of them are still in Classic ASP.
I was able to sucessfully use all of these applications off of my 32 bit Windows XP desktop, but now that I upgraded my desktop to the 64 bit Windows 7, all of a sudden I can no longer access any of the Classic ASP applications. The error I keep getting is "Error accessing the database".
Does anybody know how to fix this issue?

Thank you in advance.
Oct 27 '10 #1
Share this Question
Share on Google+
4 Replies


jhardman
Expert 2.5K+
P: 3,405
Sounds like your db provider isn't working with windows 08. What does your db connection string look like?

Jared
Oct 27 '10 #2

P: n/a
Here is my connection string:

"Provider=SQLOLEDB;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=DATABASENAME;Data Source=SERVERNAME"
Oct 30 '10 #3

P: n/a
I just figured my problem.
The "Error accessing the database" prompt was due to the initial stored procedure that was used to trace and record the IP of the user. This stored procedure was written to expect the IP in the IP4 format (XXX.XXX.XXX.XXX). My new Winodws Vista by default prefers to use IP6 as default. The IP address in IP6 format is a string that is longer than 15 characters. Because the stored procedure was originally written to expect 15 character long IP address, it was failing.
After increasing the length of the IP parameter to 50 characters, I now can access my old applications.
Oct 31 '10 #4

jhardman
Expert 2.5K+
P: 3,405
glad you got it figured out. Thanks for posting your solution.

Jared
Nov 1 '10 #5

Post your reply

Sign in to post your reply or Sign up for a free account.