By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,706 Members | 2,046 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,706 IT Pros & Developers. It's quick & easy.

Web Config IIS 7.0

P: n/a
I am not sure if this is the right forum.

Environment : Windows server 2008, IIS 7.0

I get the 'Could not load the file or assembly 'blowery.web.httpCompress' or
one of its dependencies. The system cannot fond the file specified error.
When I comment out the line in the web config file, I get the error on the
line following that.

I have all the dll files in the bin folder.

I am attaching the web config file.

Is this a permission issue ?

Thanks in advance

<?xml version="1.0"?>
<configuration>
<configSections>
<sectionGroup name="system.web.extensions"
type="System.Web.Configuration.SystemWebExtensions SectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
<sectionGroup name="scripting"
type="System.Web.Configuration.ScriptingSectionGro up, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<section name="scriptResourceHandler"
type="System.Web.Configuration.ScriptingScriptReso urceHandlerSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication"/>
<sectionGroup name="webServices"
type="System.Web.Configuration.ScriptingWebService sSectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
<section name="jsonSerialization"
type="System.Web.Configuration.ScriptingJsonSerial izationSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="Everywhere"/>
<section name="profileService"
type="System.Web.Configuration.ScriptingProfileSer viceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication"/>
<section name="authenticationService"
type="System.Web.Configuration.ScriptingAuthentica tionServiceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication"/>
</sectionGroup>
</sectionGroup>
</sectionGroup>
<sectionGroup name="blowery.web">
<section name="httpCompress"
type="blowery.Web.HttpCompress.SectionHandler, blowery.Web.HttpCompress"/>
</sectionGroup>
<sectionGroup name="applicationSettings"
type="System.Configuration.ApplicationSettingsGrou p, System, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089">
<section name="SMWeb05.Properties.Settings"
type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
</sectionGroup>
</configSections>
<appSettings>
<add key="Login.BruteForceDetection.TriesBeforeBlock" value="10"/>
<add key="Login.BruteForceDetection.BlockTime" value="5"/>
<add key="MailServiceAddress" value="IPC"/>
</appSettings>
<connectionStrings/>
<!-- This adds an http Compression Module to SmarterMail.
see http://www.blowery.org/code/HttpCompressionModule.html for more
info
-->
<blowery.web>
<!--
acceptable values:
<compressionModule preferredAlgorithm="deflate|gzip"
compressionLevel="high|normal|low|none"/>
gzip always uses compressionLevel="normal"
-->
<httpCompress preferredAlgorithm="deflate" compressionLevel="low">
<excludedMimeTypes>
<add type="image/gif"/>
<add type="image/jpg"/>
<add type="image/jpeg"/>
<add type="application/octet-stream"/>
<add type="application/vnd.syncml+xml"/>
</excludedMimeTypes>
<excludedPaths>
<add path="frmReadMail_Attachment.aspx"/>
<add path="WebResource.axd"/>
<add path="frmKeepAlive.aspx"/>
<add path="frmPrintPreview.aspx"/>
</excludedPaths>
</httpCompress>
</blowery.web>
<system.web>
<xhtmlConformance mode="Transitional"/>
<httpModules>
<clear/>
<add name="OutputCache" type="System.Web.Caching.OutputCacheModule"/>
<add name="Session" type="System.Web.SessionState.SessionStateModule"/>
<!-- <add name="FormsAuthentication"
type="System.Web.Security.FormsAuthenticationModul e" />
<add name="RoleManager" type="System.Web.Security.RoleManagerModule" />
<add name="UrlAuthorization"
type="System.Web.Security.UrlAuthorizationModule" />
<add name="FileAuthorization"
type="System.Web.Security.FileAuthorizationModule" />
<add name="AnonymousIdentification"
type="System.Web.Security.AnonymousIdentificationM odule" />
-->
<add name="ErrorHandlerModule"
type="System.Web.Mobile.ErrorHandlerModule, System.Web.Mobile,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="CompressionModule" type="blowery.Web.HttpCompress.HttpModule,
blowery.web.HttpCompress"/>
<add name="RadUploadModule"
type="Telerik.WebControls.RadUploadHttpModule, RadUpload.Net2"/>
</httpModules>
<httpHandlers>
<add verb="*" path="EditorStyleSheetHandler.ashx"
type="SMWeb05.HelperClasses.Handler.EditorStyleShe etHandler"/>
<add verb="*" path="StyleSheet.ashx"
type="SmarterTools.Web.HttpHandlers.CommonCssHandl er, SmarterTools.Web"/>
<add verb="*" path="Javascript.ashx"
type="SmarterTools.Web.HttpHandlers.CommonJSHandle r, SmarterTools.Web"/>
<add verb="*" path="TempResourceHandler.ashx"
type="SmarterTools.Web.HttpHandlers.TempResourceHa ndler, SmarterTools.Web"/>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="*" path="*_AppService.axd" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
type="Telerik.WebControls.RadUploadProgressHandler , RadUpload.Net2"></add>
<add verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
validate="false"/>
</httpHandlers>
<pages validateRequest="false" buffer="true">
<controls>
<add tagPrefix="STWC" namespace="SmarterTools.Web.Controls"
assembly="SmarterTools.Web"/>
<add tagPrefix="SMWC" namespace="SMWeb05.UserControls"
assembly="SMWeb05"/>
<add tagPrefix="UC" namespace="SMWeb05.UserControls" assembly="SMWeb05"/>
<add tagPrefix="asp" namespace="System.Web.UI"
assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
</controls>
</pages>
<compilation debug="false">
<assemblies>
<add assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B77A5C561934E089"/>
</assemblies>
</compilation>
<urlMappings enabled="true">
<add url="~/Main/frmMessagesX.aspx" mappedUrl="~/Main/frmMessages.aspx"/>
<add url="~/Main/frmMessagesAdv.aspx" mappedUrl="~/Main/frmMessages.aspx"/>
</urlMappings>
<authentication mode="Windows"/>
<httpRuntime maxRequestLength="10240"/>
<customErrors mode="Off" defaultRedirect="frmError.aspx"/>
</system.web>
<system.web.extensions>
<scripting>
<scriptResourceHandler enableCompression="false" enableCaching="true"/>
</scripting>
</system.web.extensions>
<!--<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<add name="ScriptModule" preCondition="integratedMode"
type="System.Web.Handlers.ScriptModule, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated" />
<add name="ScriptHandlerFactory" verb="*" path="*.asmx"
preCondition="integratedMode"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*"
path="*_AppService.axd" preCondition="integratedMode"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptResource" preCondition="integratedMode"
verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
</handlers>
</system.webServer>-->
<applicationSettings>
<SMWeb05.Properties.Settings>
<setting name="SMWeb05_ProductInfo_ProductInfo" serializeAs="String">
<value>http://www.smartertools.com/billing/services/ProductInfo.asmx</value>
</setting>
</SMWeb05.Properties.Settings>
</applicationSettings>
</configuration>

Sep 19 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
anon wrote:
I am not sure if this is the right forum.
It's not :-)
There was no way for you to know it (except maybe by browsing through some
of the previous questions in this newsgroup before posting yours - always a
recommended practice) , but this is a classic (COM-based) asp newsgroup.
ASP.Net bears very little resemblance to classic ASP so, while you may be
lucky enough to find a dotnet-knowledgeable person here who can answer your
question, you can eliminate the luck factor by posting your question to a
group where those dotnet-knowledgeable people hang out. I suggest
microsoft.public.dotnet.framework.aspnet or the forums at www.asp.net.
--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Sep 19 '08 #2

P: n/a
Thank you.

"Bob Barrows [MVP]" wrote:
anon wrote:
I am not sure if this is the right forum.
It's not :-)
There was no way for you to know it (except maybe by browsing through some
of the previous questions in this newsgroup before posting yours - always a
recommended practice) , but this is a classic (COM-based) asp newsgroup.
ASP.Net bears very little resemblance to classic ASP so, while you may be
lucky enough to find a dotnet-knowledgeable person here who can answer your
question, you can eliminate the luck factor by posting your question to a
group where those dotnet-knowledgeable people hang out. I suggest
microsoft.public.dotnet.framework.aspnet or the forums at www.asp.net.
--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Sep 19 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.