By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,837 Members | 1,195 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,837 IT Pros & Developers. It's quick & easy.

Decimal value setting problem (ASP & ADODB.Recordset value & MSSQLServer & 2003 Server)

P: n/a
We upgraded our system and problem below occured, pleas help me...

Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)

Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)

Thanks

Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP

Sep 17 '08 #1
Share this Question
Share on Google+
6 Replies


P: n/a
!!! Correction....!!!
in the second state updated value is (12332) ... sory...
On 17 Eylül, 14:25, avcitamer <tta...@gmail.comwrote:
We upgraded our system and problem below occured, pleas help me...

* * Windows 2003 server SP1
* * * * When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)

* * Windows 2003 server SP2
* * * * Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)

Thanks

Systems
* * * * Windows 2003 server Enterprise SP2
* * * * SqlServer 2000 SP4
* * * * Activex Data Object 2.8~
* * * * IIS7, Classsical ASP
Sep 17 '08 #2

P: n/a
avcitamer wrote:
!!! Correction....!!!
in the second state updated value is (12332) ... sory...
On 17 Eylül, 14:25, avcitamer <tta...@gmail.comwrote:
>We upgraded our system and problem below occured, pleas help me...

Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)

Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)

Thanks

Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP
It sounds like a Regional Settings issue. By default, regional settings are
US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
and the SP restored them to default?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Sep 17 '08 #3

P: n/a
How can I cange Regional Settings of the IUSR on windows 2003 server?

On 17 Eylül, 14:41, "Bob Barrows [MVP]" <reb01...@NOyahoo.SPAMcom>
wrote:
avcitamer wrote:
!!! Correction....!!!
in the second state updated value is (12332) ... sory...
On 17 Eylül, 14:25, avcitamer <tta...@gmail.comwrote:
We upgraded our system and problem below occured, pleas help me...
Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)
Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)
Thanks
Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP

It sounds like a Regional Settings issue. *By default, regional settings are
US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
and the SP restored them to default?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"- Alıntıyı gizle -

- Alıntıyı göster -
Sep 17 '08 #4

P: n/a
Never done it myself - I try my best not to write code that is affected
by those settings. You could change the password of the account, log
onto the machine as that account and use the Regional Settings dialog.
But changing the IUSR password can have unwanted consequences, so you
can edit the Registry, HKEY_Users/<IUSR node>/Control
Panel/International

The trick will be to identify the IUSR node ... maybe someone who has
done this can jump in. Or perhaps someone has a script to change the
regional settings of the IUSR account. You can try the .inetserver.iis
group, or the .scripting.vbscript group.

avcitamer wrote:
How can I cange Regional Settings of the IUSR on windows 2003 server?

On 17 Eylül, 14:41, "Bob Barrows [MVP]" <reb01...@NOyahoo.SPAMcom>
wrote:
>avcitamer wrote:
>>!!! Correction....!!!
in the second state updated value is (12332) ... sory...
>>On 17 Eylül, 14:25, avcitamer <tta...@gmail.comwrote:
We upgraded our system and problem below occured, pleas help me...
>>>Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)
>>>Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)
>>>Thanks
>>>Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP

It sounds like a Regional Settings issue. By default, regional
settings are US. Perhaps you had changed the Regional Settings of
the IUSR account to UK, and the SP restored them to default?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so
I don't check it very often. If you must reply off-line, then remove
the "NO SPAM"- Alıntıyı gizle -

- Alıntıyı göster -
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Sep 17 '08 #5

P: n/a
On 17 Eylül, 17:33, "Bob Barrows [MVP]" <reb01...@NOyahoo.SPAMcom>
wrote:
Never done it myself - I try my best not to write code that is affected
by those settings. You could change the password of the account, log
onto the machine as that account and use the Regional Settings dialog.
But changing the IUSR password can have unwanted consequences, so you
can edit the Registry, HKEY_Users/<IUSR node>/Control
Panel/International

The trick will be to identify the IUSR node ... maybe someone who has
done this can jump in. Or perhaps someone has a script to change the
regional settings of the IUSR account. You can try the .inetserver.iis
group, or the .scripting.vbscript group.

avcitamer wrote:
How can I cange Regional Settings of the IUSR on windows 2003 server?
On 17 Eylül, 14:41, "Bob Barrows [MVP]" <reb01...@NOyahoo.SPAMcom>
wrote:
avcitamer wrote:
!!! Correction....!!!
in the second state updated value is (12332) ... sory...
>On 17 Eylül, 14:25, avcitamer <tta...@gmail.comwrote:
We upgraded our system and problem below occured, pleas help me...
>>Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)
>>Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)
>>Thanks
>>Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP
It sounds like a Regional Settings issue. By default, regional
settings are US. Perhaps you had changed the Regional Settings of
the IUSR account to UK, and the SP restored them to default?
--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so
I don't check it very often. If you must reply off-line, then remove
the "NO SPAM"- Alýntýyý gizle -
- Alýntýyý göster -

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.- Alıntıyı gizle -

- Alıntıyı göster -
i solved it by the helps of you.

I checked the checkbox as shown below. It solved...
Regional Settings-->Advenced-->Default User Account Settings--
>[x]Apply all settings to then current user account to the default
user profile.

thanks alot.
Sep 18 '08 #6

P: n/a
avcitamer wrote:
On 17 Eylül, 17:33, "Bob Barrows [MVP]" <reb01...@NOyahoo.SPAMcom>
wrote:
>Never done it myself - I try my best not to write code that is
affected by those settings. You could change the password of the
account, log onto the machine as that account and use the Regional
Settings dialog. But changing the IUSR password can have unwanted
consequences, so you can edit the Registry, HKEY_Users/<IUSR
node>/Control Panel/International

The trick will be to identify the IUSR node ... maybe someone who has
done this can jump in. Or perhaps someone has a script to change the
regional settings of the IUSR account. You can try the
.inetserver.iis group, or the .scripting.vbscript group.

i solved it by the helps of you.

I checked the checkbox as shown below. It solved...
Regional Settings-->Advenced-->Default User Account Settings--
>[x]Apply all settings to then current user account to the default
user profile.

thanks alot.
Good to know - thanks for the follow-up.

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Sep 18 '08 #7

This discussion thread is closed

Replies have been disabled for this discussion.