469,908 Members | 2,069 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,908 developers. It's quick & easy.

ASP.NET 2.0 Gridview - Output on a Blackberry 8700/8800

2
Hi there,

I've been trying to display a simple grid on a web page in a Blackberry.
I've used a gridview control which is populated from a database query,
using ASP.NET 2.0.
The target platform is a 8700v (Vodafone model). The issue also occurs on the 8800.



I've downloaded the 8700c (Cingular model) which is the closest I can find.
After much frustration and googling I've constructed a Blackberry.Browser file, which with a page including Response.Writes of Browser Capabilities seems to be working with identical results on the Simulator and the Vodafone.

The problem is the table will not display on the Vodafone. The output is fine on the simulator. On the vodafone, the numbers are on three lines separated with single spaces.

I am reluctant to "patch" the vodafone, as it represents the entry level for an unknown number of Blackberries in our organisation.

My Capability list is as follows:

<capability name="browser" value="BlackBerry" />
<capability name="isMobileDevice" value="true" />
<capability name="javascript" value="true" />
<capability name="ecmascriptversion" value="1.3" />
<capability name="version" value="${version}" />
<capability name="majorVersion" value="${major}" />
<capability name="minorVersion" value="${minor}" />
<capability name="supportsCss" value="true" />
<capability name="frames" value="true" />
<capability name="cookies" value="true" />
<capability name="tables" value="true" />
<capability name="HTMLTextWriter" value="true" />
<capability name="RequiresLeadingPageBreak" value="true" />

The User Agents are identical apart from the Vendor:
BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/120
(120 - Vodafone)

Am I missing something here, or is patching the only way forward?

Any assistance greatly appreciated.

Jim
Feb 14 '08 #1
1 2635
RedSon
5,000 Expert 4TB
Moved....anyone have any idea how to help in this forum? ...maybe this needs to be in .NET?
Feb 15 '08 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Chumley Walrus | last post: by
1 post views Thread by John Cosmas | last post: by
reply views Thread by Bazza Formez | last post: by
1 post views Thread by Huseyin Altun | last post: by
6 posts views Thread by E-Lo | last post: by
1 post views Thread by =?Utf-8?B?TWVs?= | last post: by
1 post views Thread by Waqarahmed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.