469,621 Members | 1,685 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,621 developers. It's quick & easy.

Saving Classic ASP in UTF-8 Format

I have classic asp files (IIS6) that need to be saved in UTF-8 format. I
save a file with Notepad using SAVE-AS & UTF-8 format. If I reopen the file
using Notepad and bring up the save-as dialog is defaults to UTF-8, which is
good. But after the file is modified and saved using Visual Interdev the
format switches back to ANSI format, which causes some international
characters to display as little boxes in the browser. I found one comment on
the internet about making sure the Meta tag with Charset=UTF-8 must be in the
file to instruct interdev to use the UTF-8 format when saving. This seems to
work on some .asp files but not all.

Any suggestions would be appreciated.

Thank You

--
Robert Hill
Aug 3 '07 #1
2 7722
=?Utf-8?B?Um9iZXJ0SGlsbEVEUw==?= wrote on 03 aug 2007 in
microsoft.public.inetserver.asp.general:
I have classic asp files (IIS6) that need to be saved in UTF-8 format.
I save a file with Notepad using SAVE-AS & UTF-8 format. If I reopen
the file using Notepad and bring up the save-as dialog is defaults to
UTF-8, which is good. But after the file is modified and saved using
Visual Interdev the format switches back to ANSI format, which causes
some international characters to display as little boxes in the
browser.

Any suggestions would be appreciated.
Don't use Visual Interdev, I don't.
I found one comment on the internet about making sure the
Meta tag with Charset=UTF-8 must be in the file to instruct interdev
to use the UTF-8 format when saving. This seems to work on some .asp
files but not all.
I would not know about this.

--
Evertjan.
The Netherlands.
(Please change the x'es to dots in my emailaddress)
Aug 3 '07 #2
"RobertHillEDS" <rw****@nospam.nospamwrote in message
news:E6**********************************@microsof t.com...
I have classic asp files (IIS6) that need to be saved in UTF-8 format. I
save a file with Notepad using SAVE-AS & UTF-8 format. If I reopen the
file
using Notepad and bring up the save-as dialog is defaults to UTF-8, which
is
good. But after the file is modified and saved using Visual Interdev the
format switches back to ANSI format, which causes some international
characters to display as little boxes in the browser. I found one comment
on
the internet about making sure the Meta tag with Charset=UTF-8 must be in
the
file to instruct interdev to use the UTF-8 format when saving. This seems
to
work on some .asp files but not all.

Any suggestions would be appreciated.
You should also have:-

<%@ codepage=65001 %>

at the top of your page.
--
Anthony Jones - MVP ASP/ASP.NET
Aug 3 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

19 posts views Thread by Svennglenn | last post: by
7 posts views Thread by Philipp Lenssen | last post: by
8 posts views Thread by Bill44077 | last post: by
2 posts views Thread by MartyNg | last post: by
4 posts views Thread by =?Utf-8?B?Q2FybGluIEFuZGVyc29u?= | last post: by
reply views Thread by devrayhaan | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.